Tos 3.10.3 - wifi mtu settings neglected


#1

I am trying to change the mtu of the wifi cards but haven’t found the knob to turn.

What is confusing is that in /etc/config/wireless they are named as radio0 and and radio1 respectively but from cli ip l show up are dislayed as wlan0 and wlan1 respectively.

adding option mtu in etc/config/wireless does nothing and neither is adding the below to /etc/config/network

config interface 'wlan0'
	option mtu '2000'
	option ifname 'wlan0'
	option proto 'none'

config interface 'wlan1'
	option mtu '2000'
	option ifname 'wlan1'
	option proto 'none'

No option apparent in Foris or LuCI.

Apprecaite some pointer of how to change the mtu for the wifi cards.


#2

Uh, I might be interested why you think a MTU > 1500 is a good idea (in your case).


#3

Apprciate the curiosity but do not wish to turn this thread into a discussion of why/pro/con mtu settings but simply would like to know how to change the mtu for the wifi cards.


Anyway, to answer your question - I like to test/experiment. On other systems I raised the mtu of ifaces to 9000 and

which works pretty well since not being reliant on imcp path mtu, or at the last resort.

Now as for the TO

but since the

its mtu is being dragged down as soon as the wifi cards with mtu 1500 are being enslaved.


#4

https://www.mail-archive.com/openwrt-devel@lists.openwrt.org/msg41851.html

The wireless config section is kinda only up to layer 1.5, so
everything on netdev level has to be done in the network UCI config.
Example:

config interface 'wireless0'
        option proto 'none'
        option mtu '1536'

Since this is not working in TOS it appears to be a bug


(br-)lan mtu setting neglected
#5