TO 5.0.2 in HBK - Package LuCI is not available

I report two mistakes in TO MOX 5.0.2 HBK… tonight

st 17. 6. 2020 0:01

Oznámení o chybách

Updater selhal: Called uri_path on URI of scheme: https

st 17. 6. 2020 5:25

Oznámení o chybách

Updater selhal:

inconsistent: Requested package luci that is not available.

1 Like


Thank you for reporting it to us. I can confirm that LuCI package was not compiled for any of our routers.
It failed with following output:

make[2]: execvp: /usr/bin/env: Argument list too long

It seems that it should be fixed by following patch, but it was not reviewed in OpenWrt since February.

I’m going to apply it to see if it works. If yes, I will add my Tested-by, there and hopefully it will speed it up.

Thanks Pepe. I have the same luci package error. Looking forward to the fix.

I suppose there is no workaround for this correct?

If you don’t need LuCI for some time, you might want to remove it. There’s also another and better possibility as you are using development branch, where occasional bugs might appear like this one and you don’t want it then you should consider to use Stable or Testing branch. Just take a look at switch-branch utility, which is installed on your router.

To be honest didnt know Ive development branch :wink: So will switch for time being. Need to get TO on v 5 to play with MOX power wifi and mesh

LuCI should be there for all routers in every development branches, which we have.

And what is the correct way of printing the current branch, e.g. using switch-branch or another command?
I can think of one way to detect the current branch is by running “opkg update” and inspecting the repository URLs which would contain the branch name. But don’t think that’s the case on Turris OS 3.x though.

btw even after switch to stable branch still the same error message about missing LuCI

There are many ways how you can check the current branch. There is uci show updater (= /etc/config/updater), switch-branch. If you don’t like CLI, then in (re)Foris in the About tab, you can find it.

1 Like

In the stable branch, there wasn’t such error in the past and it is not present there for sure. It is neither present in the testing branch.

This happened in HBK,HBL and HBD branches, which are developement branches, but it was fixed 2 days ago within one day and since then it is there. Can you please show us the notification or output from pkgupdate?

Strange. Exactly same commands but today it worked. Automatic reboot after just couple minutes and v5 installed. Initially without LXC containers but quickly appeared in Luci again.

So now I can finally start to play with mesh.