Testing rescue mode 4

MOX classic.

I wanted to test rescue mode 4, to see if I would be able, in case of any troubles, easily return to previous working state of OS. Therefore I exported schnapps of such working state of OS to root directory of USB flash drive (and renamed it to mox-medkit-latest.tar.gz - at first as link to exported schnapps stored in another directory, later as one stored directly in root USB directory). Unfortunately, neither of this two possibilities worked, even after repeated attempts (repeated for case when exported schnapps was stored directly in USB root directory).

I always waited for about half an hour to allow to complete the procedure after selecting rescue mode 4; MOX never did reboot ourselves as stated in documentation (maybe because of pertaining MOX reboot problem). After powering it off/on it rebooted in current state of OS (5.3.11 HBK).

Maybe I didn’t understand the documentation well or made some error during test procedure.

I suppose that while trying rescue mode 4, the procedure ignored mox-medkit-latest.tar.gz in USB root directory and used this in micro SD card… Is there any means to select between these? Or it is needed to rewrite mox-medkit-latest.tar.gz in micro SD card? and how to do it (in place, without removing it from MOX and do it in another Linux machine), if it is the case?

TIA for any hints/advice.

Rescue systems are pretty same on both MOX and Omnia. They search for the tarball with the right name both in MicroSD card and on external USB drive. MicroSD card is there as an option to support scenario when you for some reason don’t have Linux machine at hand (maybe fixing stuff from your tablet?) and you have SD card with FAT32, you just download medkit on it, tell MOX to reflash itself and it will convert the SD card to Btrfs and deploy tarball there.

It searches only root partitions of every device tried. If you have tarball in root of your SD card, it might prefer it, but if you have just fully working system there, it should ignore it (unless there is a tarball).

Thanks @miska for weighting in.

Of course the procedure for MOX and Turris should be the same. I used MOX, for time being it is my spare (and experimental :wink: ) device.

I’d like to fully understand whats going on. Is there any priority between external USB and MicroSD card? This is not clear.

Anyhow, how could one access MicroSD card - which device it is? Sorry being so noob - I was’nt able to find how :frowning:

Suppose following scenario: there is tarball in root of external USB flash, either as link to file in another directory on USB (which, IMHO, as to Linux filesystem should be enough/equal to file stored directly in root of USB), or file as such (i.e. copy of file in another directory) in root of USB - is this tarball acted upon or is it ignored because of MicroSD? (I don’t understand what exactly is stored on this MicroSD and how to acces it :-). Is it enough or should tarball info file be present there, like in schnapps import operation?

USB external flash is mounted as (part of df command)

/dev/sda 30277632 241516 29511892 1% /srv

and snapshots are stored on it as for example (part of ls -l command)

drwxr-xr-x 1 root root 130 May 31 22:02 2022-05-31.18-35


-rw-r–r-- 1 root root 78 May 31 18:35 33.txt
-rw-r–r-- 1 root root 28 May 31 18:35 33_5.3.10
-rw-r–r-- 1 root root 89 May 31 18:39 mox-medkit-MOXjp-33.info
-rw-r–r-- 1 root root 55802987 May 31 18:39 mox-medkit-MOXjp-33.tar.gz

where contents of those text files is (text files were added by myself to distinguish among different versions)

33 | time | 16.00KiB | 2022-05-31 18:35:02 +0200 | Created by SaveLastSchn.sh

VERSION: 5.3.10 BRANCH: hbk

DESCRIPTION=“Created by SaveLastSchn.sh”
CREATED=“2022-05-31 18:35:02 +0200”

Tarballs were in USB root directory, either as copy of files in above directory /srv/SCH/2022-05-31.18-35 (2nd scenario)

-rw-r–r-- 1 root root 55802987 Jul 17 17:07 /srv/mox-medkit-latest.tar.gz

or as links to files in above directory (1st scenario)

lrwxrwxrwx 1 root root 52 Jul 18 19:57 /srv/mox-medkit-latest.tar.gz → /srv/SCH/2022-05-31.18-35/mox-medkit-MOXjp-33.tar.gz

After trying rescue mode 4 in above descripted scenarios, MOX rebooted (forced by power off/on after about 30 minutes) in current version of OS, i.e. 5.3.11, while saved schnapps was for version 5.3.10.

Could you please explain? Please don’t take me as being difficult, I only want to understand the procedure in details. TIA.

either use a linux computer OR use tools that make windows able to read these file systems (for example “linux file system for windows” by paragon software)

as I understand it, the mox will ignore the usb stick in rescue mode 4 if a working OS is found on sd card, which is checked first, afaik.

I’d like to access MicroSD in place, without dismounting it from MOX (or Omnia) and search it in another machine.

As to ignoring USB, it seems so… This is reason why I’d like to access MicroSD to be able to change this behavior…

After rereading documentation of Rescue (MOX - Turris Documentation) and Schnapps (Schnapps - Turris Documentation) more thoroughly, and thanks to comments of @miska and @n8mahr, I realized that for easy return to previous working state of OS, in case of some troubles, would be to use rollback feature of schnapps… (and tested it :wink: ). Moreover I learned that actual version of OS, stored on MicroSD card, is accessible on /dev/mmcblk1p1.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.