Supported SFP modules

@bugrasan it works, I think, since v3.*. Do not forget to enable SFP: https://docs.turris.cz/geek/tos3-migration/#turris-omnia-specifics

Current info:
TurrisOS 5.1.4

[   13.852045] libphy: SFP I2C Bus: probed
[   14.191151] sfp sfp: module TP-LINK          TL-SM321B        rev 1.1  sn 35506106580385   dc 17-06-15
[   14.200547] sfp sfp:   LC connector, encoding 8b10b, nominal bitrate 1.3Gbps +0% -0%
[   14.208333] sfp sfp:   1000BaseSX- 1000BaseLX+ 1000BaseCX- 1000BaseT- 100BaseTLX- 1000BaseFX- BaseBX10- BasePX-
[   14.218465] sfp sfp:   10GBaseSR- 10GBaseLR- 10GBaseLRM- 10GBaseER-
[   14.224761] sfp sfp:   Wavelength 1310nm, fiber lengths:
[   14.230091] sfp sfp:     9µm SM    : 20000m
[   14.234384] sfp sfp:  62.5µm MM OM1: unsupported/unspecified
[   14.240152] sfp sfp:    50µm MM OM2: unsupported/unspecified
[   14.245928] sfp sfp:    50µm MM OM3: unsupported/unspecified
[   14.251704] sfp sfp:    50µm MM OM4: unsupported/unspecified
[   14.257473] sfp sfp:   Options: txdisable, txfault, los+
[   14.262813] sfp sfp:   Diagnostics: 
1 Like

@yorik thank you! I just received mine (TP-LINK TL-SM321B) today, and works flawless :smiley:

I also updated the Supported SFP modules accordingly.

I am also interested in finding a way to make my fiber work with a compatible SFP. Are you on fiber or xDSL? Did you have to configure the SFP module? Unfortunately the form provided by my ISP is not compatible with Omnia.

@lucenera i have fiber. as @yorik mentioned you need to manually switch to sfp. then the SFP module is on eth2 on TOS v4 & v5 (on TOS v3 it was eth1). additionally since i’m with Sunrise in Switzerland i needed to set the VLAN to 10; meaning WAN is on eth2.10. i didn’t do any reprogramming/patching of the SFP module it self - luckily.

Thanks for the reply. I know all the part concerning the configuration of the VLAN on 4.x and later, and in addition my new Omnia (revision 2020) has the automatic switch on startup without the need to manually set it between WAN and SFP cage. The problem remains only the incompatible module. What connection does that TP-Link module mount? Mine is an SC connector.
Maybe my ISP expects a certain MAC address as well, but I don’t even know where to start to change that. However if the connector is SC, I would still like to do a test.

@lucenera it is LC-Simplex

TP-LINK TL-SM321B has only single LC connection.

Also I had to contact my ISP Init7, and they (as far as I understand) had to set speed instead of auto negotiation. For some reason auto negotiation doesn’t (didn’t?) work in Omnia. But no VLAN is needed in my case.

1 Like

I’ve added another working module in the supported sfp list: Technicolor AFM0002. Tested on HBD 6.x.

That’s a good news when more SFP are supported. I’m still struggling to get my TRENDnet TE100-MGBS20 working.

Currently the Technicolor AFM0002 SFP module also works on Turris OS 5.2.3 and above.

To be precise. Its needed on Omnias with 5.x+ software but hardware revision before 2020. It’s related to the default U-Boot shipped with the device. Your Omnia from 2020 just have newer U-Boot and manual switching is not needed. Supposely the U-Boot versions will be unified and updated on all hardware revisions. When? I guess when it’s ready:D We have to wait for the @turris_team to release it.

However, if you are interested, you can update both the bootloader and the recovery on mtd0 and mtd1 respectively by installing the turris-nor-update package and running the nor-update command. Turris OS will check the versions installed on the device and the latest ones available and, if the check is not passed, it will write the latest images available, downloading them from the internet.
And I tell you that even with the last U-Boot I had to use the command ln -sf armada-385-turris-omnia-sfp.dtb /boot/dtb after my Omnia magically no longer saw the SFP module (Turris OS 5.2.3 and U-Boot 2019.07).

1 Like

i have the same issue with the latest uboot version still need to put the command for the SFP . Maybe need the uboot enviroment configuration

joining the select group of wan via sfp omnia operators - gpon via Technicolor AFM0002 module (thanks to @lucenera for documenting it)
connected via telnet/ssh to 192.168.2.1 (you need to add secondary ip ifconfig eth2:0 192.168.2.2 netmask 255.255.255.0) ssh u/p admin/system, telnet no u/p then via diag menu I’ve changed the S/N to my ZTE OLT’s one and after omnia reboot it automagically started pppoe

1 Like

Joining the SFP group as well - GPON FS GSFP-43-20B.

I am uncertain how to get the device to use the SFP port for WAN. Someone mentioned running an “SFP to WAN” command, but did not provide the command itself. Can anyone offer me some guidance here?

Would love to keep using this router, but if I can’t get the SFP port working I think I may be out of luck with my new ISP - their gateway refuses to be bridged.

Thanks in advance!

Hello, is the device detected by the router?
Can you please plug it in and send us the output of dmesg command?

The router is refusing to let me log in via SSH.

First I had to dump the old ECDSA key stored by my computer, now it’s giving me this message:

root@192.168.1.1's password:
channel 0: open failed: connect failed: open failed
stdio forwarding failed
kex_exchange_identification: Connection closed by remote host
Connection closed by UNKNOWN port 65535

I’m at a loss what to do here…

Do you run the minipot service? Are you able to log in through the web?

I used to, but gave the router a full factory reset,

I can log into the web interface (Foris 100.5) normally.

Hello!

Here is my experience:
Visual Online (Luxembourg ISP) installed a FTTH service with TP-Link MC220L which has a SBU35020GE0B / SFP / 1000Base-BXU .

Reboot, and the inbuilt netmetr confirms that everything works as expected:

Measurement detail

Download 605.314 Mb/s
Upload 322.000 Mb/s

Here is the log:

root@turris:~# dmesg | grep sfp
[ 12.805078] sfp sfp: module Skylane Optics SBU35020GE0B493 rev A sn 2AF2B10171 dc 30-04-21
[ 12.814422] sfp sfp: LC connector, encoding 8b10b, nominal bitrate 1.3Gbps +0% -0%
[ 12.822234] sfp sfp: 1000BaseSX- 1000BaseLX+ 1000BaseCX- 1000BaseT- 100BaseTLX- 1000BaseFX- BaseBX10- BasePX-
[ 12.832350] sfp sfp: 10GBaseSR- 10GBaseLR- 10GBaseLRM- 10GBaseER-
[ 12.838631] sfp sfp: Wavelength 1310nm, fiber lengths:
[ 12.843959] sfp sfp: 9µm SM : 20000m
[ 12.848237] sfp sfp: 62.5µm MM OM1: unsupported/unspecified
[ 12.853998] sfp sfp: 50µm MM OM2: unsupported/unspecified
[ 12.859756] sfp sfp: 50µm MM OM3: unsupported/unspecified
[ 12.865518] sfp sfp: 50µm MM OM4: unsupported/unspecified
[ 12.871278] sfp sfp: Options: txdisable, txfault, los+
[ 12.876605] sfp sfp: Diagnostics: ddm, intcal, rxpwravg

root@turris:~# cat /etc/openwrt_*
DISTRIB_ID=‘TurrisOS’
DISTRIB_RELEASE=‘5.3.0’
DISTRIB_REVISION=‘r11382+91-5e8b9624f1’
DISTRIB_TARGET=‘mvebu/cortexa9’
DISTRIB_ARCH=‘arm_cortex-a9_vfpv3-d16’
DISTRIB_DESCRIPTION=‘TurrisOS 5.3.0 5e8b9624f1791d193e8d5e007ce4c873454f014a’
DISTRIB_TAINTS=‘busybox’
5e8b9624f1791d193e8d5e007ce4c873454f014a

root@turris:~# cat /etc/os-release
NAME=“TurrisOS”
VERSION=“5.3.0”
ID=“turrisos”
ID_LIKE=“lede openwrt”
PRETTY_NAME=“TurrisOS 5.3.0”
VERSION_ID=“5.3.0”
HOME_URL=“https://www.turris.cz/
BUG_URL=“Issues · Turris · GitLab
SUPPORT_URL=“https://www.turris.cz/support/
BUILD_ID=“r11382+91-5e8b9624f1”
OPENWRT_BOARD=“mvebu/cortexa9”
OPENWRT_ARCH=“arm_cortex-a9_vfpv3-d16”
OPENWRT_TAINTS=“busybox”
OPENWRT_DEVICE_MANUFACTURER=“CZ.NIC”
OPENWRT_DEVICE_MANUFACTURER_URL=“https://www.turris.cz/
OPENWRT_DEVICE_PRODUCT=“Turris Omnia”
OPENWRT_DEVICE_REVISION=“v0”
OPENWRT_RELEASE=“TurrisOS 5.3.0 5e8b9624f1791d193e8d5e007ce4c873454f014a”