Support for Quectel EP06 LTE-A?

I updated to stable branch and I am on 3.11 - Please see attached. With the current mini-pci card (screenshot named current) I can see/select USB2 and configure the card to make a successful connection to the internet. When I power down and swap the cards, installing the EP06-A (screenshot named EP06-A) I do not have the same choices for the interface and I do not remember the commands in SSH to enumerate the devices the system sees, What do I need to do from here? Thanks, please advise.

Pepe: What about my latest attempts? Do you have any ideas or solutions?

Have you taped PCI-e pins as it was described here - Quectel EP06 configuration?

Is there anything in lspci or lsusb? Screenshots from LuCI for this issue are not helpful. Only what I can see, there is that you don’t have there /dev/ttyUSB0-3, but it doesn’t say why.

Hi,
I recently got my parents a Quectel EP06-A for Christmas. If you need and there is some instructions on how to compile and load a Turris kernel, I can look into putting my hard hat on!

I do not think it is a good idea to tape the pins. Specifically, the pins the user taped on another forum are the USB 3.0 tx/rx pins, so taping them will likely result in USB 2.x speeds.

Moreover, I think the one-line kernel modification suggested is wrong and should be reverted. In addition, some code to dynamically configure the Quectel interface should be added per this commit below:

Can the Turris team please apply the above patch?

I believe these two patches will also be necessary:


Support for Quectel EP06 wasn’t backported to LTS kernel 4.4 as you can see here.
However, the one line patch was backported to LTS kernel 4.9, and also for LTS kernel 4.14.

Right now for Turris 1.x and Turris Omnia, we’re using LTS kernel 4.4, which is supported until February 2022.
With Turris OS 4.0, we’re using LTS kernel 4.14, which is supported until January 2020. In a few months ago, we have released Turris OS 4.0 for Turris Omnia and Turris 1.x in early alpha state.

And looking about commit: USB: serial: option: improve Quectel EP06 detection, it was backported just to LTS kernel 4.14. So, with Turris OS 4.0 it should be better.

I’d like to know, if it works now before making any changes and all these commits are made from the same author.

I do not think it is a good idea to tape the pins. Specifically, the pins the user taped on another forum are the USB 3.0 tx/rx pins, so taping them will likely result in USB 2.x speeds.

This one is a little bit complicated. You can look for example here:
https://techship.com/faq/sierra-wireless-mc74-series-module-is-not-detected-by-the-operating-system/

Some LTE modems are not detected by hardware, if pins are not tapped as it avoids pin incompatibility between PCIe data interface lines and the USB3 lines. For some users it can be enough to use USB 2.0 speeds, however, if you’d like to use USB 3 speed, you would need to have an adapter and plug it to the front or back USB 3.0 port.

1 Like

Pepe,

Thanks for your quick and informative response! Glad to see all the commits will land in Turris OS 4.0!

I see your comments about the taping. I think I will wait for Turris OS 4.0 before resorting to the taping and further testing, even though waiting may be in vain. I am not skilled at doing this and weary about the tape getting stuck in the mPCI-e slot and damaging my Omnia device.

I can try Turris OS 4.0 alpha sometime soon to see if it works without modification if you could kindly provide some instructions or location of current Turris OS 3.x image (so I can rollback from 4.0 alpha after testing…).

Thank you to all who are interested and willing to further this effort. I would very much like to leverage the EP06. I want to be able to use mine as well, and I will assist this effort in any way I can.

Turris repo files https://repo.turris.cz/

TOS branches workflow https://gitlab.labs.nic.cz/turris/turris-build/blob/master/WORKFLOW.asciidoc

My workflow for switching between current 3.x and testing 4.x

  1. from current 3.x stable last good known schnapps create
  2. then export that snapshot with schnapps export (takes a few moments to complete, preferably choose a saving path to external drive)
  3. download the generate files (*.tar.gz | *info) from router via ssh to local client
  4. download medkit for TOS4.branch for the Turris repo
  5. reset the router with the medkit from the TOS4.branch
  6. after testing the TOS4.branch completed and a rollback to the 3.x is desired there are 2 ways to go about:
  • upload exported snapshot files for 3.x (*.tar.gz | *.info) via ssh from local client to the router and import via schnapps import and then rollback to the imported snapshot, or (my preference)
  • router medkit reset with the snapshot medkit file created from the 3.x last last good known

This way safely switching between 3.x and 4.x takes usually less than 10 minutes and it saves a setup from scratch for the 3.x


NOTE: schnapps export requires the tar package being installed, which is not by default Cannot export shnapps snapshot

1 Like

Sorry for not posting in so long.

Today, I installed Turris OS 4.0. After taping off the USB3 pins on the Quactel EP06 modem, the QMI interface registered as a USB device:

root@turris:~# lsusb
...
Bus 001 Device 002: ID 2c7c:0306 Quectel Wireless Solutions Co., Ltd. EG06/EP06/EM06 LTE-A modem
...

I then installed the opkgs kmod-usb-net-qmi-wwan, luci-proto-qmi, and uqmi.

A /dev/cdc-wdm0 device node appeared after installing the qmi-wwan kmod.

I then ran uqmi and was able to query the device, so it appears to be working!

root@turris:~# uqmi -d /dev/cdc-wdm0 --get-capabilities
{
	"max_tx_channel_rate": 50000000,
	"max_rx_channel_rate": 100000000,
	"data_service": "non_simultaneous_cs_ps",
	"sim": "supported",
	"networks": [
		"umts",
		"lte"
	]
}

Thank you VERY much for sharing this! I really appreciate you taking the time to detail this info. Were you able to make a connection with a carrier? May I ask how and where you taped the pins? A photo or two, if possible, would be even better! Thanks again, and I hope I can call on you if I need to. My EP-06 has been collecting dust, and the EC20 I am using cannot leverage LTE-A speeds.

Taping the pins was a pain in the rear, so I don’t want to take the modem out of the socket!

Look at page “14/53” of the following PDF:

With the modem pins facing you and the shorter set of pins to the left, you will see something like the below (assume the notch is __ and the pins are X or dots. You tape the pins with dots (4 total, 2 groups of 2).

XXXXXXXX____XXX..XX..XXXXXXXXX

I have not yet installed a SIM card, so I cannot verify that it works with the carriers. I plan on using it with Verizon in the coming months, though.

1 Like

Thanks again! Can I please ask what you taped them with and how you went about it?

I used frog tape (painters tape). Just cut it to size and plaster it on the right pins. You can also use scotch tape, but I found it was annoyingly hard to manage a piece small enough so that only two pins are covered.

Be sure to have a magnifying glass handy unless you have some very good eyes :slight_smile:

So, after many months of waiting, I have some good and bad news. I got a SIM card and was finally ready to set up my Omnia for use on Verizon’s network…

Good news: Once the pins are taped off as prescribed above, the EP06-A likely works great in QMI mode out of the box in Turris Omnia 4.0 beta1. So thank you all of you here for your support.

Bad news: Wait, why did he say likely!? Well, I say likely because while you can swizzle and swirl the modem from the OS (via uqmi), the modem itself looks seriously botched – it won’t register itself on Verizon’s network. I spent probably my entire weekend learning the Hayes’ AT command language and poked and prodded at the modem 20 different ways via /dev/ttyUSB2 (playing with bands, LTE modes, forcing manual registration, improving signal strength,etc…). It just simply won’t register on Verizon’s network. I also tried popping my T-Mobile SIM in, but T-Mobile wasn’t even been seen in the operator list in respond to a COPS? command.

Now – I’m a very, very technical person, but it always could be me messing something up since this is my first time… but I really don’t think so at this point. I think the EP06-A is just a bad lemon. I noticed that while their “tech spec” document has Verizon certification pending (as denoted by the asterisk!)… Verizon still does not acknowledge the modem as of today. At the same time, however, Verizon does support older Quectel modems and a range of other manufacturer’s recent LTE-A and LTE-A Pro modems. So it’s kinda fuel to the fire for me. I e-mailed Quectel support with some diagnosis I did, so we’ll see.

Anyways, I’m really not optimistic that this modem will work on the Verizon network, so I broke open the piggy bank and ordered a Telit LM-940 (mPCI-e) card. It’s a LTE-A Pro Cat11 modem that Verizon has already certified. Supposedly only requires >= kernel 4.10, and Turris Omnia 4.0 beta1 is based on 4.14. We’ll find out this weekend. :stuck_out_tongue_winking_eye: I can open a new thread for the LM-940 if desired.

Thank you for all of your hard work on this, as well as sharing the details of what you discovered. Both are greatly appreciated! Please do keep us updated on your findings with the new modem. If it works, I am definitely getting one, especially if it does not require pins to be taped!

No problem. I do imagine the pins will have to be taped, unfortunately. And this time, instead of being in sets of 2 pins, they are 1-off pins… will require the taping to be more precise. :frowning:

I am typing this forum post from a connection going through the EP06-A! :slight_smile:

Quectel gave me a firmware update dated 2019/05/09. The changelog for the update references several things for Verizon/Verizon certification. Once I applied it, the modem fired right up over a QMI connection.

root@turris:~# uqmi -d /dev/cdc-wdm0 --get-signal-info
{
	"type": "lte",
	"rssi": -63,
	"rsrq": -10,
	"rsrp": -91,
	"snr": 88
}
1 Like

I’m not sure what performance people are getting with the EC20, but in the suburb I am testing from, the EP06-A yields about 55-65ms pings consistently on beta.speedtest.net with download speeds of 22-25mbps and uploads of 11-12mbps.

Signal info right now:

root@turris:~# uqmi -d/dev/cdc-wdm0  --get-signal-info
{
	"type": "lte",
	"rssi": -62,
	"rsrq": -14,
	"rsrp": -94,
	"snr": 32
}

This is excellent news indeed! Could I please get a copy of that firmware? robroy90 at gmail dot com.