Správné nastavení DNS a nepřipojení některých zařízení

dns

#22

Tohle mam v/etc/config/network
config interface 'lan’
option ifname 'eth0 eth1’
option force_link '1’
option type 'bridge’
option proto 'static’
option ipaddr '192.168.1.1’
option netmask '255.255.255.0’
option ip6assign ‘60’

config interface 'wan’
option ifname 'eth2’
option proto ‘dhcp’


#23

A v LuCi máš to získávání DNS operátora vypnuté? A restartoval jsi router po této změně?


#24

Tak na druhy pokus a restartu (ten jsem poprve neudelal) to vypada, ze konecne to funguje :slight_smile: I v /etc/config/network se uz dns objevily. Dekuju za navedeni.
config interface 'wan’
option ifname 'eth2’
option proto 'dhcp’
option peerdns '0’
option dns ‘217.31.204.130 193.29.206.206 8.8.8.8 8.8.4.4’


#25

Takže ve finále mi došla trpělivost. Skončil jsem u původního peer DNS, zapnutém forwardingu a vypnutém DNSSEC. Zajímavé je, že test mi píše DNSSEC…OK.
Jak máte DNS u připojení přes UPC nastaveno vy?


#26

Vypnuté peerDNS (UPC dnska nepodporují DNSSEC) a nastaveny ručně OpenDNS od CZ.NIC a Google


#27

Přesně tak jsem to měl, po nastavení to fungovalo. A po nějaké době se hrozivě prodlužovala odezva u některých webů. A některé se načtou až na pátý pokus…
Při zapnutém peerDNS a vypnutém DNSSEC vše funguje OK. A dokonce i test DNSSEC proběhne v pořádku, i když je DNSSEC vypnuté. Podivné…


#28

Ne nutně podivné. Pokud se forwarduje na server který validuje a nepropustí domény které se nezvalidují, tak bude i bez lokální validace situace typicky vypadat jako zabezpečena DNSSEC…


#29

No to je hezké, ale co s tím mým problémem…