[SOLVED] Updater.sh does not finish, just hangs

The updater hangs and will not continue. Rolling back to two days ago results in the same “error”. This is the latest output:

  • /etc/init.d/lighttpd restart
    Output from foris-diagnostics-plugin-l10n-de.postinst:
  • [ -n ]
  • /etc/init.d/lighttpd restart
    Output from luci-i18n-base-en.postinst:
    /usr/lib/opkg/info//luci-i18n-base-en.postinst: .: line 4: can’t open ‘/etc/uci-defaults/luci-i18n-base-en’
    Output from luci-i18n-commands-en.postinst:
    /usr/lib/opkg/info//luci-i18n-commands-en.postinst: .: line 4: can’t open ‘/etc/uci-defaults/luci-i18n-commands-en’
    Output from luci-i18n-base-de.postinst:
    /usr/lib/opkg/info//luci-i18n-base-de.postinst: .: line 4: can’t open ‘/etc/uci-defaults/luci-i18n-base-de’
    Output from luci-i18n-commands-de.postinst:
    /usr/lib/opkg/info//luci-i18n-commands-de.postinst: .: line 4: can’t open ‘/etc/uci-defaults/luci-i18n-commands-de’
    Output from foris-controller-openvpn-module.postinst:
  • [ -n ]
  • /etc/init.d/foris-controller restart
    Output from foris-openvpn-plugin.postinst:
  • [ -n ]
  • /etc/init.d/openvpn enable
  • /etc/init.d/lighttpd restart
    Output from foris-openvpn-plugin-l10n-de.postinst:
  • [ -n ]
  • /etc/init.d/lighttpd restart

Is there a more detailed log which shows what exactly is failing?

Rolled back again, removed l10n de, but updater hangs again:

Output from foris-wizard.postinst:

  • [ -n ]
  • /etc/init.d/lighttpd restart
    Output from foris-diagnostics-plugin.postinst:
  • [ -n ]
  • /etc/init.d/lighttpd restart
    Output from foris-controller-openvpn-module.postinst:
  • [ -n ]
  • /etc/init.d/foris-controller restart
    Output from foris-openvpn-plugin.postinst:
  • [ -n ]
  • /etc/init.d/openvpn enable
  • /etc/init.d/lighttpd restart

Same happening to me. Contacted Turris support, no answers. If you check the main 3.10.1 thread there’s one other (@palo_m) with this issue as well. :expressionless:

This worked for me: stop and disable ddns service, reboot, let the updater finish, then re-enable ddns.


I can confirm that disabling the DDNS allows the updater to work.

Now my question, how did you find it out?

It was mentioned in the 3.10.1 thread. Tried it, and it worked for me.

We have your email since Sunday as we don’t provide support 24/7 and I know that you wrote us, please be patient.

//EDIT: 13.6. 01:32 replied to you.

My updater is hanging but ddns was already disabled. Any tipps on what might be blocking the updater from succeeding, or how to find out which process is blocking it?

The error message that appears sometimes is:

Updater selhal:

[string “backend”]:1194: [string “backend”]:1185: Failed to lock the lock file //var/lock/opkg.lock: Resource temporarily unavailable

1 Like

Same here. I already contacted support and they investigate it currently. I will report back in if it gets solved.

Next try: I did a factory reset with the built-in factory snapshot (press the reset buttin until 3 LEDs are lit)
Update to latest turrisOS runs through without any apparent errors.

but as soon as I add modules in FORIS->Updater it hangs again.
see schnapps list:
123 | rollback | 2019-05-20 14:53:41 +0000 | Rollback to snapshot factory
124 | pre | 2019-05-20 16:59:55 +0200 | Automatic pre-update snapshot
125 | post | 2019-05-20 17:06:54 +0200 | Automatic post-update snapshot
126 | pre | 2019-05-20 17:11:15 +0200 | Automatic pre-update snapshot

Thsi is a little bit frustrating to be honest.

We also did a reset yesterday. Not sure if it was a factory reset or medkit though…
Afterwards we uploaded our configuration backup again.

Then we logged into SSH and started the updater.sh to have it updated to the latest version.
When it finished we restarted and the automatic updater works fine since then. Dunno what the problem actually was in the end…

After updater.sh finishes, just don’t use it anymore. It’s deprecated… You can use opkg update to trigger manual updates in newer versions.

So after being fed up with the turris a took a day today and dragged myself to install the HBT-medkit via USB Flash reset mode 4.

For Whatever Reason I ended up with a version 4.something istead of 5 (HBT!)
And guess what: After the first round of Updates while installing all the packeges once again the updater ceased working.

I didn’t recognise it at first, trying to recreate my lx containers, which dind not work at all, It came to my mind that DNS is not working. And this apparently and understandably breaks everything.
As you can imagine I tried once again fixing DNS, shuffleing through all the options in FORIS and LuCI, but it was simply not possible.

So after once again spending too many hours with the turris I am finally finished. Now my devices can’t even connect to the internet anymore.

I’ll get a proprietary router ASAP and ditch the turris.

Where did you find the info that you should download HBT medkit? It was said to use switch-branch in all of the announcement posts.
Please see: Turris OS 5 is coming - #40 by Pepe - General discussion - Turris forum

Yeah whatever, one would expect that DNS works on HBS, would’t one?

Let’s try it slightly differently this time alright? Download HBS medkit, flash it to your router and you will see there is working DNS. :wink: There is still a way to download HBT medkit, but before you proceed through Updater tab, you need to use switch-branch hbt or whatever medkit you download.

Sorry for being so unfriendly. Apparently the latest HBT TurrisOS works as expected for my setup. It appeared magically on my half working Omnia via Auto Update.

So finally this thread is closed for me too.