[solved] Updater failed, Debug usign -> killed

Hi,

in the last 3 days my cron scheduled updater process is not working anymore. When I run updater.sh in debug mode I get:

DEBUG:src/lib/events.c:717 (download_check_info):Download succesfull (https://repo.turris.cz/omnia/packages/base/Packages.sig)
DEBUG:src/lib/events.c:717 (download_check_info):Download succesfull (https://repo.turris.cz/omnia/packages/php/Packages.gz)
DEBUG:src/lib/events.c:717 (download_check_info):Download succesfull (https://repo.turris.cz/omnia/packages/hardware/Packages.sig)
DEBUG:src/lib/events.c:717 (download_check_info):Download succesfull (https://repo.turris.cz/omnia/packages/base/Packages.gz)
DEBUG:src/lib/interpreter.c:319 (lua_run_generic):Command: /usr/bin/usign -V -p /tmp/lua_NGkAHC -x /tmp/lua_JFNoMI -m /tmp/lua_cJdEEm
Killed

My whole /tmp/ is filled with these kind of files:

# usign -V -p /tmp/lua_
lua_ABbAkO  lua_CoclmL  lua_FiAlFL  lua_HmMKPh  lua_Jfefha  lua_LeFJHf  lua_NPaMga  lua_PejNLM  lua_bhJDhJ  lua_egDLLC  lua_hpmDcC  lua_jmppcA  lua_oilpFP
lua_AFmgcL  lua_DDKjOH  lua_GAfaIb  lua_HoKOGJ  lua_KCDfip  lua_MAMkkE  lua_NcNAfN  lua_PfffAm  lua_cGeKdI  lua_eoCgiE  lua_iFEEnC  lua_kpBJOg  lua_pIDhfA
lua_AKgIJE  lua_DLMniM  lua_GEACcG  lua_IFBICp  lua_KPDNlo  lua_MCBBLp  lua_NlGimb  lua_PmIpoC  lua_cJdEEm  lua_fEfpmk  lua_iFbIGp  lua_lNpDeK  lua_pOBDmI
lua_ALBpLM  lua_DaHjPl  lua_GboiFM  lua_IGHGhK  lua_KjgBcl  lua_MFFNfg  lua_NmGfla  lua_aIdBPo  lua_cKeCac  lua_fFOiDF  lua_iaAifk  lua_lbOJoO  lua_pchFmo
lua_ALpFOK  lua_DoOAeB  lua_GdHFpg  lua_IHodig  lua_KkOaof  lua_MFHiFl  lua_OGNbbm  lua_aeEmOd  lua_cOhChG  lua_fGLgcg  lua_iiGehA  lua_ldBNHE  lua_phaCnG
lua_Alggmb  lua_EKDDJF  lua_Glgolb  lua_IfbcFn  lua_KnLcCh  lua_MJPNno  lua_OgLdob  lua_aneifn  lua_cPIjIf  lua_fPNDNI  lua_iobHbp  lua_mLhgmd  lua_pnKjcj
lua_Alhpbo  lua_EgLCEI  lua_HKbjGk  lua_IjppAh  lua_KpINJM  lua_MNFJAP  lua_OgnIdd  lua_bIdNKA  lua_dEAafc  lua_feohAE  lua_iopphh  lua_mgBJLb
lua_BLNOOG  lua_FBjPNP  lua_HgMmAa  lua_InPLIh  lua_LDnjeC  lua_MhbgGa  lua_PEFinp  lua_bLoKBE  lua_dMKiOJ  lua_gICJhj  lua_jGHfMD  lua_nCKGIa
lua_CJAkBP  lua_FGfNJL  lua_HglOgK  lua_JCiaka  lua_LJfgIF  lua_MjOiAf  lua_PJHOBb  lua_bOkEld  lua_dMbion  lua_hamMIG  lua_jJolmI  lua_nDolPl
lua_CghEOa  lua_FOdJpg  lua_HkMnaf  lua_JFNoMI  lua_LKLhmk  lua_NBpmkC  lua_PLmcIE  lua_bdhdmK  lua_dkgbCh  lua_hbhfbH  lua_jNNEJP  lua_njeanh
lua_CmbBFN  lua_FcMPcn  lua_HlmdHd  lua_JbnPCJ  lua_LNHeHm  lua_NGkAHC  lua_POifLN  lua_bedJNe  lua_edPNGK  lua_hpMEpc  lua_jPKDoK  lua_oKipgA

#file lua_HlmdHd
lua_HlmdHd: gzip compressed data, was "Packages", last modified: Mon Mar  5 09:57:12 2018, max compression, from Unix

I unzipped it. It seems to be the package description file but the validation request failed.

After that I removed all these lua* files under /tmp and restarted updater.sh.

DEBUG:requests.lua:440 (func):Running script https://repo.turris.cz/omnia/lists/netutils.lua
DEBUG:src/lib/events.c:817 (download):Downloading https://repo.turris.cz/omnia/lists/netutils.lua.sig
DEBUG:src/lib/events.c:817 (download):Downloading https://repo.turris.cz/omnia/lists/netutils.lua
DEBUG:src/lib/events.c:717 (download_check_info):Download succesfull (https://repo.turris.cz/omnia/packages/base/Packages.sig)
DEBUG:src/lib/events.c:717 (download_check_info):Download succesfull (https://repo.turris.cz/omnia/packages/php/Packages.gz)
DEBUG:src/lib/events.c:717 (download_check_info):Download succesfull (https://repo.turris.cz/omnia/packages/hardware/Packages.sig)
DEBUG:src/lib/events.c:717 (download_check_info):Download succesfull (https://repo.turris.cz/omnia/packages/base/Packages.gz)
DEBUG:src/lib/interpreter.c:319 (lua_run_generic):Command: /usr/bin/usign -V -p /tmp/lua_iKDlmG -x /tmp/lua_EmdbaB -m /tmp/lua_PKHHmo
DEBUG:src/lib/events.c:717 (download_check_info):Download succesfull (https://repo.turris.cz/omnia/packages/hardware/Packages.gz)
DEBUG:src/lib/interpreter.c:319 (lua_run_generic):Command: /usr/bin/usign -V -p /tmp/lua_EObhBP -x /tmp/lua_bMCoKB -m /tmp/lua_fHGNmj
DEBUG:src/lib/events.c:717 (download_check_info):Download succesfull (https://repo.turris.cz/omnia/packages/php/Packages.sig)
DEBUG:src/lib/interpreter.c:319 (lua_run_generic):Command: /usr/bin/usign -V -p /tmp/lua_AEenel -x /tmp/lua_edBCkA -m /tmp/lua_KFNEJI
Killed

Does maybe someone know about this issue and can help.

Thanks

Can you post output of dmesg after you reproduced it? I suspect that you are running low on ram and that updater is killed by OOM killer.

1 Like

Thank you very much. That’s it. I was out of memory :slight_smile:

It’s solved.

Hi, its interesting, how you managed to get OOM on router?

A combination of syslog-ng (remote logging) and logstash (which was unfortunately not available) - after that syslog-ng had many forks.