[Solved] Unsaved change in LuCI after every reboot with ssd installed

Whenever I reboot my Omnia and enter LuCI, there is this unsaved change:

system.cfg098bba.trigger=sda

I save & apply and it goes away until the next reboot. Any idea what that might be? sda is an mSata ssd that I installed in the router.

EDIT: After looking around, it is the led configuration for PCI3 in /etc/config/system:

config led
option default '0’
option name 'Auto-configuration for PCI3’
option sysfs 'omnia-led:pci3’
option trigger ‘sda’

I still don’t know why at boot it’s different…

I installed mSata in middle of board as in this video, is my SSD pci 1 or 3?

It’s PCI3

(need 20 characters to post)

I get the same recurring change alert. Haven’t had time to look into it but since it’s not affecting performance, it’s a low priority. Annoying flag though. Did you also get the issue where SDA1 is mounted directly and via the automounter?

I am not sure what that issue is, I made two partitions on my ssd, sda1 formatted as btrfs and sda2 for swap and enabled them both in LuCI so they are mounted automatically at boot.

Try to rename it from ‘Auto-configuration for PCI3’ to ‘PCI3’ to disable reconfiguration on reboots.

1 Like

Yes, it worked, thanks!

It was actually a bug in the configuration script, which has been fixed recently.

I updated to 3.3 and I still have that message.

Yeah, the fix haven’t made it yet to the release. Feel free to apply the fix yourself. It will get eventually overwritten by an update.