[Solved] Moving from Openwrt 19.07 to Turris OS Latest Release (Omnia)

Hello all!
I have run into an issue while attempting to flash back to TurrisOS, and that is my Omnia won’t boot. It is the older model (non-2019). I have been able to go back to openWRT, but unable to have WIFI working, even after numerous reinstalls of firmware. My end result is to go back to TurrisOS.

I am currently waiting for my new TTL Cable to come in, as I could not locate my current one. I did have a similar issue a few years back, but I am unable to find the thread that gives the instructions on how to return to TurrisOS.

Thanks!

You can return to Turris OS by re-flashing from a USB flash disk - see Mode 4: https://docs.turris.cz/hw/omnia/rescue_modes/

Unfortunately that doesn’t work, that was my first attempt.

What I remember from the instructions is I’ll have to reset U-boot to its default setting through serial. But I can’t find the instructions on how to do that and to flash the firmware using the serial cable.

https://docs.turris.cz/hw/omnia/serial-boot/
https://doc.turris.cz/doc/en/troubleshooting/serial_link#turris_omnia or https://docs.turris.cz/hw/serial/

I believe this is what I’m looking for, my new cable should be here later this week and I’ll update if I get it running again! Thanks!

Update, got it running, connected through serial using PuTTY and used the following command:
env default -a
saveenv

I then flashed the medkit image using the 4led method.

Router booted right up and worked!

Thanks to all that helped!

1 Like