[solved] kernel panic - unable to mount root disk

Hi,

i had an issue with my omnia not being able to boot.
when i opened up the serial console (emergency console mode) i had an BTRFS error:

[ 1272.637991] BTRFS info (device mmcblk0p1): disk space caching is enabled
[ 1272.645672] BTRFS: has skinny extents
[ 1272.656706] BTRFS: detected SSD devices, enabling SSD mode
[ 1272.666162] BTRFS: error (device mmcblk0p1) in btrfs_recover_log_trees:5465: errno=-22 unknown (Failed to pin buffers while recovering log root tree.)
[ 1272.679691] BTRFS: error (device mmcblk0p1) in btrfs_replay_log:2401: errno=-22 unknown (Failed to recover log tree)
[ 1272.690268] BTRFS info (device mmcblk0p1): delayed_refs has NO entry
[ 1272.696662] BTRFS error (device mmcblk0p1): cleaner transaction attach returned -30
[ 1272.780598] BTRFS: open_ctree failed

basically what i did to fix this was to run

btrfs-zero-log /dev/mmcblk0p1

then the device booted succesfully
I thought i would share this if anyone has the same issue

cheers

I think the “best” solution depends on the kind of corruption that happened. Still, I expect with -zero-log you at most lose the last couple of transactions, which mostly won’t be a problem for Omnia users. A more thorough reference would be on https://btrfs.wiki.kernel.org/index.php/Btrfsck

yeah,

btrfsck was the first thing i tried but there was no output after 30 min of command run so i thought something is wrong so i tried the zero-log and the that fixed it.