Solved: Ifup wg0 giving "Line unrecognized: `PublicKey='" error

Turris Omnia w/ OS version 3.11.18

> opkg list | grep wiregu
kmod-wireguard - 4.4.199+0.0.20191219-1-a890a5a94ebb621f8f1720c24d12fef1-0
luci-app-wireguard - git-19.318.61483-fd63d5c-1
luci-proto-wireguard - git-19.318.61483-fd63d5c-1
wireguard - 0.0.20191219-1
wireguard-tools - 0.0.20191219-1

I set up a wireguard “server” using the “Via configuration files” instructions at Turris Documentation several months ago. It worked great.
However, it went several weeks without being used, so I can’t say when things broke.
No changes to the configuration files.
‘ifup wg0’ returns with no messages
‘wg show’ returns “interface: wg0” That is all.
ifconfig wg0:

wg0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

And in /var/log/messages:

2020-08-05 10:06:23 notice netifd: Interface ‘wg0’ is setting up now
2020-08-05 10:06:23 notice netifd: wg0 (7491): Line unrecognized: `PublicKey=’
2020-08-05 10:06:23 notice netifd: wg0 (7491): Configuration parsing error

Has the wireguard format in /etc/config/network changed from the documentation? Is the current Turris version of wireguard broken?


Took way too long to find this. Typo in the peer setting. “option publish_key” instead of “option public_key”. Not a useful error, at all, but should have been an easy catch if I had noticed the interface didn’t come back up after I added that peer. Unfortunately, I didn’t until my son complained weeks later.