[Solved] Cannot login using Google


#1

Hi guys,

recent change of the Discourse URL made it impossible to use Google login, due to URL mismatch.


#2

Hi Ondrěj,

this problem should be fixed already, thanks for the report.


[Solved] mojeID thinks that this site is other than it really is
#3

Hello, the similar problem is during login by MojeID. The message is: “Tento požadavek na přihlášení přes mojeID o sobě tvrdí, že přichází z jiné stránky, než tomu ve skutečnosti je. Zvažte, zda vůbec chcete pokračovat s předáváním údajů ze svého mojeID.” Could you solve it, please?


#4

Should be solved now :slight_smile:


#5

Thanks. It looks to be perfect! :slight_smile:


#6

Looks like Google login is broken again. All I get after authenticating to Google is:

Sorry, there was an error authorizing your account. Perhaps you did not approve authorization?


#7

Thank you for reporting. I can confirm it also on my side. We’ll look at it.


#8

Pertinent? https://security.googleblog.com/2018/10/announcing-some-security-treats-to.html

When your username and password are entered on Google’s sign-in page, we’ll run a risk assessment and only allow the sign-in if nothing looks suspicious. We’re always working to improve this analysis, and we’ll now require that JavaScript is enabled on the Google sign-in page, without which we can’t run this assessment.


#9

@n8v8r Maybe, thanks for feedback.

I am not sure where the problem could be at this time (but certainly a different issue than before).

There are some pending Discourse updates (which I can not apply at the moment). Maybe the google API has changed so this minor update could help. I will upgrade the forum in the evening.


#10

It works for me from now


#11

Works now, thank you!