Solution found for WiFi clients disconnects

Yeah, I see.
I’m sorry my ear is in a bad mood since New Year’s Eve, so do I.
Thank you anyway.

Hmmm…I tried this but it doesn’t seem to be working. I still get random disconnects every so often. And the most frustrating part is that the logs don’t offer any meaningful explanation of what’s happening.

These are the only pertinent entries I can find in the system log (the entries before that are entirely unrelated to WLAN or DHCP etc):

2018-01-10 17:31:06 info hostapd[]: wlan1: STA xx:xx:xx:xx:xx:xx IEEE 802.11: authenticated
2018-01-10 17:31:06 info hostapd[]: wlan1: STA xx:xx:xx:xx:xx:xx IEEE 802.11: associated (aid 9)
2018-01-10 17:31:06 info hostapd[]: wlan1: STA xx:xx:xx:xx:xx:xx RADIUS: starting accounting session 41CC6D591F90C4F2
2018-01-10 17:31:06 info hostapd[]: wlan1: STA xx:xx:xx:xx:xx:xx WPA: pairwise key handshake completed (RSN)
2018-01-10 17:31:06 info dnsmasq-dhcp[14004]: DHCPREQUEST(br-lan) 192.168.1.10x xx:xx:xx:xx:xx:xx 
2018-01-10 17:31:06 info dnsmasq-dhcp[14004]: DHCPACK(br-lan) 192.168.1.10x xx:xx:xx:xx:xx:xx MyDevice

Why is my device re-authenticating itself again mid way through usage?

What is your disconnect period?
What device?
Is there any link to device usage?
Is it one specific client or more?
What is DHCP lease time?
Do you have static IP?
Is there any link between disconnect and router operation?
Is it 5G, 2G or both?
…?

As in how long the disconnect lasted for? Probably 60-90 seconds at most I think?

Surface Pro 3. The disconnect happened mid-way through usage (i.e. it wasn’t in hibernation or anything like that).

Just this particular device on this occasion.

The default 12 hours.

Yes.

Not that I’m aware of. The router was (and is) running as usual. No link that I can see.

The SP3 is connected via 2.4Ghz

And what type of disconnect? Complete disconnect (wifi lost) or stay connected to WiFi but lost LAN/WAN connection?
Do you need to reconnect manually?

What happens 9 times out of 10 is that I’m still connected to the wifi (i.e. the wifi connection icon is still there in the taskbar) but I can’t access anything. I can’t access external websites (e.g. google.co.uk) and I can’t reach internal destinations such as Luci on 192.168.1.1

After 90 seconds or so, everything will magically start working again without me needing to manually reconnect etc.

Then I don’t think it’s wifi problem or at least not related to this topic. And SP3 is known to have problems with drivers and Hyper-V so my suggestion is try to find solution for SP3 directly first.

1 Like

So. It’s done :+1:

But the patch from @HomerSp most probably not yet.

2 Likes

I also had the problem of many disconnects after updating my wifi-card.
Diving deeper into it I discovered I deleted all SSIDs and by accident created new main SSID with PSK2+TKIP+AES encryption.
After changing that to PSK2+CCMP everything works again as expected.

@blbeczech82: What I’m curious about - do we have the option to set wpa_strict_rekey=1 somehow as it doesn’t seem to be set by default?

1 Like

I enter in the middle of discussion with a question - is it only happening on Android devices ? If yes, can it be the cause of default randomization of the MAC address ?

I experienced WiFi connection drop outs on various clients recently (Q1/2021) after manual upgrade to TurrisOS 5.x even when I was using WPA2 PSK (CCMP).

The reason was hostapd: wlan0: STA IEEE 802.11: disconnected due to excessive missing ACKs.

The solution was to turn off this feature.

The real problem - the lose of ACK packets remains a mystery to me. Probably poor performance due to driver or hardware itself.

EDIT

Nope, the solution mentioned above doesn’t fix much. The connection still fails with a different message.

wlan0: STA MAC_ADDRESS IEEE 802.11: disassociated

I believe that the reason is still the same - the lost of ACK packets. The bummer is that the USB adapter which I use to connect my desktop PC is on my table with no movement around and connection is stable for 99 % of time. :woman_shrugging:t6:

I wish to know why the performance of the WiFi card varies so much over time.

1 Like

Second paragraph in the very first post in this thread :wink:

Yeah, I see it but neither of presented solutions really solves the problem, see my edit.

I have similar issue.

For iphone 7 ios 14.6. is no problem
For iphone SE 2020 ios 14.6. is problem! -> different wifi chip?

i tried 2.4 ghz, 5ghz, TKIP or AES, or combo. For macbook 2018 (os Mojave) and iphone 7 without issues. But for new iphone its issue.

i have still Turris OS 3.9.6 due problems with updates, and migration of settings (VPN, NAS, etc)

2021-06-19T11:29:10+02:00 debug hostapd[]: wlan0: STA e2:04:a7:ee:50:71 IEEE 802.11: authentication OK (open system)
2021-06-19T11:29:10+02:00 debug hostapd[]: wlan0: STA e2:04:a7:ee:50:71 MLME: MLME-AUTHENTICATE.indication(e2:04:a7:ee:50:71, OPEN_SYSTEM)
2021-06-19T11:29:10+02:00 debug hostapd[]: wlan0: STA e2:04:a7:ee:50:71 MLME: MLME-DELETEKEYS.request(e2:04:a7:ee:50:71)
2021-06-19T11:29:10+02:00 info hostapd[]: wlan0: STA e2:04:a7:ee:50:71 IEEE 802.11: authenticated
2021-06-19T11:29:10+02:00 debug hostapd[]: wlan0: STA e2:04:a7:ee:50:71 IEEE 802.11: association OK (aid 3)
2021-06-19T11:29:10+02:00 info hostapd[]: wlan0: STA e2:04:a7:ee:50:71 IEEE 802.11: associated (aid 3)
2021-06-19T11:29:10+02:00 debug hostapd[]: wlan0: STA e2:04:a7:ee:50:71 MLME: MLME-ASSOCIATE.indication(e2:04:a7:ee:50:71)
2021-06-19T11:29:10+02:00 debug hostapd[]: wlan0: STA e2:04:a7:ee:50:71 MLME: MLME-DELETEKEYS.request(e2:04:a7:ee:50:71)
2021-06-19T11:29:10+02:00 debug hostapd[]: wlan0: STA e2:04:a7:ee:50:71 IEEE 802.11: binding station to interface 'wlan0'
2021-06-19T11:29:10+02:00 debug hostapd[]: wlan0: STA e2:04:a7:ee:50:71 WPA: event 1 notification
2021-06-19T11:29:10+02:00 debug hostapd[]: wlan0: STA e2:04:a7:ee:50:71 WPA: start authentication
2021-06-19T11:29:10+02:00 debug hostapd[]: wlan0: STA e2:04:a7:ee:50:71 IEEE 802.1X: unauthorizing port
2021-06-19T11:29:10+02:00 debug hostapd[]: wlan0: STA e2:04:a7:ee:50:71 WPA: sending 1/4 msg of 4-Way Handshake
2021-06-19T11:29:10+02:00 debug hostapd[]: wlan0: STA e2:04:a7:ee:50:71 WPA: received EAPOL-Key frame (2/4 Pairwise)
2021-06-19T11:29:10+02:00 debug hostapd[]: wlan0: STA e2:04:a7:ee:50:71 WPA: sending 3/4 msg of 4-Way Handshake
2021-06-19T11:29:10+02:00 debug hostapd[]: wlan0: STA e2:04:a7:ee:50:71 WPA: received EAPOL-Key frame (4/4 Pairwise)
2021-06-19T11:29:10+02:00 debug hostapd[]: wlan0: STA e2:04:a7:ee:50:71 IEEE 802.1X: authorizing port
2021-06-19T11:29:10+02:00 info hostapd[]: wlan0: STA e2:04:a7:ee:50:71 RADIUS: starting accounting session BA5710A4D6238D3D
2021-06-19T11:29:10+02:00 info hostapd[]: wlan0: STA e2:04:a7:ee:50:71 WPA: pairwise key handshake completed (RSN)
2021-06-19T13:29:11+02:00 info dnsmasq-dhcp[5700]: DHCPDISCOVER(br-lan) e2:04:a7:ee:50:71 
2021-06-19T13:29:11+02:00 info dnsmasq-dhcp[5700]: DHCPOFFER(br-lan) 192.168.1.103 e2:04:a7:ee:50:71 
2021-06-19T13:29:12+02:00 info dnsmasq-dhcp[5700]: DHCPREQUEST(br-lan) 192.168.1.103 e2:04:a7:ee:50:71 
2021-06-19T13:29:12+02:00 info dnsmasq-dhcp[5700]: DHCPACK(br-lan) 192.168.1.103 e2:04:a7:ee:50:71 AndreasiPhoneSE
2021-06-19T11:29:12+02:00 info dhcp_host_domain_ng.py[]: DHCPv4 new lease
2021-06-19T11:29:12+02:00 warning dhcp_host_domain_ng.py[]: Add_lease, hostname check failed
2021-06-19T13:29:12+02:00 warning dhcp_host_domain_ng.py[3322]: Last message 'Add_lease, hostname ' repeated 2 times, suppressed by syslog-ng on turris
2021-06-19T11:29:12+02:00 info dhcp_host_domain_ng.py[]: DHCP remove old hostname [old,AndreasiPhoneSE,192.168.1.103]


2021-06-19T11:29:59+02:00 debug hostapd[]: wlan0: STA e2:04:a7:ee:50:71 WPA: event 2 notification
2021-06-19T11:29:59+02:00 debug hostapd[]: wlan0: STA e2:04:a7:ee:50:71 IEEE 802.1X: unauthorizing port
2021-06-19T11:29:59+02:00 info hostapd[]: wlan0: STA e2:04:a7:ee:50:71 IEEE 802.11: disassociated
2021-06-19T11:29:59+02:00 debug hostapd[]: wlan0: STA e2:04:a7:ee:50:71 MLME: MLME-DISASSOCIATE.indication(e2:04:a7:ee:50:71, 8)
2021-06-19T11:29:59+02:00 debug hostapd[]: wlan0: STA e2:04:a7:ee:50:71 MLME: MLME-DELETEKEYS.request(e2:04:a7:ee:50:71)
2021-06-19T11:30:00+02:00 info hostapd[]: wlan0: STA e2:04:a7:ee:50:71 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
2021-06-19T11:30:00+02:00 debug hostapd[]: wlan0: STA e2:04:a7:ee:50:71 MLME: MLME-DEAUTHENTICATE.indication(e2:04:a7:ee:50:71, 2)
2021-06-19T11:30:00+02:00 debug hostapd[]: wlan0: STA e2:04:a7:ee:50:71 MLME: MLME-DELETEKEYS.request(e2:04:a7:ee:50:71)

I was tryin to adjust the wireless config, but didnt solve the issue.

config wifi-device 'radio0'
	option type 'mac80211'
	option country 'CZ'
	option hwmode '11a'
	option path 'soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
	option htmode 'VHT80'
	option disabled '0'
	option channel '116'
	option txpower '27'
	option log_level '1'

config wifi-iface
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option disabled '0'
	option ssid 'Ondra5'
	option disassoc_low_ack '0'
	option wpa_group_rekey '86400'
	option encryption 'psk2+ccmp'

config wifi-device 'radio1'
	option type 'mac80211'
	option country 'CZ'
	option hwmode '11g'
	option path 'soc/soc:pcie-controller/pci0000:00/0000:00:01.0/0000:01:00.0'
	option htmode 'HT20'
	option txpower '19'
	option channel '13'
	option disabled '1'

config wifi-iface
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'Ondra'
	option encryption 'psk2+ccmp'
	option disassoc_low_ack '0'
	option wpa_group_rekey '86400'
	option disabled '1'

config wifi-iface 'guest_iface_0'
	option disabled '1'

config wifi-iface 'guest_iface_1'
	option disabled '1'

Is the disassoc_low_ack '0' ignored because i am using older version of openWRT ? Thx

I found that there is related bug in OpenWRT, so its common issue with some wifi apple firmwares

These settings are not suitable for testing ?

I dont have these settings.
In my system i have only

my system :
Turris Omnia - rtrom01
Turris OS 3.9.6
Core 4.4.119-082ea0f4a4e204b99821bedcb349ed54-0
Powered by LuCI 49c3edd5861fd032fa8379ceda525c27a908a114 branch (git-17.212.24321-49c3edd) / OpenWrt omnia 15.05 r47055

I tried manually push the settings into
wireless:


, but only disassoc_low_ack '0' is exported into hostapd-phy0.conf , and manually edit of this conf is also overwritten

This version is no longer supported for many months, not even years! It was released on 18th March 2018. We are not going to provide any support for ancient versions. I am sorry.

If you want to help, you should update your router to the latest versions 3.11.23, or preferably rather Turris OS 5.2.2. Once you have an up-to-date version, feel free to reach our support department, and they might help you if you provide more details like diagnostics.

Ok, i will try to update to latest OS 3.x. Last time, when i tried to update from 3.9. to 3.10, it broken the router and i was worry to break also my raid 1 table, because i am using turris as NAS also.
I wont to push myself to OS 5.x due some bugs what i actually see for the same reason of loosing data in my raid 1 table.

Edit: Hmm, i updated to 3.11.23, Foris and Luci is broken now.

Edit: i get failure to update in Foris, after cmds in SSH opkg update and pkgupdate and manual restart, it seems to i updated to 3.11.23 hopefully ok. I will start with testing the wifi adjustments.