Since 9 April, multiple issues with multiple devices on network

I can’t work out where the commonalities are but something happened on 9 April that has wrecked my network. Some things still work, others connect to the router, but can’t be accessed remotely:

  1. Wireless IP security cameras (“Device Offline” errors, even though I can see them in the the router tables) Some of them I can access when I’m logged in via iPhone on the LAN but then can’t see them remotely. Next time I try to access locally, says “network error”, Try again 5 minutes later and it works again. 5 minutes after that, ‘network error again’. Was working fine prior to 9 April.

  2. Zigbee security system items. Hub is connected, but the app says “hub not connected” so can’t see the sensors; or the sensors can’t connect to it and app returns errors when trying to reconnect to it. Worked fine for 12 mo prior to 9 April.

  3. SSH throughput is dramatically reduced when accessing security cameras across SSH connection. Looking at the headless server directly, everything is normal; trying to view stored videos across the LAN on another computer, frame rate is less than 1 frame per second. Hangs, etc. Worked fine prior to 9 April.

  4. WiFi access points unreliable. Sometimes can connect to AP but AP cannot connect to Internet. An hour later, it works again. Apple AirPlay. Randomly stops working, goes offline. Reboot it and it works again; an hour later it disconnects and won’t work unless rebooted and each device that wants to use it has to be rebooted.

Half a dozen other similar things, all happened at the same time on 9 April, so the only commonality amongst them all is the Turris Router.

Have rebooted the router, tried various DNS servers, rebooted the devices one by one several times, but the situation remains unchanged.

Would suspect that it may be some sort of firewall rule or DNS issue introduced by a firmware update, but have no evidence to confirm this.

Any thoughts appreciated.

1 Like

A couple of my wifi access points can’t connect to the Internet any longer.

Earlier, I’ve tried to run the Turris Diagnostics, but an hour later, it still says ‘Preparing’

Where is the file stored when it’s completed?

Get these errors when trying to do internal Ping, Traceroute, etc.

The page will show a link.

Thanks vcunat, after several hours, the file link eventually appeared. Is this normal to take so long?

Also, the file format is an unformatted text file. Is there a simple way to format the file to read it once downloaded?

Cheers and thanks.

No, I don’t think so. I’ve tried diagnostics a few times and it was maybe something like a minute, not significantly longer.

I have something similiar happened.
When I check the 5G wifi network was not working.
And it has been change the non - AC mode
it was changed to legacy mode…
maybe you can check any config were wrong.

1 Like

You could always ssh in to the router and use schnapps to see if you have a snapshot from before that date, and then just restore that and see if it works better. If it doesn’t it’s most likely a hardware issue. If it does indeed start working well again you would have to do some detective work to see what’s changed.


Same here, COuld not connect to WiFi the card is seen enabled but it’s greyed in the turris interface. Will unmount tonight the module and see how it goes… Any devs passing by?

I solved my problem by unscrewing the top cover and unplugging and blowing into the two wifi cards. I had to open the case to replace an sma cable anyway. Hope this helps

OK, thanks for all the suggestions. Problem solved. I finally gave up and called in a local wizard who eventually worked out the problem. I suspect this may be an issue causing problems for many people. See attached screen grab for explanation.

Note, that this parameter was originally set at the default setting (‘lan’). A firmware update around 9/10 April must have changed some parameters to make this setting no longer valid !


See attached.

The link doesn’t work. It’s an <a> without href=. I’m not sure where it’s gone wrong.

Apologies, it actually displayed on my preview when I posted it. Let’s try again.

Fixing this has made a HUGE difference on so many aspects of my network; suddenly, everything works as expected. WiFi, IP security cameras, sensors, etc. etc. Have to wonder how many people have this same issue and don’t realise it?

I have /lan/ in my config, and I dont experience any problems…

@wayoutwest could you double/tripple check that this was the only change?
seems very odd

I was watching the tech who fixed it while he did it. That was the only change he made. Instantly, everything worked properly when he applied the changes; all my devices that previously weren’t connecting to the network all began connecting and I got half a dozen notifications from various apps telling me the devices were now connected.

I suspect there may have been issues from the very beginning when I installed the router – until this fix was applied, I had been having lots of obscure problems with devices dropping off the network for no reason and wouldn’t re-connect. Now everything is working great.

Very happy with the router now.

Interesting – my router previously had just ‘lan’ not /lan/. I wonder if this had some unintentional impact?

Hi again Hadc. I will email your question to the tech to make certain there was nothing else that he changed that I didn’t see and will let you know. Give me a couple of days and I will reply.