Shouldnt iface HWaddr be same within bridge?

Hello,

ifconfig shows these HWaddr. lan0-3 has same HWaddr and lan4 has different.

lan0 Link encap:Ethernet HWaddr XX:XX:XX:XX:XX:CB
lan1 Link encap:Ethernet HWaddr XX:XX:XX:XX:XX:CB
lan2 Link encap:Ethernet HWaddr XX:XX:XX:XX:XX:CB
lan3 Link encap:Ethernet HWaddr XX:XX:XX:XX:XX:CB
lan4 Link encap:Ethernet HWaddr XX:XX:XX:XX:XX:CD

and lan0 is at lan bridge and others are at guest bridge

config interface ‘lan’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘192.168.1.1’
option netmask ‘255.255.255.0’
option ip6assign ‘60’
option bridge_empty ‘1’
list ifname ‘lan0’

config interface ‘guest_turris’
option enabled ‘1’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘10.111.222.1’
option netmask ‘255.255.255.0’
option bridge_empty ‘1’
list ifname ‘lan1’
list ifname ‘lan2’
list ifname ‘lan3’
list ifname ‘lan4’

Shouldn’t be the lan1-4 same HWaddr and lan0 different?

Many thanks

This is correct behavior. It is the way of inner connection of magjacks to the internal switch.

So does that mean magjacks have reverse order? such as
lan0 lan1 lan2 lan3 lan4
lan4 lan3 lan2 lan1 lan0

No, how did you come to it?

Above only lan4 has different HWaddr, but I have only lan0 in lan bridge(which is same with other 3). I was expecting lan0 would be different than the other group.

Sorry if I m confused or my question is not clear.

lan0 - lan3 are physically connected to eth0 and lan4 is physically connected to eth1.
Verify with MAC addresses of eth0 and eth1. That’s the reason why the lan4 has different MAC address.

Got it now, thanks.

Btw lan0-3 is connected to eth1 and lan4 to eth0
eth0 Link encap:Ethernet HWaddr XX:XX:XX:XX:XX:CD
eth1 Link encap:Ethernet HWaddr XX:XX:XX:XX:XX:CB

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.