SFP setup - Help


#1

Hi!
I have read thru the threads for people with similar problem but Im unable to get my SFP to work.
Basically my ISP is providing my with a simple fiber converter with an SFP to it (see picture).

When removing the SFP from the converter and pluggin it into the Turris I get the following data (and it does not work).

Does this has to do with “Speed No Negotiate” on the ISP side or can I make this work without ISP changing anything ?

root@TillyTurris:~# sfpswitch.py -n -d
sfp det change detected: 1
Removed SFP, using onboad PHY.
Switching NIC mode to phy-def.
Current mode is already phy-def. Noop.
Mode not changed. Iface restart not needed.
sfp los change detected: 1
Warning: SFP status signal changing in PHY mode.
sfp flt change detected: 1
Warning: SFP status signal changing in PHY mode.
sfp flt change detected: 0
Warning: SFP status signal changing in PHY mode.
sfp det change detected: 0
SFP inserted, setting sfpdis=0
Going to probe EEPROM after init in 1 s.
SFP EEPROM: ['\x03', '\x04', '\x01', '\x00', '\x00', '\x00', '\x00', '\x12', '\x00', '\x01', '\x01', '\x01', '\r', '\x00', '\x14', '\xc8', '\x00', '\x00', '\x00', '\x00', 'P', 'R', 'O', ' ', 'O', 'P', 'T', 'I', 'X', ' ', ' ', ' ', ' ', ' ', ' ', ' ', '\x00', '\x00', '\x00', '\x00', 'G', 'L', 'C', '-', 'B', 'X', '-', 'U', '-', '3', '5', '-', '2', '0', 'S', 'C', 'A', ' ', ' ', ' ', '\x05', '\x1e', '\x00', '(', '\x00', '\x1a', '\x00', '\x00', 'P', 'X', 'O', '1', '8', '0', '3', '1', '9', '0', '3', '7', '7', ' ', ' ', ' ', '1', '8', '0', '3', '1', '9', ' ', ' ', 'h', '\x90', '\x01', '\xe7', '-', '\x00', '\x11', '\x80', '\xe5', 'K', '\xd7', '\x9c', '\x0e', '\x80', '\x8d', '\x8a', '\\', '\xee', '\x02', '8', '\xb1', '\xd4', 'c', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\xaa', '\xd7', '\x81', '[', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00', '\x00']
Mode selected: generic 1000BASE-X
Switching NIC mode to phy-sfp.
Switched successfully to mode phy-sfp.
Testing whether the interface eth1 is up...
Interface eth1 is up. Sleeping for 1 second(s).
Shutting down interface eth1
Bringing up interface eth1
Net restart finished.
sfp los change detected: 0
sfp los change detected: 1
sfp los change detected: 0
sfp los change detected: 1
sfp los change detected: 0


root@TillyTurris:/tmp/log# ethtool eth1
Settings for eth1:
	Supported ports: [ TP MII ]
	Supported link modes:   1000baseT/Half 1000baseT/Full
	Supported pause frame use: No
	Supports auto-negotiation: Yes
	Advertised link modes:  1000baseT/Half 1000baseT/Full
	Advertised pause frame use: No
	Advertised auto-negotiation: Yes
	Speed: 10Mb/s
	Duplex: Half
	Port: MII
	PHYAD: 2
	Transceiver: external
	Auto-negotiation: on
	Link detected: no
root@TillyTurris:/tmp/log# tcpdump -pAe -n -i eth1
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth1, link-type EN10MB (Ethernet), capture size 262144 bytes

^C
0 packets captured
0 packets received by filter
0 packets dropped by kernel

Any advice would be appreciated!


SFP port - will it eventually work?
#2

I got the same SFP form the same ISP (Bahnhof) working with a HPE Aruba switch (with the unsupported-transceiver command).

Try forcing it into 1000baseT/Full mode and see if that helps.


#3

Hi and thanks for the reply!

Tried to change /usr/sbin/sfpswitch.py and set:
force_mode = ‘phy-sfp-noneg’

I can see that it is trying to get DHCP response now thru tcpdump, but no answer :confused:

Any other suggestions ?

root@TillyTurris:~# ethtool eth1
Settings for eth1:
	Supported ports: [ TP MII ]
	Supported link modes:   1000baseT/Half 1000baseT/Full
	Supported pause frame use: No
	Supports auto-negotiation: Yes
	Advertised link modes:  1000baseT/Half 1000baseT/Full
	Advertised pause frame use: No
	Advertised auto-negotiation: Yes
	Link partner advertised link modes:  1000baseT/Full
	Link partner advertised pause frame use: No
	Link partner advertised auto-negotiation: No
	Speed: 1000Mb/s
	Duplex: Full
	Port: MII
	PHYAD: 2
	Transceiver: external
	Auto-negotiation: on
	Link detected: yes
root@TillyTurris:~# tcpdump -i eth1 -vv
tcpdump: listening on eth1, link-type EN10MB (Ethernet), capture size 262144 bytes
17:00:44.976516 IP (tos 0x0, ttl 64, id 0, offset 0, flags [none], proto UDP (17), length 328)
    0.0.0.0.68 > 255.255.255.255.67: [udp sum ok] BOOTP/DHCP, Request from d8:58:d7:00:42:37 (oui Unknown), length 300, xid 0x7d16453, secs 36, Flags [none] (0x0000)
	  Client-Ethernet-Address d8:58:d7:00:42:37 (oui Unknown)
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: Discover
	    MSZ Option 57, length 2: 576
	    Parameter-Request Option 55, length 8:
	      Subnet-Mask, Default-Gateway, Domain-Name-Server, Hostname
	      Domain-Name, BR, NTP, Option 212
	    Vendor-Class Option 60, length 12: "udhcp 1.25.1"
17:00:48.056470 IP (tos 0x0, ttl 64, id 0, offset 0, flags [none], proto UDP (17), length 328)
    0.0.0.0.68 > 255.255.255.255.67: [udp sum ok] BOOTP/DHCP, Request from d8:58:d7:00:42:37 (oui Unknown), length 300, xid 0x7d16453, secs 40, Flags [none] (0x0000)
	  Client-Ethernet-Address d8:58:d7:00:42:37 (oui Unknown)
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: Discover
	    MSZ Option 57, length 2: 576
	    Parameter-Request Option 55, length 8:
	      Subnet-Mask, Default-Gateway, Domain-Name-Server, Hostname
	      Domain-Name, BR, NTP, Option 212
	    Vendor-Class Option 60, length 12: "udhcp 1.25.1"
17:00:51.116485 IP (tos 0x0, ttl 64, id 0, offset 0, flags [none], proto UDP (17), length 328)
    0.0.0.0.68 > 255.255.255.255.67: [udp sum ok] BOOTP/DHCP, Request from d8:58:d7:00:42:37 (oui Unknown), length 300, xid 0x7d16453, secs 43, Flags [none] (0x0000)
	  Client-Ethernet-Address d8:58:d7:00:42:37 (oui Unknown)
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message Option 53, length 1: Discover
	    MSZ Option 57, length 2: 576
	    Parameter-Request Option 55, length 8:
	      Subnet-Mask, Default-Gateway, Domain-Name-Server, Hostname
	      Domain-Name, BR, NTP, Option 212
	    Vendor-Class Option 60, length 12: "udhcp 1.25.1"
17:00:54.186511 IP (tos 0x0, ttl 64, id 0, offset 0, flags [none], proto UDP (17), length 328)

#4

@drcain did U use Banhofs SFP or a new one?
This “should” work or what do you think?!

https://www.direktronik.se/direktronik/natverk/sfpgbicxfpcwdm/sfp-1g/sfp-bidi-wdm-20km-lx-1.25gbps/?variationCode=33-2385

Br
Tilly


#5

Oho well…

Keep trying the get the SFP up and running.
I have now got the ISP to disable auto-negotiation…

But now, after a fresh reboot and plugin in the SFP I get this :frowning:

2018-10-29 09:03:42 err sfpswitch.py[3217]: Switching NIC mode to phy-sfp.
2018-10-29 09:03:43 err sfpswitch.py[3217]: Shutting down interface eth1
2018-10-29 09:03:43 err sfpswitch.py[3217]: Bringing up interface eth1
2018-10-29 09:03:43 err sfpswitch.py[3217]: RTNETLINK answers: Out of memory 

Out of memory?