Setup for 4K IPTV Shanghai (China) telecom

Does someone in the forum have experience with the setup? I tried several OpenWrt guidelines, but nothing really worked.


If you could give a bit more information, how your ISP actually distributes its service, maybe we could figure it out?

Hi Etz,

highly appreciated. I have a FTTH were all data (Internet and IPTV) is on one Ethernet port.
For Internet I have to use PPPoE.
Here is a working configuration with OpenWRT for the Netgear 4300

All Chinese but the configuration is as follows:


and for the port configuration:

02.config interface 'loopback’
03. option ifname 'lo’
04. option proto 'static’
05. option ipaddr '’
06. option netmask '’
08.config globals 'globals’
09. option ula_prefix 'fd4b:b465:1e49::/48’
11.config interface 'lan’
12. option ifname 'eth0.1’
13. option force_link '1’
14. option type 'bridge’
15. option proto 'static’
16. option ipaddr '’
17. option netmask '’
18. option ip6assign '60’
19. option macaddr '6c:b0:ce:1f:xx:xx’
21.config interface 'wan’
22. option ifname 'eth0.2’
23. option _orig_ifname 'eth0.2’
24. option _orig_bridge 'false’
25. option proto 'pppoe’
26. option username 'adxxxxxx’
27. option password 'xxxxxxxx’
29.config switch
30. option name 'switch0’
31. option reset '1’
32. option enable_vlan '1’
33. option enable_vlan4K '1’
34. option mirror_source_port '0’
35. option mirror_monitor_port '0’
37.config switch_vlan
38. option device 'switch0’
39. option vlan '1’
40. option ports '0t 1 2 3 4’
41. option vid '1’
43.config switch_vlan
44. option device 'switch0’
45. option vlan '2’
46. option ports '0t 5’
47. option vid '2’
49.config switch_vlan
50. option device 'switch0’
51. option vlan '85’
52. option vid '85’
53. option ports '1t 2t 3t 4t 5t’
55.config switch_vlan
56. option device 'switch0’
57. option vlan '51’
58. option vid '51’
59. option ports ‘1t 2t 3t 4t 5t’

If you need further information from the linked document, please let me know.

Your support is highly appreciated.


I will have a look, when I get some spare time.

But, by the looks of it, it does not work this way on Omnia, this config needs to be modified quite a bit to get this to work.
Catch is that Omnia has a very different hardware implementation compared to that Netgear