Set LEDs not to blink


#1

I would like to set the LAN LEDs to a constant on (not blinking indicating traffic) to indicate whenever there is link and off when there’s no link. Is that possible?


#2

Have you tried LED Configuration in LUCI? This might do the trick, haven’t tested tho.
image


#3

Yes, I tried. That only give you to option to turn them all off, all on or have them blink upon traffic. However, I would like them all off or on on upon link only. There’s no option for that in LUCI.


#4

The menu Rainbow (LuCi -> System -> Rainbow) is suitable for this settings.

The third option is “Color and status of LAN ports LEDs” and here you choice your preferable color and status ON.

And there is the link to the right section of oficial Turris documentation (just to be sure) :slight_smile:


#5

Unfortunately not. That function turns them all on, whether there’s link or not. I’d like them on when there’s link, off when there is no link and no blinky blinky upon data transmit.


#6

The solution I gave you turns off blinking, just tested it. It’s lit when selected interface is connected and off when interface is down. Isn’t that what you want?


#7

That is what I want, but that’s not what happens on my router. Off turns them off, no matter the link state. On turns them on, no matter the link state. (That’s in-line w/ the documentation on the rainbow man page)

I’d like them to represent the link state and the link state only (no data transmit).


#8

I see what the problem is here. While WAN has its own interface (eth1), LAN doesn’t (all ports eth0). You can address the LEDs individually, but there is no individual trigger per LAN port. Any ideas how to solve this?


#9

You are talking about Rainbow, which is a different thing. You have to go to System > LED Configuration. There only PCI LED configuration is present, you have to click ADD on the bottom to add LED override, select specific LED to modify, give it name, select netdev as trigger, select corresponding interface (device) and have only Link On checked this controls when LED is on or off depending on the device state. Leave Transmit and Receive unchecked, those control blinking.

You have to override each LED separately like this.


#10

I gotcha. However, there’s no individual device per LAN port to trigger, is there? (just eth0).


#11

plus it’s not reboot safe.


#12

Not available with TOS3.x only in TOS4.x


#13

For remain youre settings “System- Led configuration” add this line in to section Local startup /etc/init.d/led_autoconfig disable