Server side issues on Netmetr (after opt-in migration?)

I upgraded my Turris Omnia to TurrisOS 5.1.4 from 3.11.x yesterday. Honestly, a poor experience I must say. Most of the services are broken after upgrade. Anyway… Netmeter does not work anymore.

Here is debug run:

root@Turris:~# netmetr --debug
Checking uuid on the control server...
Sending the following request to

  "uuid": "b22789a9-8aa5-40aa-b09a-3e0f60ec05df",
  "language": "en_US",
  "name": "RMBT",
  "terms_and_conditions_accepted": "true",
  "type": "DESKTOP",
  "version_name": "Python netmetr client v1.6.0"
  "settings": [
	  "urls": {
		"url_ipv6_check": "",
		"control_ipv4_only": "",
		"url_ipv4_check": "",
		"control_ipv6_only": "",
		"statistics": ""
	  "qostesttype_desc": [
		  "name": "DNS",
		  "test_type": "DNS"
		  "name": "Non Transparent Proxy",
		  "test_type": "NON_TRANSPARENT_PROXY"
		  "name": "HTTP Proxy",
		  "test_type": "HTTP_PROXY"
		  "name": "Website",
		  "test_type": "WEBSITE"
		  "name": "UDP",
		  "test_type": "UDP"
		  "name": "TCP",
		  "test_type": "TCP"
		  "name": "JITTER",
		  "test_type": "JITTER"
	  "versions": {
		"control_server_version": "master_2.0.83-CZ_0.9.28-324-g4c7caa7"
Requesting test config from the control server...
Sending the following request to

  "client": "HW-PROBE",
  "language": "en_US",
  "time": 1605802583000,
  "timezone": "CET",
  "type": "DESKTOP",
  "uuid": "b22789a9-8aa5-40aa-b09a-3e0f60ec05df",
  "version": "0.1"
  "user_server_selection": false,
  "test_server_address": "",
  "test_server_port": 8081,
  "test_server_name": "CZ.NIC (Prague)",
  "test_server_encryption": false,
  "test_server_type": "RMBT",
  "test_duration": "5",
  "test_numthreads": "3",
  "test_numpings": "10",
  "client_remote_ip": "",
  "result_url": "",
  "result_qos_url": "",
  "test_token": "30172177-0a5c-45c7-b38a-06ca163228e4_1605802583_g1nFIFwUCgVJkfdNzUgdOzKzS6s=",
  "test_uuid": "30172177-0a5c-45c7-b38a-06ca163228e4",
  "test_id": 9657314,
  "test_wait": 0,
  "error": []
Starting ping test...
ping_1_msec = 4.56
ping_2_msec = 4.65
ping_3_msec = 4.62
ping_4_msec = 4.65
ping_5_msec = 4.74
ping_6_msec = 4.55
ping_7_msec = 4.54
ping_8_msec = 4.55
ping_9_msec = 4.66
ping_10_msec = 4.64
Starting speed test...
==== rmbt 3f5c59bb2 ====
connected with 3 flow(s) for dl; 3 flow(s) for ul
pretest downlink start... (min 1s)
pretest downlink end.
rtt_tcp_payload start... (11 times)
rtt_tcp_payload end.
downlink test start... (5s)
downlink test end.
pretest uplink start... (min 1s)
pretest uplink end.
uplink test start... (5s)
uplink test end.
dl_throughput_mbps = 94.026179
ul_throughput_mbps = 93.972824
Speed test result:
  "res_uname_version":"#0 SMP Fri Nov 13 04:11:07 2020",

Sending the following request to
(speed detail omitted)
  "client_language": "en_US",
  "client_name": "HW-PROBE",
  "client_version": "0.1",
  "client_software_version": "Python netmetr client v1.6.0",
  "geoLocations": [],
  "model": "Turris Omnia",
  "network_type": 98,
  "product": "os: 5.1.4 hw: cznic,turris-omnia",
  "test_bytes_download": 68950369,
  "test_bytes_upload": 70050986,
  "test_nsec_download": 5095847624,
  "test_nsec_upload": 5065645875,
  "test_num_threads": 3,
  "test_ping_shortest": 4540000,
  "num_threads_ul": 3,
  "test_speed_download": 94026.17883301136,
  "test_speed_upload": 93972.82394912772,
  "test_token": "30172177-0a5c-45c7-b38a-06ca163228e4_1605802583_g1nFIFwUCgVJkfdNzUgdOzKzS6s=",
  "pings": []
Traceback (most recent call last):
  File "/usr/bin/netmetr", line 11, in <module>
	load_entry_point('netmetr==1.6.0', 'console_scripts', 'netmetr')()
  File "/usr/lib/python3.7/site-packages/netmetr/", line 656, in main
  File "/usr/lib/python3.7/site-packages/netmetr/", line 362, in upload_result
  File "/usr/lib/python3.7/site-packages/netmetr/", line 102, in send_request
  File "/usr/lib/python3.7/urllib/", line 222, in urlopen
  File "/usr/lib/python3.7/urllib/", line 531, in open
  File "/usr/lib/python3.7/urllib/", line 641, in http_response
  File "/usr/lib/python3.7/urllib/", line 569, in error
  File "/usr/lib/python3.7/urllib/", line 503, in _call_chain
  File "/usr/lib/python3.7/urllib/", line 649, in http_error_default
urllib.error.HTTPError: HTTP Error 400: Bad Request

Here is the list of installed packages:

netmetr 1.6.0-3.7-1
foris-netmetr-plugin 4.6.2-3.7-1
foris-netmetr-plugin-l10n-cs 4.6.2-3.7-1
foris-controller-netmetr-module 0.4.2-3.7-3
reforis-netmetr-plugin 0.1.1-3.7-1
reforis-netmetr-plugin-l10n-cs 0.1.1-3.7-1

Any help, please?

1 Like

I updated to 5.1.4 in the morning on 17/11/2020. Netmeter stopped working only today between 0:11 and 02:30.
I’ve just tried Netmeter on my Android phone and it returns server error. It seems to me there is a problem on the Netmeter server not in TOS 5.1.4.

@KUTlime as @meresjev told you. This is not related to Turris OS update either opt-in migration. I got confirmed that there are some issues on the server-side and guys from Netmetr will take a look. Thank you for reporting this to us!

My last test is dated on 2020-11-18 21:11 CET, about 3 minutes before I hit the upgrade button. It test my connection every hour and I have a record until the date stated about. I can see my record on NetMetr web and Foris but not in reForis. Re-download also fails.

@Pepe Are you sure that this is not upgrade/Turris OS related?

I am definitely sure that this is not related to Turris OS anyhow. Just take a look at HTTP errors.

@Pepe OK, acknowledged.

BTW: What HTTP errors? I see only one HTTP error. I can reach netmetr in browser, I can ping there from SSH, the test is conducted until the result must be uploaded. That is the moment when test fails.

Two people confirmed to you that there are server-side issues and it happens on a mobile app, it happens on the website and still, this has something to do with Turris OS.

No, it does not anything to do with Turris OS, and let’s wait until it is solved. There is nothing that you neither I can do in this situation. Netmetr team is looking into it and I am pretty sure that they will have solution for us and it will run as it should without doing anything on the client side.

It should be working, feel free to check.

1 Like

I confirm that since 20. 11. 2020 1:02 it works. :+1:t6: