SCP speed very slow behind the Omnia

I have a turris Omnia and noticed that i have very slow SCP transfer speed (close to 1MBps).

I tried many things :

  • SCP to another remote server : slow
  • SCP from a remote server to a local machine : fast
  • SCP to another SSH port : slow
  • RSYNC with ssh : slow
  • flushing most of iptables : still slow
  • SCP from another local machine : slow
  • Transferring files with HTTPS : fast

I monitored CPU usage on the local machine, the omnia, the remote machine and it’s always close to 0%.
I tried transfering to /dev/null or from ramdisk still the same.

When it’s fast i can go up to 37MBps, but I’m capped to 1MBps with ssh :-/

May it be my ISP which throttle outgoing SSH connections ?
Is there something in the Omnia which could throttle ?

What can I do to debug more ?

I don’t have the problem you’re having. I can saturate my outbound internet connection using scp.
Can you be more specific?
ISP’s can most certainly throttle. If you have enough privileges, you could try netcat to transfer files? Is it still slow then?

With netcat or via HTTP i upload at 36MBps to the same remote server but only 1MBps with scp.
The local and remote have the latest openssh.