Schnapps import does not work

Procedure performed according to https://docs.turris.cz/geek/schnapps/schnapps/#export-and-import

The export was successful.

The import is reported as successful with the following message:

"Snapshot imported as number 16
Due to the nature of import, deduplication doesn’t work, so it occupies a lot of space.
You have been warned! "

But the snapshot does not appear in the schnapps list.

All subsequent imports increment the snapshot number (17, 18, etc), but no snapshot appears in the table.

Works bybass the problem:
Successfully uploaded the medkit export file via the 4 LED procedure https://docs.turris.cz/hw/omnia/rescue-modes/
By the way, it confirmed that my medkit export file and USB flash drive are working properly.

Checked on TOS Omnia
5.1.4 HBS
5.1.5 HBT

Regards!

Knock knock on door Turris … is anybody home?
I understand that the import function is rarely used, but I feel lonely by the Turris Team :frowning:

@Pepe Can I ask you for help on this topic?
I love you guys but i get frustrated when you ignore reported problems :frowning:

Regards

i get frustrated when you ignore reported problems

AFAIK this is not support forum as written here: Bug reports must be reported to Technical support department or Gitlab and https://docs.turris.cz/basics/support/.

1 Like

Something I don’t understand …
If the forum is not for reporting issues, what is it for? For making New Year’s wishes and sending hearts?

First:
What are the SW Help and Bugs Discussion categories for?

Secondly:
Most of the posts are descriptions of problems (because that’s what the forum is for)

Thirdly:
I reported a few problems before and everything was handled positively.
For example here:


and here:

Fourthly:
In my opinion, it is better to report the problem on the forum instead of by e-mail, because other people will also be able to benefit from it.

Hi,

from what I understood:

“The forum was primarily created to allow users to exchange information amongst themselves.” [1]

In my opinion, it is better to report the problem on the forum instead of by e-mail

I agree it’s excellent idea to track and discuss problems publicly. Anyway, because you mentioned that that you “… get frustrated” and “… feel lonely by the Turris Team …”, I thought it would be useful if you’d follow the official support procedure[2], and then, share the results here with us!

[1] Why does nobody answer me on the forum?, Frequently asked questions
[2] Bug reports must be reported to Technical support department or Gitlab

So this is what is happening right now: I am exchanging information with you that Schnapps is not working properly :wink:

First:
I have reported issues before (posts above) and they have been resolved. This time I was ignored.
95% of the threads in this forum are problem reports.
Secondly:
Do you know how human nature works? When the problem is solved by the official support email, no one will want to post everything on the forum again and give the solutions = the forum will die.
Thirdly:
There was a conversation here somewhere between the guys on the official team. They talked about how they don’t mind solving problems in the forum.

Maybe I’m stupid, but I’ll ask you again:
What are the SW Help and Bugs Discussion categories for?

I was able to reproduce your issue. The problem is a typo when importing the snapshot which makes it invisible to schnapps list. I will filed an issue + a patch with the development team. Until schnapps gets updated, here’s a workaround (please adapt to your environment):

mkdir /mnt/root
mount -o subvol=/ /dev/mmcblk0p1 /mnt/root
mv /mnt/root/@16.info /mnt/root/16.info
umount /mnt/root
rm -r /mnt/root

I hope this helps!

1 Like

Thank you very much!
Thanks to you I regain my faith in people …
Maybe this whole Covid pandemic is messing my brain, I don’t know … :frowning:

1 Like