Schnapps connection to WebDAV - invalid URL

Hello,
currently I’m trying to set the automatic schnapps backup to remote server. I have Synology NAS server with WebDAV enabled. From my personal computer the connection with write permission is working. But if I try the command from documentation :

schnapps upload 8 webdav://turris:<my password>@webdav.mydomain.cz/ /backup/schnapps_backups

It ends with error:

invalid URL
Can't access remote filesystem

Also I tried setup a config file:

config remote 'remote'
        option url 'webdav://wendav.mydomain.cz'
        option path '/backup/schnapps_backups'
        option user 'turris'
        option password '<my password>'
        option sync_types 'single,time'

And command schnapps sync ending with:

/tmp/tmp.OLgFla/dav-config:2: malformed line
Can't access remote filesystem

dav-config file is only temporary so I can’t check what is wrog :frowning:

Did someone auto backups to synology with webdav?

1 Like

You have mistake in this URL - “wendav” instead of “webdav”

It’s only example. My domain is different. :slight_smile:

@xhonzax Did you ever manage to make it work?

I’m asking as I seem to be in the same boat… both using the “nextcloud method” as the webdav one, it keeps resulting in:

invalid URL
Can't access remote filesystem

Did anyone have a solution for the remote upload? I get the same result by a manual upload to the own nextcloud. I get no feedback at the commandline, if I use schnapps sync with the configuration file and can successful run schnapps rlist without any errors…therefore the configuration should be correct.

Hi Guys! Exact same problem here. Did anybody get schnapps upload to NExtcloud to work?