Router starts very slowly after I configured VLANs

I just configured VLAN on my Omnia (before that, all ports were untagged), the network works fine but, now, the router reboots very slowly: four entire minutes between ping starts to fail before it works again. Is there a connection? How can I debug that?

[Not a big issue since my Omnia does not reboot often but it puzzles me.]

The current configuration is:

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 5'
	option vid '1'

config interface 'fbx'
	option proto 'none'
	option send_rs '0'
	option stp '1'
	option type 'bridge'
	option ifname 'eth0.100 eth1.100'
	option auto '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 5t'
	option vid '100'

Problem solved, there was another bridge (the default one, “lan”) which encompassed several interfaces including eth0 and eth0.1. This apparently created a loop, packet loss, broadcast not received (therefore no more DHCP or ARP), etc.