Router reset to earlier configuration after reboot?

I got my Turris Omnia, set it up, did the required updates. Somewhat later I added my first custom interface and firewall zone through LuCI. Finally entering Internet credentials on January 5th.

I finished large parts of my network setup at January 7th, added new interfaces and firewall zones through LuCI. Always using “Save & Apply” button.

On January 10th I added the last interface and firewall zone, also saving it.

Today (January 16th) I restarted my router through LuCI → System → Reboot … and was left with a dysfunctional network. It was reset to a configuration from or after January 5th but before January 7th.

So I looked up reForis and luckily there was a snapshot from January 14th, so I rolled back to it and restarted:

… but it didn’t help, Router still had configuration from January 5th :frowning:

So I had to re-do configuration from (rare) screenshots and memory.

Why did that happen? How can I be sure that next reboot will keep my configuration and this won’t happen again?
Why did a rollback to that earlier snapshot not restore my configuration? (Experienced this earlier too, but just was a small change, so I re-did it manually and forgot to report.)

Turris technical data:

Device             Turris Omnia Wi-Fi 6
reForis version    1.4.1
Turris OS version  6.4.4
Turris OS branch   HBS
Kernel version     5.15.135

Today, I restarted my Turris, and he kept configuration.

So after reading some more of the schnapps documentation I think I know what might have happened.

See my schnapps snapshots:

    # | Type      | Size        | Date                      | Description
    8 | single    |    11.19MiB | 2024-01-05 13:19:56 +0100 | internet and access to DSL webinterface set up
    9 | single    |    11.20MiB | 2024-01-05 14:00:08 +0100 | remove modem zone (moved eth2 to wan)
   10 | rollback  |    11.20MiB | 2024-01-05 15:24:44 +0100 | Rollback to snapshot 8

This shows the events at January 5th - I saved my configuration (8), tried out some other configuration (9) and tried to rollback (10).
After rollback I saw on LuCI that the rollback didn’t work as expected (that’s what I meant with “Experienced this earlier”) and thus manually rolled back to the old configuration by reverting my changes.

The one thing what I didn’t do on that day: Reboot the device.

Then next days went by, I finished large parts of the network setup… until I rebooted on January 16th - that’s where the rollback, that I wanted to do on January 5th, became effective, and my setup was lost.

There’s a “tip” hidden down in the geek schnapps documentation:

Always reboot your Turris after rolling back. Many files are processed only at boot thus unbooted Turris is in inconsistent state and some things may not work as you expected.

Maybe that shouldn’t be a tip somewhere in the documentation - but a bold warning message after rolling back to a snapshot in reForis? Or even an automatism after rolling back to automatically reboot?

This would really have saved me some headache.

1 Like

Agree! It should generate the “reboot needed” notification. It is up to the user to handle it.