Restarting Omnia setup from scratch after persisting trouble

Hi all,

I’m facing untraceable wifi trouble since I received my Omnia. I’m frequently disconnected or having a connection with no data. Since these problems happen on multiple devices I’m suspecting the Omnia. I have tried many suggestions I found on this forum but nothing helped thus far. I’m now planning to do the following until resolved:
1: check antenna connections
2: reset wifi setting through the foris interface
3: reflash the omnia and start from scratch
4: look more closely into the setup of the antenna’s and minipci setup, especially with the USB interference issue (I’m not using any USB devices btw)
5: buy new minipci wlan cards

Anybody any other suggestions or feedback?

Rg,

Arnaud

Try disabling TKIP. LuCI > Network > Wireless > Wireless Security Force CCMP (AES). It should be turned off by default, but anyway.

Souhrn

Check if you have ath10k-firmware-qca988x driver installed in LuCI > System > Software.

Try to scan in LuCI > Network > Wireless neighbouring Wi-Fi. And select manually channel which is not in use. I’ve 5 GHz set to 36 and 2.4 GHz some channel not in use by neighbours.

Or try to switch off 5 GHz Wi-Fi or try to switch it to 2.4 GHz.

I see a fundamental error in channel setup:

2.4GHz manually set the channel between 1 and 11 (eg 5th channel)
5GHz manually set channel outside DSF (eg 36th channel)

Manually set 5G channel and region? That worked here. Region on World, channel 48.

I’ve reset the wifi settings in the foris interface.

The 5Ghz wifi is now using WPA2 PSK (CCMP) and on Channel: 36 (5.180 GHz)
2.4 Ghz is now using WPA2 PSK (CCMP) and on channel 7 (2.442 GHz)

I have ath10k-firmware-qca988x 2018-09-06-327ee47ed6…f-1 installed. (no change from previous)

I’m first going to see how it is now.

Thanks for suggestion so far!

Rg,

Arnaud

Ok, I’ve tested these changes for a while. At first I thought it was doing better but it’s as bad or even worse now. My android phone even marks the wifi as disabled now and then because of frequent failures.

I still don’t know how to debug this. Logs don’t show any hints.

I’m going to open up the turris omnia to see how the antennas are wired.

Rg,

Arnaud

Ok checked wiring and they seem te be according documentation.

to see the bootup messages, you have to dump the “dmesg” buffer to some file, so you ca inspect what is happening during init :wink: , what country-code is detected and what is actually used). Do not be scared by errors there, some are actually “wanted errors” (as lated such error is selfixed – loading of firmware for example)

set the wifi in Foris, once done (save/apply) go to Luci and finish the setup there (and save/apply)… most important is country-code which is in Luci available ; and it is not visibile in Foris (as it should be taken from “regional” setup automatically).
https://openwrt.org/docs/guide-user/network/wifi/wifi_countrycode
This country setting ensures that your router will only enable Wi-Fi radio settings that conform with the countries official regulatory laws.

Dmesg isn’t showing me many hints. I read the firmware errors are normal.

https://justpaste.it/3sbu8

Indeed I’ve set the wifi settings in the foris interface and finished them in Luci. Currently I can’t get 5Ghz to operate while it was working before. But that’s new. 2.4Ghz is still disconnecting frequently. I’m going to check whether the wiring are firmly attached.

I’ve checked the wiring and they seem to be very firm. No loose connectors. Nothing to be done there.
I got 5Ghz working again. I had to run hostapd manually as it wouldn’t start by itself. No errors there and it runs fine now. I’m going to check whether the issues remain otherwise my final solution is to reflash the router and start from scratch.

I’ve reflashed my Omnia using the medkit. One thing I didn’t expect was that I’m now running the newest 5.0 version. It’s much cleaner but my Wifi problems remain.
Close to giving up but my next idea is to move the antennas outside the box. They are now inside a closet which might not be optimal.

In the Reforis interface since Turris OS 5.1, they added an option to install alternative wifi drivers from candela technologies. Give it a try.

Although it’s far from possible but may remove the SSD for a while and place the small wifi again there (that is what default layout is at mine and i never changed that). Maybe the SSD interferres or the 3rd slot is not good for it…but i am really guessing here.

This is how the default setup is: https://www.teltarif.de/img/arch/2016/kw49/TurnisOmnia-2l2.jpg

I’m quite dependent on my ssd. Is there anyway to debug whether the SSD interferes with the wifi?

there is video guide: https://www.youtube.com/watch?v=71_M2N3ga7s
… and very first comment might be helpfull :smiley:

Add some note to description that the PCI addresses of wifi will change, while it might be natural for linux admins, others might wonder why the basic admin web page shows 5Ghz wifi working and 2.4 is not … and LuCI shows suddenly 3 wifi interfaces :smiley: the last step is to log in via ssh and edit /etc/config/wireless ( make a backup first ! ) and delete old radio1 lines and rename radio2 to radio1. This way it can be again setup in web interface… ( reboot the router also after )

ad_2,4G: if you are using both radios, do not use HT40/HT40-/HT40+ for “htmode” option, keep it HT20 . Also you can change “wpa_group_rekey” to some higher value. Also “disassoc_low_ack” should reduce client disassociation/disconnection.

ad_5G: initially try to not use DFS based channels (and if you are indoor, reduce distance or/and txpower). There are also “ff” “turbo” and “bursting” option you can use to make the AP more stable (in my case it helped a lot).

ad_wiring: ensure that you have cables in correspond pin connector (there is description 2,4/5 to indicate for which radio it is). ensure that pins/cables are not touching, laying on any chip). Left antena might interfer with usb port which is below that splitter board, but it should not cause issues on SSD.

Thanks for those remarks. I’ve changed the group rekeying timeout and also set dissassoc_low_ack.

My config is now:

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option macaddr '04:f0:21:32:40:4e'
	option country 'NL'
	option disabled '0'
	option htmode 'VHT20'
	option channel '132'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option disabled '0'
	option ssid 'a25'
	option encryption 'psk2+ccmp'
	option key '******'
	option disassoc_low_ack '0'
	option wpa_group_rekey '345600'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option macaddr '04:f0:21:21:47:df'
	option htmode 'HT20'
	option country 'NL'
	option disabled '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option disabled '0'
	option ssid 'z25'
	option encryption 'psk2+ccmp'
	option key '********'
	option disassoc_low_ack '0'
	option wpa_group_rekey '345600'

config wifi-iface 'guest_iface_0'
	option disabled '1'
	option device 'radio0'

config wifi-iface 'guest_iface_1'
	option disabled '1'
	option device 'radio1'

I’ve had trouble getting 5Ghz up and running again. I think you can’t set the channels to auto. After setting it to a fixed channel it got up again.

See how this goes…

I would try to change channel to 36(which is for indoor,while 136 is using DFS and might not be satisfied with TxPower of your AP or surroundings is crowded on or around that channel) (or “auto”), eventually with option htmode 'VHT80'
I am having also those :
option txpower '23'
option bursting '1'
option ff '1'
option turbo '1'
but i do not see those in options for wireless uci config anymore ([OpenWrt Wiki] Wi-Fi /etc/config/wireless ) so check it first…