Resolving of specific website not working

Hi,

unfortunately there’s one website where the pictures are not resolved properly - this is https://www.otto.de/.
Example picture is https://i.otto.de/i/otto/001_2019_12_mult_marke_bose_25052?$promo_poi_8-3_xl_progressive$
When directly addressing this picture, firefox shows “server not found” (similiar result with safari on iPhone 7 with lates iOS).
Disabling device level adblocker and no-script didn’t help.

My configuration is:

  • Turris Omnia, TOS v.3.11.6
  • adblock installed
  • kresd resolver with following configuration:
    • DoT to 1.1.1.1
    • DNSSEC activated (ISP Deutsche Telekom)
    • Connection test via Foris shows both DNS and DNSSEC as working

I had a similiar problem with pictures on zalando.de, which got resolved by adjusting adblock. But disabling adblock doesn’t help for https://www.otto.de/ (I even tried restarting the router afterwards).

When addressing https://www.otto.de/ either via mobile ISP (same iPhone as above) or via PC connected directly to modem, pictures on https://www.otto.de/ get resolved properly.

Any suggestions?

Best,
ssdnvv

In most cases it is an adblock. Try disabling adblock completely and try pictures.

Another thing to try is to disable dnssec or change the provider, for a few sites i had similar problem in the past.

Edit: the picture does not show for me as well when connecting over turris omnia and i dont use adblock

I don’t know. I tried with exactly the same set up and the names worked fine (several times). I also can’t see anything wrong/risky with www.otto.de (through dnsViz.net), though i.otto.de setup is crazy and I wouldn’t be surprised if it’s fragile.

If the problems still persist, I’d like to see verbose logs, if you’d gather them.

1 Like

As it persists for me (for approx. more than two months by now…) I will gather and attach logs later this day. Thanks.

Sry to not mentioning this:
Disabling adblock on device level as well as no-script were the very first things I tried.
That disabling adblock on domain level didn’t help had already been stated in first post.

Hi, I do have similar problem. Here is the thread a started.

Resolving of specific website not working

May I ask, what provider do you currently have?

Update: Now I see, you are using Deutsche Telekom.

Original post says they use DoT forwarding to 1.1.1.1.