Resolving address

my turris omnia v. refuses resolve address Others resolve well.
knot-resolver version 5.1.2-2

thanks for reasonable explanation :slight_smile:

Viktor Matys

1 Like

TO, the same version, 1st attempt bad, repeated attempts (3rd) OK, resolved. resolved successfully for the first attempt.

Thank you for your answers. Do you think problem could be on ISP side? Upstream resolvers are: and (Luci says)

dig @ works OK.
dig returns nothing


I am out of ideas where to look next :slight_smile:

Viktor Matys

EDIT: I put IP and name to /etc/hosts as a temporary solution.

I see no indication what could cause the issue (and it doesn’t happen for me). Can someone catch the failure with verbose logging?

1 Like

MOX Classic, 5.1.2
Tried to install according to above document, unfortunatelly, error:
"Manually install package
The package resolver-debug is not available in any configured repository.’

Package resolver-debug is compiled and I see that it is present in HBT and HBK, where is a version Turris OS 5.1.2.


Did you run opkg update before trying to install it?

Sorry, I didn’t update package lists as in step 2 of doc. I didn’t understand instructions well, mea culpa. Now is it installed. I’ll try to continue debug resolver.

Tried to debug resolver, at no avail. Win10 Google & Firefox resolved OK, as well as android Google… Sorry.

I’d say that the original error was a casual (random) one, according my own expirience.