Resolve FQDN from DynDNS with local ip address

I know, there are so many threads on this forum about similar problem, but I’m really not getting anywhere until now.
My issue is, that the hostname of my NAS is a URL with dots like “subdomain.hostname.domain” but turris (dnsmasq?) does only recognize “subdomain”
If my devices on the local lan try to connect to the nextcloud or ttrss instance via the external ip (which is what they get from the omnia), they connect to the router, not to the NAS, which fails obviously.

  • Firsts I’ve tried to change the static hostname setting in luci, which doesn’t work (after some research in the forum here)
  • then I’ve tried to enter the domainname as a static DHCP lease and modified /etc/init.d/kresd accordingly, which doesn’t work as well (cannot find the thread where I got this from, I’ll have a look again)
  • Tried the simple edit of /etc/hosts and changed /etc/config/resolver to include the /etc/hosts file via “option hostname_config ‘/etc/hosts’” under the kresd section (locally it does work, but not on my machines -> an iPad, a Debian machine and an Androidphone)

So please bear with me asking this question again, but I can’t find a comprehensive and understandable thread, where this issue is correctly resolved and I’m very thankful for any input or help

Ok, interestingly list hostname_config '/etc/hosts' has to be the first line in /etc/config/resolver and resolver and kresd both needed a restart to work.

If you want to move all dhcp hostnames under .some.longer.subdomain, you can configure that in the Foris UI, DNS tab, options with DHCP in name.