Remote Exception: Internal error 'mac'('<class 'KeyError'>')

Base interface: foris version: 99.7.5
Bookmark LAN and WAN returns the following error:
Remote request

{“module”: “lan”, “action”: “get_settings”, “kind”: “request”}
Stack trace

Traceback (most recent call last):
File “/usr/lib/python3.6/site-packages/foris_controller/message_router.py”, line 117, in process_message
data = module_instance.perform_action(message[“action”], message.get(“data”, {}))
File “/usr/lib/python3.6/site-packages/foris_controller/module_base.py”, line 59, in perform_action
res = action_function(data)
File “/usr/lib/python3.6/site-packages/foris_controller_modules/lan/init.py”, line 34, in action_get_settings
return self.handler.get_settings()
File “/usr/lib/python3.6/site-packages/foris_controller/utils.py”, line 112, in inner
res = func(*args, **kwargs)
File “/usr/lib/python3.6/site-packages/foris_controller_modules/lan/handlers/openwrt.py”, line 41, in get_settings
return self.uci.get_settings()
File “/usr/lib/python3.6/site-packages/foris_controller_backends/lan/init.py”, line 161, in get_settings
dhcp_data, mode_managed[“router_ip”], mode_managed[“netmask”]
File “/usr/lib/python3.6/site-packages/foris_controller_backends/lan/init.py”, line 87, in get_client_list
for e in uci_data
File “/usr/lib/python3.6/site-packages/foris_controller_backends/lan/init.py”, line 88, in
if len(e[“data”][“mac”].split(" ")) == 1 # ignore multi mac records
KeyError: ‘mac’

Any idea what to do with it?
Thanks

the same error on my turris 1.1

I have a 2 month open ticket on support website, but no result

error accidentally resolved. I removed wifi alias of the network in luci, that I had for testing purposes. wan and lan bookmarks is already working.

Please, can you advise me where can i find in luci check/remove the allias? thx

It should be the same issue as tracked on https://gitlab.labs.nic.cz/turris/foris-controller/issues/72

1 Like

No, you didn’t. I have just checked it. You mention internal error ‘network’, not ‘mac’. Anyway, you were provided solution, but you didn’t want to see it. This is completely different one. @vcunat linked the issue. :wink:

@vcunat Yes, that’s exactly the mistake I’m trying to remove :-/