ReForis port issue

Hi guys,

I just upgraded my Omnia from 3.11.9 to 5.1.0. All good (except I had to change from SFP to PHY myself after the upgrade), but

Reforis doesn’t wok for me. The immediately visible behavior is that the page constantly reloads; I’ve been able to capture exactly one JS error, specifically “WebSocket connection to ‘ws://router/foris-ws’ failed: Unexpected response code: 404” in app.min.js:2

Now, I happen to run lighthttpd on port 8080 (instead of the default 80), and I expect that ws://router/foris-ws is the same as ws://router:80/foris-ws (since WS is based AFAIK on sending a connection upgrade header over standard HTTP).
And before you ask, I’ve already confirmed that moving lighttpd to port 80 fixes it :slight_smile:

Do you gents think you can create the websockets connection on the same port as the page was fetched from?


Hi Mircea.

Thank you very much for posting your feedback.

We have already investigated this issue and solved it. It will be available in further updates.

Have a nice day,

Guys, I can confirm Turris 5.1.1 on the Omnia does not fix this issue.

Given the fact that you’ve the fix implemented, it’s probably better to leave this unsolved until you actually ship the fix.

Hello @mionica,

We know that the fix isn’t included in the stable branch of our distribution. Right now, this is fixed in the latest development versions of reForis, which you can find in HBL branch. In this branch, you can test new features, which we are preparing.

We told that it is going to be available in further updates, which is true. Stay tuned for updates.

Sure, no worries. I just wanted to point this out, in case somebody stumbled upon the topic.

I can live with pkgupdate / Foris for now :slight_smile:

Hi guys, I can confirm TurrisOS 5.1.3 got the fix.
Marking the original answer of “we fixed it” as solution.