Reboot doesn't work

just installed the latest one for my mox so i can’t say it works with an update yet…
What is the actual issue cz is trying to tackle, is it MOX cpu hardware related?
If that is the case i would rather suggest a replacement main board unit with modified or updated HW

Update: After the 5.2.6 the mox needed a hard reboot. The interesting part here is that when i got the mox from the crowd funding phase, it had no reboot issues. Always used auto update and reboot without any issues… It started basically after 5.1.x and up.

The config is here very simple…openvpn, adblock, Basic wifi, and thats it. The only thing that is not standard is a custom made vlan on the WAN side.

My experience is identical. I also bought the MOX as part of crowd funding and automatic reboot used to work OK. Hence, the firmware is capable, but there is a compatibility issue with some recent versions of the OS… I am not in a hurry to try the experimental firmware if it doesn’t really bring improvements.

There is a 4th version of the experimental firmware
https://gitlab.nic.cz/turris/mox-boot-builder/-/releases/v2021.09.07.
I flashed it two days ago, at first it behaved like the old one, i.e. it could successfully be restarted immediately after booting but would hang if restarted after several hours uptime (the shortest I tried was 4hrs, usually i tried after approx. 20 hrs). I then tried if it could successfully handle multiple reboots in a row (simply put sleep 300 && reboot in the local startup script and let it reboot for 3 hrs without any problems.
Today I tried again after maybe 15 hrs uptime and the reboot succeeded, I will keep trying if the reboot problem can be reproduced now with the latest firmware, maybe someone else wants to try as well and give feedback.

i will try this later today. But at the current state my MOX does reboot normally, only when an update arrives, or when i (de)activate a package or something it has reboot issues?

Okay, apparently no change, a reboot after 18hrs uptime hangs… that’s really disappointing for a router of this price point - I am giving up on this for the moment, hopefully they can find a real fix for this problem soon…

See my note in another thread: Turris OS 5.2.6 is now in the Testing branch - #19 by jada4p

I tested it more times after installing v4 patch later, mostly it is working. It is improvement, but unfortunately not absolutely reliable.

me think the most easy test is to in or deinstall some package, and see if the reboot works?

edit, installed. but no time fo fidle…

As to me easiest is to power off/on using DIY power cord with switch (made early upon my MOX arrival) and/or issuing reboot command via CLI.

ah, interesting…over here the reboot issue only happens after changing something on the software side?

Just remote tried to reboot the mox after the update, no go. latest patch

Same for me, unfortunately. MOX after update to HBS 5.2.7 hangs after required reboot… otherwise it seems to work.

I do have exactly the same experience. MOX got frozen during reboot, with latest patch (version 4) and right after upgrade to 5.2.7.

What is new with this issue?

What is the status of the reboot hang issue?

I have a Mox running 5.3.4 and it still hangs after rebooting after automatic updates.

I found this experimental firmware - is this still the best way forward?

1 Like

Hello,
there is several releases of the workaround available, and yes, it is still the best way forward.

1 Like

Is that still the best way, but user experience shows that workaround probably does not solve the problem. But it’s definitely good to try and then possibly wait for the new version.

Yey, v4 seems to work for me. I’ll have to wait until there’s an update to know for sure.

1 Like

Unfortunately, v4 workaround still didn’t fix the reboot problem for me :frowning:

1 Like

I took MOX to a company where I don’t normally go and do everything remotely. Everything worked beautifully after the configuration but until the update and automatic restart where I had to go to the company. So now I found out that MOX has been solving a problem with restarts since 2019 and I’m rather surprised and disappointed. I can see in the settings that I can only postpone the automatic restart for 10 days, can the automatic restart be turned off completely?
Should I return the company to Mikrotik again if the developers haven’t moved on with this problem since 2019?

1 Like

I agree with Kospas. For me It is essential to update & reboot the router automatically. My blue Turris 1.0 works like a charm and I’m disappointed MOX just stops working and waits for the human touch. I love Turris MOX but if this issue will not be solved soon I will get rid of it… :frowning:

1 Like