Radio0.network1 disabled and settings blank

I set up my router last night and configured radio0 as 5GHz and radio1 as 2.4GHz with 40 and 20 MHz channel widths respectively. I tried adding another guest network on 2.4 GHz but ran into the bug where the interface edit screen gives error 500, so I ended up doing a factory reset and starting over.

Now after setting it up again, the 5Ghz network was working last night but seems to have disappeared this morning. I don’t think I did anything unusual in setting it up. When I went in to look, the radio shows disabled and the setting boxes are all blank. I’d rather not start over again - what file do I need to edit and what are the default settings in there to bring it back? Thanks. Screenshot below:

Found this in my system log, maybe relevant?

2016-11-06T10:33:08-06:00 info kernel[]: [   12.989025] ath10k_pci 0000:02:00.0: enabling device (0140 -> 0142)
2016-11-06T10:33:08-06:00 info kernel[]: [   12.995708] ath10k_pci 0000:02:00.0: pci irq msi interrupts 1 irq_mode 0 reset_mode 0
2016-11-06T10:33:08-06:00 warning kernel[]: [   13.174190] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/cal-pci-0000:02:00.0.bin failed with error -2
2016-11-06T10:33:08-06:00 warning kernel[]: [   13.184583] ath10k_pci 0000:02:00.0: Falling back to user helper
2016-11-06T10:33:08-06:00 err kernel[]: [   13.194294] firmware ath10k!cal-pci-0000:02:00.0.bin: firmware_loading_store: map pages failed
2016-11-06T10:33:08-06:00 info kernel[]: [   13.211013] ath10k_pci 0000:02:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043202ff sub 0000:0000
2016-11-06T10:33:08-06:00 info kernel[]: [   13.220259] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 1
2016-11-06T10:33:08-06:00 info kernel[]: [   13.229795] ath10k_pci 0000:02:00.0: firmware ver 10.2.4.70-2 api 5 features no-p2p crc32 b722ec09
2016-11-06T10:33:08-06:00 warning kernel[]: [   13.278902] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/board-2.bin failed with error -2
2016-11-06T10:33:08-06:00 warning kernel[]: [   13.289377] ath10k_pci 0000:02:00.0: Falling back to user helper
2016-11-06T10:33:08-06:00 err kernel[]: [   13.299011] firmware ath10k!QCA988X!hw2.0!board-2.bin: firmware_loading_store: map pages failed
2016-11-06T10:33:08-06:00 info kernel[]: [   13.307981] ath10k_pci 0000:02:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
2016-11-06T10:33:08-06:00 warning kernel[]: [   15.410711] ath10k_pci 0000:02:00.0: failed to receive control response completion, polling..
2016-11-06T10:33:08-06:00 err kernel[]: [   16.410708] ath10k_pci 0000:02:00.0: Service connect timeout
2016-11-06T10:33:08-06:00 err kernel[]: [   16.416382] ath10k_pci 0000:02:00.0: failed to connect htt (-110)
2016-11-06T10:33:08-06:00 err kernel[]: [   16.501393] ath10k_pci 0000:02:00.0: could not init core (-110)
2016-11-06T10:33:08-06:00 err kernel[]: [   16.507350] ath10k_pci 0000:02:00.0: could not probe fw (-110)

OK I fixed it. For some reason my radios were being set to CZ. I had tried setting the country through:

iw reg set US

based on this thread, but that didn’t seem to stick. I then set these and rebooted and 5Ghz is back online:

uci set wireless.radio0.country='US'
uci set wireless.radio1.country='US'
uci set wireless.radio0.disabled='0'

my iw reg still seems set to CZ, is that causing it, or is this important? where do I make this stick?

iw reg get
country CZ: DFS-ETSI
        (2400 - 2483 @ 40), (N/A, 20), (N/A)
        (5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR
        (5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS
        (5470 - 5725 @ 160), (N/A, 27), (0 ms), DFS
        (57000 - 66000 @ 2160), (N/A, 40), (N/A)

I also disabled SQM as part of my troubleshooting since reading another thread where that was the issue. I haven’t enabled it yet to test.

To save the changes: “uci commit wireless” and then run “wifi” or reboot.

@Jason_A, for informational purpuses, i wanted to know one thing.

So you can use a “guest wifi”, using your 2.4 GHz network, although you already have a wifi-network using the 2.4 GHz?

Same problem here. Every second reboot the ath10k is gone. I already set mine to DE. Any solution?

I also have the same problem. Every second reboot the ath10k is gone and i also have set the country code.
How can i disable sqm?
Thank you

Maybe if one of you could experiment with the latest ath10k drivers…

Here’s my current situation - both networks are working but I cannot view the radio0 details in LUCI, I get an error 500. I did end up downloading the ath10k firmware yesterday and I’m using the firmware-5.bin_10.2.4.70-2 from hw2.0/10.2.4 as /lib/firmware/ath10k/QCA988X/hw2.0/firmware-5.bin and then reboot.

Here’s my current contents of /etc/config/wireless (with ssid and passwords removed):

config wifi-device 'radio0'
        option type 'mac80211'
        option channel 'auto'
        option country 'US'
        option hwmode '11a'
        option path 'platform/soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
        option htmode 'VHT40'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid ''
        option encryption 'psk2'
        option key ''

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/soc/soc:pcie-controller/pci0000:00/0000:00:01.0/0000:01:00.0'
        option htmode 'HT20'
        option channel 'auto'
        option txpower '19'
        option country 'US'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid ''
        option encryption 'psk2'
        option key ''

do a

uci commit wireless; wifi

after you change /etc/config/wireless.

I’m trying to remember if I changed anything else - I did a lot of reloading of firmware and rebooting but I think this is the final config that worked (except for the error 500 on the web UI). I haven’t rebooted much since, so I don’t know if the config works across reboots.

On a previous router where I was running OpenWRT, this was possible (2 SSIDs on the same band and channel) and I started following the directions on Configure a guest WLAN using the Luci web-interface [Old OpenWrt Wiki] but ran into problems. I might try again using the [OpenWrt Wiki] Guest Wi-Fi basics instructions of just editing the files.

I’m going to reboot a few t imes and will report back if my network goes down.

Rebooting using LUCI or issueing ‘reboot’ in CLI results in ath10k not loading. If I remove power and reapply, then the driver will load correctly.

I was back to radio0 offline, but it seems whatever I just did fixed it again - I had tried adding a txpower and channel to /etc/config/wireless but removing them again looks like it helped. I also had SQM on when I was doing the reboots but now it’s off and things seem fine. Not entirely sure that’s related, since I did a few things at the same time.

I am still getting the error 500 from here: https://github.com/CZ-NIC/turris-os/issues/10 - guess I just have to wait for that update.

I’m also on firmware-5.bin_10.2.4.70.58 if that matters.

Thats little disturbing… how the heck raw break works better than clean reboot via SSH :frowning:

Same problem here for the 5GHz radio. Changing the country code from CZ to DE in LuCI or directly in /etc/config/wireless causes the card to crash: “Wireless is disabled or not associated”. wifi or reboot commands have no effect, even if the country code is set back to CZ. Only removing the power for a couple of seconds will do the trick.
Seems like a serious bug.

1 Like

Not sure if this is the same problem but both of my radios go down after several days. Right now radio0 is down with the same “0% Wireless is disabled or not associated”. message after three days. I also get error 500. radio 1 is still up but I don’t know for how much longer. In either case disabling and the enabling has no effect. wifi down wlan0 gives

Command failed: Not found
wlan0(): Interface type not supported

A reboot fixes it. Any ideas or should I start a new thread?

Holy shit, is this Turris omnia some form of scam?

This is pretty old issue and noone is fixing this shit. I thought we are going to have fast updates.

This should be fixed by this:



But I don’t know when we will receive it to our Turris Omnia and also for previous Turris. I don’t even know why it didn’t make into release. :confused:

This is actually crazy. This router is not even remotely ready for the public.
I’ve had the router plugged in for a matter of hours and I have this issue.
Essentially after the router is restarted the first time after the initial configuration and update the 5GHz wifi is gone for good.
I can restart it via any method, power plug, reboot in ssh, reboot in luci. Nothing works.

What has technical support said?

1 Like

Thankfully i made a backup of my config after i did some mac address reservations and other stuff before i started to tinker with the wireless. I can confirm i’m also having the same issue. At first i thought it was because i was setting the wireless security to force CCMP (AES) encryption, but it seems like anytime i change the country code from CZ to CA (in my case) on either the 2.4 Ghz radio or the 5 GHz radio, it breaks the 5GHz radio. As long as i don’t disable or reboot, 5GHz radio continues to work, even though clicking on edit produces the dreaded internal server error 500.

I agree with anyone who’s said this is a pretty serious bug, i actually got in deep shit with the mrs because i broke the wireless. However, for anyone who’s backed up their config, a restore of my config from the turris GUI did restore connectivity.

@TURRISOMNIATEAM, PLEASE FIX, WHERE’S THE AUTO UPDATE FOR THIS?

EDIT: NOT SURE IF ITS RELATED, but i find after this issue crops up, i have to reboot my switches to restore connectivity (this also happens regardless of whether i make changes or not). PLEASE HELP TURRIS TEAM!

Concur. Where’s the updated firmware that fixes this issue? https://github.com/CZ-NIC/turris-os/issues/10 implies that there is a fix, but no existing build of the firmware has it.

1 Like

5 days ago which I mention here: 500 - Internal Server Error on /wireless/radio0.network1
It was pushed to branch omnia-stable. So we will receive it very soon.

I encountered on this bug after putting a mSATA in the Omnia and off course by following the procedure used in the video-tutorial.

I came to know that the channel on the 5 GHz has A LOT to do with it. The moment i changed it for example to channel 140, it lost tx-power and in a few seconds it just went down. On the net i stumbled upon this.

So apparently each country has a set of channels that permit certain tx-power output. I have experimented with it, but i have the feeling that that information is OR outdated OR incorrect. Me being from the Netherlands tried to use channel 140, however it crashed. I had to change channel and reboot to get it back. Currently i am on channel 128, although looking at the card, it does not stay fixed on channel 128, but it still randomly switches. This causes the tx-power to adapt to certain channel that it is hopping on. Which means getting a weaker signal sometimes.

EDIT2: On LuCi looking at the wireless section, i can clearly see the following.

As you can see that the TX-Rate stays the same all the time, while the RX-Rate changes sometimes. Sometimes both at the same time and sometimes only one as you can see in the pictures. Which is logical because one is my laptop and one is my smartphone. However the output from the 5 GHz has never changed.