Problems configuring DDNS with Turris Omnia and Turris OS 3.10

I just received my Turris Omnia today and I have issues configuring DDNS with ducks dns. With my old Linksys1900ACS and LEDE and never had issues.

When I go to the DDNS configuration tab in the webinterface it shows:

Blockquote
Software update required
The currently installed ‘ddns-scripts’ package did not support all available settings.
Please update to the current version!
Blockquote

But I have the newest version of DDNS installed…

further more when I try to save my DDNS configuration I get the error:

Blockquote
Advanced Settings - IP address source [IPv4]: can not detect local IP. Please select a different Source combination
Blockquote

I get the error no matter what kind of detection of the IP I choose (WAN versus URL)

And the list of DDNS providers is empty, in LEDE I could choose duckdns directly…

can any today help resolve this?

Maybe it is a bug that has already been solved in a newer version as LEDE has latest packages of the softwareapplications.

Currently TurrisOS version of ddns-scripts is 2.7.3-1, while the LEDE package from the snapshot is already on 2.7.7.5. You could download it manually and install it manually.

Just do a wget and opkg install of the package.

You need to install both of them.

Package: https://downloads.openwrt.org/snapshots/packages/x86_64/packages/ddns-scripts_2.7.7-5_all.ipk
Luci-webinterface-package: https://downloads.openwrt.org/snapshots/packages/x86_64/luci/luci-app-ddns_2.4.9-2_all.ipk

1 Like

I installed the files but got a “internal server error” after configuring DDNS… maybe I’ll wait until Turris releases the newer DDNS package

OpenWRT and TO are different repos as it currently is since TO modified some packages from the upstream. However there is no list of which packages actually been tailored to TO and thus utilizing packages from the upstream reop, and snapshots even at that, bears some risks and it is not recommended.

The wait for updated packages in the TO repo to appear might be rather long, perhaps until end of this year when TOS 4 is supposed to utilize packages from the upstream repo directly.

There are frequent recommendations for TO user to compile packages from source themselves.

I had the same problem, but only installed the required ddns-scripts package. After that, it worked right away. The second package that has been suggested by @Big_boss probably causes the error.

Best regards

Hi frechdax

Thanks, that was it. After only installing dns-scripts it works fine!

You are welcome
It was only the ddns-scripts package required so I have renewed just this. It’s best to put it in the localrepo to get no problems with later updates. Or that the updater rolls the package back.

Best regards

Yea i also experienced the luci package with some other software having some error when clicking something, but the basic package does work without problem.

How do I add it to the local repo? But then it isn’t updated by the Turris repo as soon as they update the package themselves?

First time DDNS setup here, I’ve had my omnia since day one.

I enabled the service to run on startup, and tried to configure manually as I had no provider presets. Then I figured out how to get a preset installed, so I installed it. The providers never show in the drop down (even after reboot/service restart) and no matter what I do, I always get the following messages on the config page.

Basic Settings - Custom update-script: unable to update
Advanced Settings - IP address source [IPv4]: can not detect local IP. Please select a different Source combination

Removing and re-adding all ddns associated packages has not helped. I received the following message when removing:
resolve_conffiles: Existing conffile /etc/config/ddns is different from the conffile in the new package. The new conffile will be placed at /etc/config/ddns-opkg.

I manually renamed /etc/config/ddns and copied the new config file as ddns, but that hasn’t helped either.

Suggestions?

As noted in the above posts, install this package:

https://downloads.openwrt.org/snapshots/packages/x86_64/packages/ddns-scripts_2.7.7-5_all.ipk

this worked for me.

1 Like

I’ll go a little further. In the past I always had problems that the packages were rolled back through the updater. As a result, I have dealt more intensively with TurrisOS 3.9, respectively the localrepo.
A good start is these two threads/docs:

But I will explain ddns-scripts with an example:

Personally, I use WinSCP (if you use Windows) a very fine tool in the style of Total Commander, which also has a command history. Simplifies many things.
In the first step you download the appropriate packages by normal download or “wget” into a folder of the Omnia:

https://downloads.openwrt.org/snapshots/packages/x86_64/packages/ddns-scripts_2.7.7-5_all.ipk

If normally downloaded, log in via WinSCP on the Omnia and copy the package in the tree structure to a folder of your choice.
Then you simply navigate into this folder in WinSCP and use the terminal to execute a command in the same folder.

In your case:
“localrepo add ddns-scripts_2.7.7-5_all.ipk”
A cross-check:
Navigate to: /usr/share/updater/localrepo
if you find the package under “User” everything worked fine.

It is already installed, this point I can skip

If you later delete packages from the localrepo folder, here are some useful commands:

“localrepo list” (list of all packages listed in the index for auto and users)
“localrepo clean” (uninstalled packages are removed from the localrepo)
“localrepo check” (the consistency of the index is checked)
“localrepo check --fix” (problems with the index will be fixed)

It’s true that this package is now preferred, but from experience I can say it’s that much easier. The time until the Turris Repository has this version, that can take … And do you want to have so long a not working DDNS?
I hope I could explain it understandably, now your installed package should be maintained even with an update. Also, the updater should not reset it again. If you have any questions, I’m happy to help

Best regards

Nothing else than that the options were merged, he has detected changes / new options and created a new conf file named now -opkg.

Which provider for DDNS do you have?
For example, I can not use the preset for duckdns because nothing works.
On the side of duckdns there are detailed instructions on how to implement it, in my case via script and external address and IPv4. IPv6 would not work yet.

In this case, it is best to visit the website of your provider to find out more.
This site is also good:
https://wiki.openwrt.org/doc/howto/ddns.client

If I still get some details I can help you better :slight_smile:

Best regards

I wish there was a way to mark a post as an answer, as this is the best.

I would also like to point out if you use no-ip.com, cloudflare, etc. you will also need to update the specific script to 2.7.7-5.
i.e.
https://downloads.openwrt.org/snapshots/packages/x86_64/packages/ddns-scripts_no-ip_com_2.7.7-5_all.ipk

Thanks all.

To answer your question, no-ip.com. I poked around on their site, and found the basic instructions at no-ip.com/integrate, but that didn’t help. Upgrading to 2.7.7-5 corrected my issue.

Thanks.

With standard preset or script?
Here is an excerpt from the documentation of Openwrt Wiki:

Last updated: 2015-07-21
Homepage – SupportCenter

:!: Starting CC 15.05 do not forget to additional install ddns-scripts_no-ip_com package.

The default is to use your ‘username’ and ‘password’ as normal inside ddns-scripts together with ‘service_name’ ‘no-ip.com’ or ‘noip.com’.

If you want to update multiple hosts inside one configuration/section you need the following settings:

service_name delete / --custom–
update_url http://[USERNAME]:[PASSWORD]@dynupdate.no-ip.com/nic/update?myip=[IP]&hostname=

	!!! After the 'hostname=' fill in a comma separated list of hosts to update.
	Sample: host1.example.com,host2.example.com,host3.example.com without any spaces in between.
	Sample: http://[USERNAME]:[PASSWORD]@dynupdate.no-ip.com/nic/update?myip=[IP]&hostname=host1.example.com,host2.example.com,host3.example.com

domain [Only ONE of your defined hostnames, i.e. host1.example.com]
username [Your username]
password [Your password]

So it works now? So you get an external IP as an answer and this is also reported no-ip?

Best regards

Hi frechdax

I did as you wrote, and he copied the package into the

/usr/share/updater/localrepo/auto

the “user” folder is empty

Is that OK?

When I do the following command I get this:
root@turris:/tmp# localrepo list
auto:
ddns-scripts: 2.7.7-5
user:
ddns-scripts: 2.7.7-5
root@turris:/tmp#

Please note the points from TurrisOS 3.9 on, find here:
https://doc.turris.cz/doc/en/public/custom_packages

Turis OS >= 3.9

localrepo add /root/custom.ipk

This command do followings:

create repository directory /usr/share/updater/localrepo/user (if not exists)
add it into configuration /usr/share/updater/localrepo/localrepo.lua) (if not exists)
copy specified packages there (ie. into user local repository)

Especially the last paragraph:

Add this definiton to the file /etc/updater/conf.d/user.lua (create it, if not exists)

/etc/updater/conf.d/user.lua

Install("custom", {repository = {"localrepo-user"}})

Check that out and let me know :slight_smile:

Best Regards

localrepo list says it exists but the folder itself is empty? Did you check again? Or a refresh made?

After refresh it is there!! :slight_smile:

Thx alot! Is it OK that it is in user and auto directory?