Problems after factoryreset / re-flash does not work


i needet to reset my omnia to the factory options. Now it runs on 3.2.1, with some “bugs”. So they will not update the pakagelists, there are certification issues. After switch from https to https in the repositorys, so they worke. Not fine but ok.

The automatic Updates are also not working.

Updater failed:
[string “transaction”]:285: [string “transaction”]:132: Collisions:
• /usr/bin/ updater-ng-migration-helper (new), updater-ng (new)

When execuded /usr/bin/, they will end with the Error:

cat: can’t open ‘/tmp/user_notify/1528661696-15519/message_de’: No such file or directory

So i disable otifications, same issue.

Also there is an irritating issue, after an reboot there is no networkconnectivity. I must replug the networkcabel in the normal LAN Interfaces. WAN is ok

So i want reflash, with an newer firmware, hopefully the omnia is working again like before the factoryreset.

USB Stick formated with ext4, in the root directory put the omnia-medkit-latest.tar.gz. Plugin in the USB Port on the front. Hold the resetbutton until the 4 first leds are on.
The led von the usbstick are working, the leds on the omnia are make some … things…

After 1-2 MInutes, it looks like the Omnia is working again. WAN is blinking etc

But the Firmware is also 3.2.1 not like the medkit 3.10.1.

Reboot, new factoryreset all brings nothing…

mabe they cant access the stick? Plugin the Stick in the running Omnia: locate them as /dev/sda, mount success and the tar.gz is viewable. Rights are -rw-r–r-- need more?

Is the omnia-medkit-latest.tar.gz in version 3.2.1? On my normal system(not on the stick):

tar -xzf omnia-medkit-latest.tar.gz
cat etc/turris-version

try FAT and/or another usb drive.

FAT16/FAT32 or does no matter?

Not sure if matters but I usually got it done with FAT16

FAT32 worked for me.

Try repeat re-flash.
Yesterday I had a similar problem.
I tried to reset router to default.
I proceeded as follows: - 3 LEDs: Rollback to factory reset => old version returned (3.8.2) and did not update, the same error as you described.

So i make - 4 LEDs: Re-flash router from flash drive.
First attempt => stayed version 3.8.2.
Second attempt successful => New version installed.

USB disk - 2GB FAT formatted.


the USB stick was the fault…
an new one and the reflash works

1 Like