Problem with WAN port


I have 1crown turris router. Today Internet connection stopped working completely. I tried restart Turris many times. I suspect my ISP had some problem but I connect WAN cable directly to PC or laptop it is working well (I have MAC identification in ISP). Wan port in Turris has right MAC. IF I tried connect cable from PC(I have to network cards) to WAN port in turris it is blinking. If I connect WAN cable to WAN port in turris it is not blinking and not data out or IN. Right now I’m connected to internet directly from my PC. MY ISP is Netbox Brno.

I tried reset turris to previous snaphot too. In configuration it show no WAN, no blinking when cable is connected to router to WAN port.
Is there any diagnostics what can I do on my turris?
If WAN port is broken it is possible temporaly somehow use my PC as router and share internet from WAN -> PC (card1) -> PC (card2) -> LAN port to turris -> wifi and other lans?

If I change LAN1 to WAN it works. It means the WAN looks like broken?