Problem connecting to internet via SFP module

I received this SFP module for my Turris Omnia to connect to my ISP (Telecom/Germany).
I followed this guide for the settings. Sadly this didn’t completely work:


After some further research, I found this thread which seems quiet related to my issues. I was able to follow until it was suggested to execute this command:

/etc/init.d/sfpswitch enable; /etc/init.d/sfpswitch restart && /etc/init.d/network reload && echo 'Success' || echo 'Failed'

For some reason sfpswitch is not present on my installation:

root@turris:~# /etc/init.d/sfpswitch enable; /etc/init.d/sfpswitch restart && /etc/init.d/network reload && echo 'Success' || echo 'Failed'
-ash: /etc/init.d/sfpswitch: not found
-ash: /etc/init.d/sfpswitch: not found
Failed

I was not able to figure out, why this is missing or how I can install it. Prior to the manual upgrade to Foris 101.1.1 this was present. I did the upgrade because the first thread I mentioned suggested, that this SFP module will only work on updated versions. I didn’t get it to work on this version (it was 95.x) so I flashed the most recent version.
Does anybody know why I am missing sfpswitch or what else I could try to establish the connection to my ISP?

Here are some infos on my configuration:

root@turris:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd4a:4d2b:4284::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option ip6assign '60'
        option bridge_empty '1'
        list ifname 'lan0'
        list ifname 'lan1'
        list ifname 'lan2'
        list ifname 'lan3'
        list ifname 'lan4'
        option netmask '255.255.0.0'

config interface 'wan'
        option proto 'pppoe'
        option password '...'
        option ipv6 'auto'
        option ifname 'eth1.7'
        option username '...@t-online.de'

config interface 'wan6'
        option proto 'dhcpv6'
        option ifname '@wan'

config interface 'guest_turris'
        option enabled '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '10.111.222.1'
        option netmask '255.255.255.0'
        option bridge_empty '1'

And here the tail of my log

Feb 18 22:02:39 turris insmod: module is already loaded - ppp_generic
Feb 18 22:02:39 turris insmod: module is already loaded - pppox
Feb 18 22:02:39 turris insmod: module is already loaded - pppoe
Feb 18 22:02:39 turris netifd: wan (3801): ppp: warning: Sleeping for '10' seconds
Feb 18 22:02:49 turris pppd[4089]: Plugin rp-pppoe.so loaded.
Feb 18 22:02:49 turris pppd[4089]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Feb 18 22:02:50 turris pppd[4089]: pppd 2.4.7 started by root, uid 0
Feb 18 22:03:05 turris pppd[4089]: Timeout waiting for PADO packets
Feb 18 22:03:05 turris pppd[4089]: Unable to complete PPPoE Discovery
Feb 18 22:03:05 turris pppd[4089]: Exit.

Thanks in advance.

I wasted a lot of time at the beginning with SFP module, because there`s no real documentation…

Wha VLAN does your ISP need? Is 8 really correct?

Try this:
ln -sf armada-385-turris-omnia-sfp.dtb /boot/dtb
and reboot.

Then check the status:
ls -al /boot/

1 Like

Why do you ask if VLAN 8 is correct? I should be using VLAN 7 for Telekom (according to the guide I mentioned). Did I accidentally configure VLAN 8? If so I don’t see my mistake.

Anyway, here is the output of the command:

root@turris:~# ls -al /boot/
drwxr-xr-x    1 root     root           158 Feb 19 12:53 .
drwxr-xr-x    1 root     root           134 Feb 18 17:47 ..
-rw-r--r--    1 root     root         18773 Jan 26 08:47 armada-385-turris-omnia-phy.dtb
-rw-r--r--    1 root     root         18809 Jan 26 08:47 armada-385-turris-omnia-sfp.dtb
-rw-r--r--    1 root     root          1199 Jan 26 08:47 boot.scr
lrwxrwxrwx    1 root     root            31 Feb 19 12:53 dtb -> armada-385-turris-omnia-sfp.dtb
-rwxr-xr-x    1 root     root       3350808 Jan 26 08:47 zImage

Ah sry that was a typo :confused:
VLAN 7 should be correct and it is also configured…

For me the etc/config/network looks like that:

config interface 'wan'
        option ifname 'eth2.11'
        option proto 'pppoe'
        option username 'XXXXX'
        option password 'XXXXX'
        option force_link '1'
        list dns 'X.X.X.X'
        list dns 'X.X.X.X'
        option mtu '1492'
        option peerdns '0'
        option ipv6 '1'

(VLAN 11 from my ISP)

Did you configure the DNS somewhere?

Since Turris OS 4.X wan interface (which is connected to WAN Port and SFP Port) switched from eth1 to eth2. You are using eth1, which is connected to omnias internal switch.

Thanks @protree for that hint, I have switched to eth2.7 now. Unfortunately my problem still persists afterwards.
@vulgogurktaler my provider does not publish the ip of his dns servers, because they might change. I tried to set the google dns servers (8.8.8.8 and 8.8.4.4) but that also changed nothing, because those servers cannot be reached.

I noticed, that the sfp module indicates a fault, don’t know if this is of any help:

root@turris:~# logread | grep sfp
Feb 19 16:30:39 turris kernel: [   13.936854] sfp sfp: module ALLNET           ALL4781          rev V3.4 sn 0000000FC91BA733 dc 11-01-21
Feb 19 16:30:39 turris kernel: [   13.946229] sfp sfp:   unknown connector, encoding 8b10b, nominal bitrate 1.3Gbps +0% -0%
Feb 19 16:30:39 turris kernel: [   13.954438] sfp sfp:   1000BaseSX+ 1000BaseLX- 1000BaseCX- 1000BaseT- 100BaseTLX- 1000BaseFX- BaseBX10- BasePX-
Feb 19 16:30:39 turris kernel: [   13.964552] sfp sfp:   10GBaseSR- 10GBaseLR- 10GBaseLRM- 10GBaseER-
Feb 19 16:30:39 turris kernel: [   13.970832] sfp sfp:   Wavelength 0nm, fiber lengths:
Feb 19 16:30:39 turris kernel: [   13.975898] sfp sfp:     9µm SM    : unsupported
Feb 19 16:30:39 turris kernel: [   13.980612] sfp sfp:  62.5µm MM OM1: unsupported/unspecified
Feb 19 16:30:39 turris kernel: [   13.986372] sfp sfp:    50µm MM OM2: unsupported/unspecified
Feb 19 16:30:39 turris kernel: [   13.992133] sfp sfp:    50µm MM OM3: unsupported/unspecified
Feb 19 16:30:39 turris kernel: [   13.997891] sfp sfp:    50µm MM OM4: 2.540km
Feb 19 16:30:39 turris kernel: [   14.002263] sfp sfp:   Options: retimer
Feb 19 16:30:39 turris kernel: [   14.006106] sfp sfp:   Diagnostics:
Feb 19 16:30:39 turris kernel: [   18.791417] sfp sfp: module transmit fault indicated
Feb 19 16:30:39 turris kernel: [   21.501453] sfp sfp: module transmit fault recovered
Feb 19 16:30:39 turris kernel: [   21.859740] sfp sfp: module transmit fault indicated
Feb 19 16:30:39 turris kernel: [   22.901432] sfp sfp: module transmit fault indicated
Feb 19 16:30:39 turris kernel: [   28.301417] sfp sfp: module persistently indicates fault, disabling

Today I contacted my provider and they checked my connection. I don’t know what exactly they did but it fixed my issues. So with your proposed changes, my configuration was correct.
Thanks for the help.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.