Post here about the "upcoming update"

You can install it back by searching package ddns-scripts_no-ip_com.


Go check file turris-version located in /etc (you can look for it even in LuCI)
Also in Foris UI (“O routeru” / "About ") you can see Turris version as well.


That’s what I’ve been looking for. Thanks Pepe

Warning: this will reboot your router!

opkg update && opkg install kmod-sched-cake && reboot

Afterwards, in luci, go to Network >> SQM QoS.
In the following screen under the tab Basic settings, tick enable, select the right ethernet port (eth1 if I remember correctly) and set 95% of your max download & max upload speed in kbit/s (experiment with the % value).
Go to the Queue discipline tab, select cake as Queue discipline and select piece_of_cake as Queue setup script.
Reboot yet again and profit!

Ah, good thinking. The reboot is technically not really required:
which qdiscs are currently known to be available?
ls /var/run/sqm/available_qdiscs/
remove the memory
rm /var/run/sqm/available_qdiscs/*
rmdir /var/run/sqm/available_qdiscs
search again whether some specific qdiscs are available
let’s see what changed:
ls /var/run/sqm/available_qdiscs/

The trick is that if the /var/run/sqm/available_qdiscs/ directory does not exist, sqm-scripts will check for the availability of a few selected qdiscs. Since that check is a bit costly and might have side effects (it creates and destroys ifb devices) and the available qdiscs rarely change it was deemed an acceptable compromise to only check on the first sqm-scripts invocation per boot (I still owe a GUI button to re-populate the availabe qdisc directory at run time, but that is low on my list of things todo -ELACKOFTIME).

Also it should not be necessary to reboot after changing sqm-scripts, the GUI should do the right thing if you hit save&apply (ot of you run “/etc/init.d/sqm stop ; /etc/init.s/sqm start” affter editing /etc/config/sqm).

P.S.: has some instructions how to get proceed to configure sqm-scripts. Even though it does not say much about cake it still might be useful

Awesome, thanks.

I was worried after installing the module through opkg that it wasn’t hooked. Tried

insmod sch_cake

for good measure and found it was already installed but couldn’t see it in the SQM Luci page. A reboot did the trick. +1 for a GUI button to refresh the available qdiscs.

This is getting a little off topic, but must I give SQM some bandwidth figures to work with? Is there a way to forego that and use backpressure so I can run close as possible to line rate? I’m under the assumption putting “0” for bandwidth just disables SQM.

I’ve noticed seemingly greatly improved wireless performance after this update. Changing settings in Luci for the 5 GHz adapter is also significantly less flakey and doesn’t cause the adapter to disable (previously only a reboot would bring it back up).

Wireless rate reporting for the 5 GHz adapter is still broken/false but that’s an issue with the driver/firmware itself not reporting the stats back to the kernel.


so setting bandwidth to 0 disables sqm on that direction, correct (enforcing 0 bps bandwidth in one direction will make a link basically unusable, so 0 was “over loaded” to signify “do not shape”). If you have a WAN link that runs at line rate of your interface, you do not need sqm-scripts at all, unless you want to prioritize based on DSCP marks. Cake also offers an auto rate estimator for the downlink, but that capability is not exposed in sqm-scripts.

Thank you for the update but it looks like my repo got repoed :slight_smile: here is my command line error.
WARN:Branch overriden to stable-new
unreachable: curl: (22) The requested URL returned error: 404 Not Found

uci: Entry not found
uci: Entry not found

So which branch would I be using now? ?

sed -i '/kmod-rt2800-pci/d' /etc/updater/auto.lua
opkg install rt2800-pci-firmware_2016-09-21-42ad5367dd38371b2a1bb263b6efa85f9b92fc93-1_mvebu.ipk
opkg install kmod-rt2800-pci
1 Like

Comment “branch” in “/etc/config/updater”:

config override ‘override’
#option branch 'stable-new’
option disable ‘0’

Thank you after I commented out that line updater worked. Thanks for the help.

And why is again re-installing the removed hd-idle? :rage: :tired_face:

You may have to correct “/etc/opkg/distfeeds.conf” too. See again the post:

@iddqd Could you post some directions regarding getting cake configured? Does it survive an update?

Try sqm-scripts and luci-app-sqm, if cake is installed as kernel module (which you might have to do manually), select cake as qdisc and either piece_of_cake.qos or layer_cake.qos. Configuration than mainly happens through the GUI (even though the GUI does not currently expose the more interesting cake option like nat in a user friendly way). It should survive an update, at least it did for me. Also I believe that sqm-scripts was selected as “official” replacement for the venerable wshaper in one of the latest updates.

Best Regards

Sure thing, check this
I have the same experience as @moeller0, cake survived the update.