PCI port #1 issue or msata issue

I have a more or less no name 32Gb msata ssd, which is gpt with a ext4 file system on a single partition. The issue is - it doesn’t work, it isn’t detected and isn’t showing either in dmesg, /dev or lspci, what more I get the following answer with lspci -v (no matter if msata is in or not).

    00:01.0 PCI bridge: Marvell Technology Group Ltd. Device 6820 (rev 04) (prog-if 00 [Normal decode])
    Flags: fast devsel
    Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
    Prefetchable memory behind bridge: 00000000-000fffff
    Capabilities: [40] Express Root Port (Slot+), MSI 00
    lspci: Unable to load libkmod resources: error -12

I did follow the instruction properly and the msata is in the correct slot, according to the leds my pci1 and 2 are occupied (as they should). What is also relevant that the msata ssd is detected and auto-mounted in a usb3 enclosure and works fine.

[   66.240796] usb 3-1: new SuperSpeed USB device number 2 using xhci-hcd
[   66.262037] usb-storage 3-1:1.0: USB Mass Storage device detected
[   66.262216] scsi host2: usb-storage 3-1:1.0
[   67.261179] scsi 2:0:0:0: Direct-Access     KSM-mSAT A.L2-032MS       8105 PQ: 0 ANSI: 6
[   67.261522] sd 2:0:0:0: Attached scsi generic sg0 type 0
[   67.262596] sd 2:0:0:0: [sda] Spinning up disk...
[   68.270746] .ready
[   68.270987] sd 2:0:0:0: [sda] 61865984 512-byte logical blocks: (31.7 GB/29.5 GiB)
[   68.271194] sd 2:0:0:0: [sda] Write Protect is off
[   68.271202] sd 2:0:0:0: [sda] Mode Sense: 33 00 00 08
[   68.271398] sd 2:0:0:0: [sda] No Caching mode page found
[   68.276725] sd 2:0:0:0: [sda] Assuming drive cache: write through
[   68.287408]  sda: sda1
[   68.288998] sd 2:0:0:0: [sda] Attached SCSI disk
[   69.201407] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)

Frankly I am at a loss and can’t really guess the issue here. Is my TO broken?

It should not show in the lspci if it is mSATA drive.

Without mSATA drive I also get the same error message for “lspci -v” command:

lspci: Unable to load libkmod resources: error -12

I would suspect that the drive is incorrectly detected as miniPCIe card. It might be that the drive doesn’t have correct identification so that Omnia could detect it as a mSATA card.

Look for the front of OMNIA at the LEDs.

PCI3 is on the LEFT, PCI2 in the middle, PCI1 is on the right.

Now the print on the box case is wrong: PCI3 is lighting PCI1 LED, PCI1 is lighting PCI3 LED.

You said you put the mSATA in PCI#3. It goes into PCI#1 only. The Wireless Card in #1 gets moved to PCI#3

Looking at the schematic only PCI#1 gets the mSATA connections in the Schematics.

I was judging by the case, so you are right, it is PCI1, which doesn’t light up, even though it is marked as PCI3.

Anything I can do to fix it? Idle speculation and dodgy links are welcome.

Look at this thread:

Thanks for the link, I am reluctant to modify bootloader though, perhaps we can ask the developers to create some config option?

quickshot, have you tried re-install libkmod (and pciutils maybe)?

  root@kukuzi:~# opkg list-installed pciutils
  pciutils - 3.5.1-1
  root@kukuzi:~# opkg list-installed libkmod
  libkmod - 20-1
  root@kukuzi:~# opkg --force-removal-of-dependent-packages remove libkmod&& opkg install libkmod pciutils
  Removing package pciutils from root...
  Removing package libkmod from root...
  Installing libkmod (20-1) to root...
  Downloading https://api.turris.cz/openwrt-repo/omnia/packages//packages/libkmod_20-1_mvebu.ipk.
    % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                   Dload  Upload   Total   Spent    Left  Speed
  100 36878  100 36878    0     0  29163      0  0:00:01  0:00:01 --:--:-- 32320
  Configuring libkmod.
  Installing pciutils (3.5.1-1) to root...
  Downloading https://api.turris.cz/openwrt-repo/omnia/packages//packages/pciutils_3.5.1-1_mvebu.ipk.
    % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                   Dload  Upload   Total   Spent    Left  Speed
  100  293k  100  293k    0     0  87750      0  0:00:03  0:00:03 --:--:-- 87953
  Configuring pciutils.

Hi Perpetual,

Yesterday I received my mSATA SSD and installed it following the instructions of the Turris video. I observed that the LED named PCI3 only lights up when there is activity going on, fx. when copying a (large) file to or from the mSATA drive.

Whelp, fine tuning LED activity is a matter for some other time. I was trying to say that according to emurach, PCI1 - is the pci closest to CPU, where you put mSata, but the corresponding LED is marked as PCI3, so I indeed used PCI1 slot, but was using LED marking as reference.

Just tried to reinstall it, nope, still receive same error. Probably throws it on an empty slot.