I installed an mSATA SSD in the first PCI slot as per the instructions in the official video and moved the smaller wi-fi card to the last PCI slot. The router sees the SSD, but I’m not sure if it detects both wi-fi cards correctly.

Forris interface shows two configurable wi-fi networks without any additional details about the physical devices behind them.

Luci also shows two. One is Qualcomm Atheros QCA9880 802.11bgnac (radio0), but the other is Generic MAC80211 802.11bgn (radio1).

Output of: lspci | egrep -i 'network|ethernet’
02:00.0 Network controller: Qualcomm Atheros QCA986x/988x 802.11ac Wireless Network Adapter
03:00.0 Network controller: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express) (rev 01)

I’m not sure if this is the correct setup. I would add that only the PCI1 and PCI2 LEDs in front of the router are on. The PCI3 LED is off.

I did the same as you.
Foris webinterface only shows the 5ghz radio, I’m guessing they hard-coded some ids in there.
Luci webinterface shows the 5ghz as radio0, a “ghost” radio1 that does nothing, and a working 2,4ghz radio2.
PCI1 and PCI2 are mostly on and sometimes blinking, PCI3 ist blinking very shortly sometimes.

Guys, have you found any solution yet?
I just ended up in the very same situation (shifted the small wifi to another slot in order to install the mSATA).


  • I had to reconfigure the wifi in /etc/config/wireless to make the shifted card working again with my setup
  • Wifi LED’s (PCI1+2) are on
  • mSATA LED (PCI3) is off (I suppose additional setup is needed in /etc/config/system).

Ok, I have failed to set up the LED trigger correctly in /etc/config/system to reflect the mSATA SSD disk activity.
Hopefully someone else will succeed and share.

EDIT: So, not so failed after all :slight_smile:
Just tried to copy a huge file to the SSD from a samba share, and PCI3 LED was happily blinking.

So - this one is obviously working:

config led
option name 'Auto-configuration for PCI3'
option sysfs 'omnia-led:pci3'
option default '0'
option trigger 'sda'

But these two are not:

config led
option default '0'
option name 'SSD read'
option sysfs 'omnia-led:user1'
option trigger 'sda-read'

config led
option default '0'
option name 'SSD write'
option sysfs 'omnia-led:user2'
option trigger 'sda-write'

Not sure if it’s the trigger name or the user led :neutral_face:

I’ve got

config led
        option name 'ssd'
        option sysfs 'omnia-led:pci3'
        option default '1'
        option trigger 'sda'

So it blinks reading and writing like a normal hdd led.

If LEDs are not working for you with SATA or mSATA with above setup, it might be due to autonomous attribute being set to 1 by rainbow, but 0 by led configuration.

To fix this, set rainbow to enabled for given LED in /etc/config/rainbow:

config led 'pci1'
        option color '000f00'
        option status 'enable'

For example complete setup for user LEDs showing sda and sdb activity (with NAS perk):

LED trigger setup in /etc/config/system:

 config led
        option name 'user1'
        option sysfs 'omnia-led:user1'
        option trigger 'sda'
        option default '0'

config led
        option name 'user2'
        option sysfs 'omnia-led:user2'
        option trigger 'sdb'
        option default '0'

Color and status setup in /etc/config/rainbow:

config led 'usr1'
        option color '000f00'
        option status 'enable'

config led 'usr2'
        option color '000f00'
        option status 'enable'

Hi @JamesT42, thanks for your tip on how to set up the sda trigger for
the “pci3” LED. After editing the /etc/config/system file and a reboot it
works and show the traffic of the installed mSATA drive.

But for some reason the changes in the /etc/config/system file are
lost. Any idea why this manually edited information is somehow

Same here.

Updating the file /etc/config/system directly or over the luci web - and one reboot later all is lost and reset

Anyone having success keeping the changes?

Entries having string “Auto-configuration for” in name are reconfigured on reboot. If you want to edit those entries rename them. For example rename ‘Auto-configuration for PCI2’ to ‘PCI2’.


It works and the parameters in /etc/config/system stay persistent, when you change the strings “Auto-configuration for PCIx” into “Configuration for PCIx”. You can edit this in LuCI.

Thanks. So got that part working.

However, the LEDs seem to be not really following the status.
PCI1 and PCI2 LED seem to be always on. I removed the Link status on the wifi for both of them and even shutdown the wifi and these 2 LEDs are unchanged always on.

I’m curious if someone else can try to disable a wireless and have the LED go off…