Pakon.db filling up tmp

pakon

#21

Hello,
that’s almost correct, but you need to stop pakon-monitor first (it copies it’s database to /srv/pakon when the service is stopping).
So:

/etc/init.d/pakon-monitor stop
rm /srv/pakon/*
/etc/init.d/pakon-monitor start

should do the work. Just remember that it deletes the whole history.


PaKon - smazání databáze
#22

In the 3.11 release, the archivation process was reworked quite heavily, hopefully solving this problem. When the “database is locked” error happened before, old flows remained in /var/lib/pakon.db, possibly for many days, which could lead to filling up the whole tmpfs. That hopefully shouldn’t happen anymore.

Also, as a safety measure, we added a hard limit of the /var/lib/pakon.db database. When the database grows too much, the oldest records are deleted. The limit is pretty high, so it should be triggered only when the database is getting really insanely big. It’s probably less than ideal, but we don’t see a better way what to do in this situation. It’s probably better to lose a part of logs than to crash the router.


#23

Thanks alot. Maybe would be nice to have a “Reset” button on https://192.168.1.1/foris/config/main/pakon/ page for resetting the history :wink:


#24

just add the issue again last week. Pakon.db is still filling up all the space:

root@turris:/tmp# du -sh lib/*
0	lib/collectd
0	lib/misc
856.2M	lib/pakon.db

Btw I’m not even using pakon, why is it running ?


#25

There should be something similar like there is rollover for logs, e.g. move data of say the past 24 hours to a secondary db and wipe those secondary db say after a period of 8 or 10 or 14 days. I does not make sense (or does it?) to keep the data indefinitely unless sufficient storage space is available.


#26

Bug is still there, there is no solution ?

root@turris:/tmp# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/mmcblk0p1            7.3G      1.3G      6.0G  18% /
tmpfs                  1010.8M   1010.8M         0 100% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev
root@turris:/tmp# ls -lh ./lib/pakon.db
-rw-r--r--    1 root     root      990.8M Mar 12 15:04 ./lib/pakon.db

How to stop pakon.db ?


#27

Hello ? Is there anyone here ?

It happened again:

root@turris:~# du -sh /tmp/lib/pakon.db
995.1M	/tmp/lib/pakon.db

When it does, foris is unavailable, and kresd is buggy.

So that means the hard limit in pakon.db is not working.

I’ve tried to stop pakon-monitor but it says db is locked. I will try to figure out by whom.


#28

Yes, I do have the same issue as well. Nobody seems to care. Is it possible to uninstall pakon? I do not need it for anything.


#29

Just uncheck it in foris -> updater and click save. It should then be removed (maybe you have to approve it if you have update approvals enabled)


#30

Don’t forget to then also disable device detection as was stated here before.


#31

Nobody seems to care.

The forum is not the proper channel, which you should use to report bugs, also forum is not a bug tracker at all. This was already said on the forum many times. If you’d like to report a bug, we have in our documentation article for Error reporting. I’d kindly ask you to follow it and send us the necessary details. We’d like to have more details about it and diagnostics should help us. Thank you.