Pacon - no records to show

After opkg update and installation I’m getting “no records to show” message. I’ve wait about an hour for data collection. (I have to say installation failed with unknown error but version of OS is now 3.9, Turris Omnia).

Terminal output:

root@turris:~# opkg install pakon Installing pakon (1.1-2) to root... Downloading https://repo.turris.cz/omnia/packages//turrispackages/pakon_1.1-2_mvebu.ipk % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 100 11145 100 11145 0 0 11145 0 0:00:01 --:--:-- 0:00:01 272k Installing sqlite3-cli (3200100-1) to root... Downloading https://repo.turris.cz/omnia/packages//turrispackages/sqlite3-cli_3200100-1_mvebu.ipk % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 100 443k 100 443k 0 0 443k 0 0:00:01 --:--:-- 0:00:01 3518k Installing pakon-lists (1) to root... Downloading https://repo.turris.cz/omnia/packages//turrispackages/pakon-lists_1_mvebu.ipk % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 100 238k 100 238k 0 0 238k 0 0:00:01 --:--:-- 0:00:01 3675k Configuring pakon-lists. Configuring sqlite3-cli. Configuring pakon. Command failed: Not found Command failed: Not found root@turris:~# pakon-show no records to show

What’s happening or what’s missing in my installation?

You probably do not have a suricata installed.
As it is written in the doc https://www.turris.cz/doc/en/howto/pakon “PaKon collects this data from Suricata”.

You may need to wait for a while before you’ll see something. Few minutes should be enough.

Is that the problem, does it show something now?

Not having Suricata shouldn’t be the problem, Suricata is specified as a dependency of PaKon, it should get installed and configured automatically.

Ah, sorry, I overlooked the part about waiting an hour…

Well, the postinstall script is here: https://gitlab.labs.nic.cz/turris/turris-os-packages/blob/test/cznic/pakon/Makefile#L77

It might be missing restarting Suricata, can you try /etc/init.d/suricata restart?

Thanks for your help with debugging, I will fix that in the next release (and write it to the documentation for now).

I guess we rebooted after upgrading, before actually playing with pakon. That restarted suricata too…

Yes, it’s necessary to restart Suricata after installing pakon (it actually brings some part of Suricata’s configuration too). I forgot about that in the postinst script.

Thanks for your help, I’m glad it’s not any bigger problem then this.

1 Like