OpenVPN connection problem

Hi there,

my openvpn connection seems to time out after the succesfull initialization, ping doesnt work either. After a few days of tinkering I´m now pretty much out of ideas…any suggestions?

Thanks for help!

Log

2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: OpenVPN 2.3.6 arm-openwrt-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [MH] [IPv6] built on Sep 5 2016 2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: library versions: OpenSSL 1.0.2j 26 Sep 2016, LZO 2.08 2016-12-17T18:38:25+01:00 warning openvpn(airnether)[4386]: WARNING: file 'user.key' is group or others accessible 2016-12-17T18:38:25+01:00 warning openvpn(airnether)[4386]: WARNING: file 'ta.key' is group or others accessible 2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: Control Channel Authentication: using 'ta.key' as a OpenVPN static key file 2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication 2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication 2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: Socket Buffers: R=[163840->131072] S=[163840->131072] 2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: UDPv4 link local: [undef] 2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: UDPv4 link remote: [AF_INET]109.232.227.137:443 2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: TLS: Initial packet from [AF_INET]109.232.227.137:443, sid=770ebab2 1f8b2886 2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: VERIFY OK: depth=1, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=airvpn.org CA, emailAddress=info@airvpn.org 2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: Validating certificate key usage 2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: ++ Certificate has key usage 00a0, expects 00a0 2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: VERIFY KU OK 2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: Validating certificate extended key usage 2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication 2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: VERIFY EKU OK 2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: VERIFY OK: depth=0, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=server, emailAddress=info@airvpn.org 2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: Validating certificate key usage 2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: ++ Certificate has key usage 00a0, expects 00a0 2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: VERIFY KU OK 2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: Validating certificate extended key usage 2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication 2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: VERIFY EKU OK 2016-12-17T18:38:25+01:00 notice openvpn(airnether)[4386]: VERIFY OK: depth=0, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=server, emailAddress=info@airvpn.org 2016-12-17T18:38:29+01:00 notice openvpn(airnether)[4386]: Data Channel Encrypt: Cipher 'AES-256-CBC' initialized with 256 bit key 2016-12-17T18:38:29+01:00 notice openvpn(airnether)[4386]: Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication 2016-12-17T18:38:29+01:00 notice openvpn(airnether)[4386]: Data Channel Decrypt: Cipher 'AES-256-CBC' initialized with 256 bit key 2016-12-17T18:38:29+01:00 notice openvpn(airnether)[4386]: Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication 2016-12-17T18:38:29+01:00 notice openvpn(airnether)[4386]: Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 4096 bit RSA 2016-12-17T18:38:29+01:00 notice openvpn(airnether)[4386]: [server] Peer Connection Initiated with [AF_INET]109.232.227.137:443 2016-12-17T18:38:32+01:00 notice openvpn(airnether)[4386]: SENT CONTROL [server]: 'PUSH_REQUEST' (status=1) 2016-12-17T18:38:32+01:00 notice openvpn(airnether)[4386]: PUSH: Received control message: 'PUSH_REPLY,redirect-gateway def1 bypass-dhcp,dhcp-option DNS 10.4.0.1,comp-lzo no,route-gateway 10.4.0.1,topology subnet,ping 10,ping-restart 60,ifconfig 10.4.60.48 255.255.0.0' 2016-12-17T18:38:32+01:00 notice openvpn(airnether)[4386]: OPTIONS IMPORT: timers and/or timeouts modified 2016-12-17T18:38:32+01:00 notice openvpn(airnether)[4386]: OPTIONS IMPORT: LZO parms modified 2016-12-17T18:38:32+01:00 notice openvpn(airnether)[4386]: OPTIONS IMPORT: --ifconfig/up options modified 2016-12-17T18:38:32+01:00 notice openvpn(airnether)[4386]: OPTIONS IMPORT: route options modified 2016-12-17T18:38:32+01:00 notice openvpn(airnether)[4386]: OPTIONS IMPORT: route-related options modified 2016-12-17T18:38:32+01:00 notice openvpn(airnether)[4386]: OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified 2016-12-17T18:38:32+01:00 notice openvpn(airnether)[4386]: TUN/TAP device tun0 opened 2016-12-17T18:38:32+01:00 notice openvpn(airnether)[4386]: TUN/TAP TX queue length set to 100 2016-12-17T18:38:32+01:00 notice openvpn(airnether)[4386]: do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0 2016-12-17T18:38:32+01:00 notice openvpn(airnether)[4386]: /sbin/ifconfig tun0 10.4.60.48 netmask 255.255.0.0 mtu 1500 broadcast 10.4.255.255 2016-12-17T18:38:32+01:00 notice netifd[]: Interface 'airvpntun' is enabled 2016-12-17T18:38:32+01:00 notice netifd[]: Network device 'tun0' link is up 2016-12-17T18:38:32+01:00 notice netifd[]: Interface 'airvpntun' has link connectivity 2016-12-17T18:38:32+01:00 notice netifd[]: Interface 'airvpntun' is setting up now 2016-12-17T18:38:32+01:00 notice netifd[]: Interface 'airvpntun' is now up 2016-12-17T18:38:32+01:00 notice firewall[]: Reloading firewall due to ifup of airvpntun (tun0) 2016-12-17T18:38:37+01:00 notice openvpn(airnether)[4386]: /sbin/route add -net 109.232.227.137 netmask 255.255.255.255 gw 172.16.1.1 2016-12-17T18:38:37+01:00 notice openvpn(airnether)[4386]: /sbin/route add -net 0.0.0.0 netmask 128.0.0.0 gw 10.4.0.1 2016-12-17T18:38:37+01:00 notice openvpn(airnether)[4386]: /sbin/route add -net 128.0.0.0 netmask 128.0.0.0 gw 10.4.0.1 2016-12-17T18:38:37+01:00 notice openvpn(airnether)[4386]: Initialization Sequence Completed 2016-12-17T18:41:30+01:00 notice openvpn(airnether)[4386]: [server] Inactivity timeout (--ping-restart), restarting 2016-12-17T18:41:30+01:00 notice openvpn(airnether)[4386]: SIGUSR1[soft,ping-restart] received, process restarting 2016-12-17T18:41:30+01:00 notice openvpn(airnether)[4386]: Restart pause, 2 second(s) 2016-12-17T18:41:32+01:00 notice openvpn(airnether)[4386]: Socket Buffers: R=[163840->131072] S=[163840->131072] 2016-12-17T18:41:32+01:00 notice openvpn(airnether)[4386]: UDPv4 link local: [undef] 2016-12-17T18:41:32+01:00 notice openvpn(airnether)[4386]: UDPv4 link remote: [AF_INET]109.232.227.137:443 2016-12-17T18:41:32+01:00 notice openvpn(airnether)[4386]: TLS: Initial packet from [AF_INET]109.232.227.137:443, sid=b79a2555 760b9ed2 2016-12-17T18:41:32+01:00 notice openvpn(airnether)[4386]: VERIFY OK: depth=1, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=airvpn.org CA, emailAddress=info@airvpn.org 2016-12-17T18:41:32+01:00 notice openvpn(airnether)[4386]: Validating certificate key usage 2016-12-17T18:41:32+01:00 notice openvpn(airnether)[4386]: ++ Certificate has key usage 00a0, expects 00a0 2016-12-17T18:41:32+01:00 notice openvpn(airnether)[4386]: VERIFY KU OK 2016-12-17T18:41:32+01:00 notice openvpn(airnether)[4386]: Validating certificate extended key usage 2016-12-17T18:41:32+01:00 notice openvpn(airnether)[4386]: ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication 2016-12-17T18:41:32+01:00 notice openvpn(airnether)[4386]: VERIFY EKU OK 2016-12-17T18:41:32+01:00 notice openvpn(airnether)[4386]: VERIFY OK: depth=0, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=server, emailAddress=info@airvpn.org 2016-12-17T18:41:36+01:00 notice openvpn(airnether)[4386]: Data Channel Encrypt: Cipher 'AES-256-CBC' initialized with 256 bit key 2016-12-17T18:41:36+01:00 notice openvpn(airnether)[4386]: Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication 2016-12-17T18:41:36+01:00 notice openvpn(airnether)[4386]: Data Channel Decrypt: Cipher 'AES-256-CBC' initialized with 256 bit key 2016-12-17T18:41:36+01:00 notice openvpn(airnether)[4386]: Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication 2016-12-17T18:41:36+01:00 notice openvpn(airnether)[4386]: Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 4096 bit RSA 2016-12-17T18:41:36+01:00 notice openvpn(airnether)[4386]: [server] Peer Connection Initiated with [AF_INET]109.232.227.137:443 2016-12-17T18:41:38+01:00 notice openvpn(airnether)[4386]: SENT CONTROL [server]: 'PUSH_REQUEST' (status=1) 2016-12-17T18:41:38+01:00 notice openvpn(airnether)[4386]: PUSH: Received control message: 'PUSH_REPLY,redirect-gateway def1 bypass-dhcp,dhcp-option DNS 10.4.0.1,comp-lzo no,route-gateway 10.4.0.1,topology subnet,ping 10,ping-restart 60,ifconfig 10.4.60.48 255.255.0.0' 2016-12-17T18:41:38+01:00 notice openvpn(airnether)[4386]: OPTIONS IMPORT: timers and/or timeouts modified 2016-12-17T18:41:38+01:00 notice openvpn(airnether)[4386]: OPTIONS IMPORT: LZO parms modified 2016-12-17T18:41:38+01:00 notice openvpn(airnether)[4386]: OPTIONS IMPORT: --ifconfig/up options modified 2016-12-17T18:41:38+01:00 notice openvpn(airnether)[4386]: OPTIONS IMPORT: route options modified 2016-12-17T18:41:38+01:00 notice openvpn(airnether)[4386]: OPTIONS IMPORT: route-related options modified 2016-12-17T18:41:38+01:00 notice openvpn(airnether)[4386]: OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified 2016-12-17T18:41:38+01:00 notice openvpn(airnether)[4386]: Preserving previous TUN/TAP instance: tun0 2016-12-17T18:41:38+01:00 notice openvpn(airnether)[4386]: Initialization Sequence Completed 2016-12-17T18:47:54+01:00 notice openvpn(airnether)[4386]: [server] Inactivity timeout (--ping-restart), restarting 2016-12-17T18:47:54+01:00 notice openvpn(airnether)[4386]: SIGUSR1[soft,ping-restart] received, process restarting 2016-12-17T18:47:54+01:00 notice openvpn(airnether)[4386]: Restart pause, 2 second(s)

OpenVPN settings file

client dev tun proto udp remote 109.232.227.137 443 resolv-retry infinite nobind persist-key persist-tun remote-cert-tls server cipher AES-256-CBC comp-lzo no route-delay 5 verb 3 ca "ca.crt" cert "user.crt" key "user.key" tls-auth "ta.key" 1

Firewall settings

[CODE]
config defaults
option syn_flood '1’
option input 'ACCEPT’
option output 'ACCEPT’
option forward ‘REJECT’

config zone
option name 'lan’
list network 'lan’
option input 'ACCEPT’
option output 'ACCEPT’
option forward ‘ACCEPT’

config zone
option name 'wan’
list network 'wan’
list network 'wan6’
option input 'REJECT’
option output 'ACCEPT’
option forward 'REJECT’
option masq '1’
option mtu_fix ‘1’

config forwarding
option src 'lan’
option dest ‘wan’

config rule
option name 'Allow-DHCP-Renew’
option src 'wan’
option proto 'udp’
option dest_port '68’
option target 'ACCEPT’
option family ‘ipv4’

config rule
option name 'Allow-Ping’
option src 'wan’
option proto 'icmp’
option icmp_type 'echo-request’
option family 'ipv4’
option target ‘ACCEPT’

config rule
option name 'Allow-IGMP’
option src 'wan’
option proto 'igmp’
option family 'ipv4’
option target ‘ACCEPT’

config rule
option name 'Allow-DHCPv6’
option src 'wan’
option proto 'udp’
option src_ip 'fe80::/10’
option src_port '547’
option dest_ip 'fe80::/10’
option dest_port '546’
option family 'ipv6’
option target ‘ACCEPT’

config rule
option name 'Allow-MLD’
option src 'wan’
option proto 'icmp’
option src_ip 'fe80::/10’
list icmp_type '130/0’
list icmp_type '131/0’
list icmp_type '132/0’
list icmp_type '143/0’
option family 'ipv6’
option target ‘ACCEPT’

config rule
option name 'Allow-ICMPv6-Input’
option src 'wan’
option proto 'icmp’
list icmp_type 'echo-request’
list icmp_type 'echo-reply’
list icmp_type 'destination-unreachable’
list icmp_type 'packet-too-big’
list icmp_type 'time-exceeded’
list icmp_type 'bad-header’
list icmp_type 'unknown-header-type’
list icmp_type 'router-solicitation’
list icmp_type 'neighbour-solicitation’
list icmp_type 'router-advertisement’
list icmp_type 'neighbour-advertisement’
option limit '1000/sec’
option family 'ipv6’
option target ‘ACCEPT’

config rule
option name 'Allow-ICMPv6-Forward’
option src 'wan’
option dest '*'
option proto 'icmp’
list icmp_type 'echo-request’
list icmp_type 'echo-reply’
list icmp_type 'destination-unreachable’
list icmp_type 'packet-too-big’
list icmp_type 'time-exceeded’
list icmp_type 'bad-header’
list icmp_type 'unknown-header-type’
option limit '1000/sec’
option family 'ipv6’
option target ‘ACCEPT’

config include
option path ‘/etc/firewall.user’

config include
option path '/usr/share/firewall/turris’
option reload ‘1’

config include
option path '/etc/firewall.d/with_reload/firewall.include.sh’
option reload ‘1’

config include
option path '/etc/firewall.d/without_reload/firewall.include.sh’
option reload ‘0’

config rule
option src 'wan’
option dest 'lan’
option proto 'esp’
option target ‘ACCEPT’

config rule
option src 'wan’
option dest 'lan’
option dest_port '500’
option proto 'udp’
option target ‘ACCEPT’

config include 'miniupnpd’
option type 'script’
option path '/usr/share/miniupnpd/firewall.include’
option family 'any’
option reload ‘1’

config zone
option name 'vpnfirewall’
option input 'REJECT’
option output 'ACCEPT’
option forward 'REJECT’
option masq '1’
option mtu_fix '1’
list network ‘airvpntun’

config forwarding
option src 'lan’
option dest ‘vpnfirewall’
[/CODE]

Network settings

[CODE]
config interface 'loopback’
option ifname 'lo’
option proto 'static’
option ipaddr '127.0.0.1’
option netmask ‘255.0.0.0’

config globals 'globals’
option ula_prefix ‘fd47:05bf:dea9::/48’

config interface 'lan’
option ifname 'eth0 eth2’
option force_link '1’
option type 'bridge’
option proto 'static’
option ipaddr '192.168.1.1’
option netmask '255.255.255.0’
option ip6assign ‘60’

config interface 'wan’
option ifname 'eth1’
option proto 'dhcp’
option peerdns '0’
list dns '208.67.222.222’
list dns ‘208.67.220.220’

config interface 'airvpntun’
option proto 'none’
option ifname ‘tun0’

config interface 'wan6’
option ifname '@wan
option proto ‘none’

config switch
option name 'switch0’
option reset '1’
option enable_vlan ‘1’

config switch_vlan
option device 'switch0’
option vlan '1’
option ports ‘0 1 2 3 5’

config switch_vlan
option device 'switch0’
option vlan '2’
option ports ‘4 6’
[/CODE]

In my configuration I set the network in the zone as option network instead of list network, and the other difference i have is that I have option input "ACCEPT" instead of REJECT.

Maybe some wiki-doku might help. I think that uci syntax for zone is having list as list-of-values not like operation to list something. … and in another configs list is valid element…yep, nice and confusing me still , so i have that wiki open and always check ref. (not always 100% and corresponding with TO fork of openWRT, but very handy …)

Just tried the option network and option input "ACCEPT" changes, still only timeout…

I have same problem, other clients work without problems. tun0 receive ip … no problem in log … but icmp or data to other clients not working.

OpenVPN server is Centos 7

I’m not having any problems in accepting (acting as server) or connecting (acting as client).

vpn0 is my server, and vpn1 the client.

config interface 'vpn0'
        option ifname 'tun0'
        option proto 'none'
        option auto '1'

config interface 'vpn1'
        option ifname 'tun1'
        option proto 'none'
        option auto '0'
config zone
        option input 'ACCEPT'
        option forward 'REJECT'
        option output 'ACCEPT'
        option name 'vpn'
        option masq '1'
        option network 'vpn0 vpn1'

config forwarding
        option dest 'lan'
        option src 'vpn'

config rule
        option target 'ACCEPT'
        option proto 'tcp'
        option dest_port '1194'
        option name 'openvpn_inbound'
        option src '*'

(the last rule is only needed because I need inbound connections).

Seems like the option dest and option src points are interchanged in your config, tried it with mine, but no luck - still no connection…

Hmmm i think i know where is problem :slight_smile: i dont use lzo too, maybe OpenVPN on omnia has problem with that (in default is on). Try turn on LZO compression. I try it tomorow on my VPN

Nice idea, didnt tried that yet. Unfortunately no effect, still no connection - but a new entry in the log I didnt see before:

2016-12-19T17:16:13+01:00 notice openvpn(airnether)[3453]: SENT CONTROL [server]: ‘PUSH_REQUEST’ (status=1)
2016-12-19T18:16:23+01:00 notice openvpn(airnether)[]: Last message ‘SENT CONTROL [server’ repeated 1 times, supressed by syslog-ng on turris

Ok, i tried it and it works !! :slight_smile: looks like bug in luci webUI (question for developers) … if you dont want to use LZO compression just delete “option comp-lzo no” in configuration file on Omnia.

For info and comparison:

Server config
#################################################
# Sample OpenVPN 2.0 config file for            #
# multi-client server.                          #
#                                               #
# This file is for the server side              #
# of a many-clients <-> one-server              #
# OpenVPN configuration.                        #
#                                               #
# OpenVPN also supports                         #
# single-machine <-> single-machine             #
# configurations (See the Examples page         #
# on the web site for more info).               #
#                                               #
# This config should work on Windows            #
# or Linux/BSD systems.  Remember on            #
# Windows to quote pathnames and use            #
# double backslashes, e.g.:                     #
# "C:\\Program Files\\OpenVPN\\config\\foo.key" #
#                                               #
# Comments are preceded with '#' or ';'         #
#################################################

# Which local IP address should OpenVPN
# listen on? (optional)
;local a.b.c.d

# Which TCP/UDP port should OpenVPN listen on?
# If you want to run multiple OpenVPN instances
# on the same machine, use a different port
# number for each one.  You will need to
# open up this port on your firewall.
port 1194

# TCP or UDP server?
;proto tcp
proto udp6

# "dev tun" will create a routed IP tunnel,
# "dev tap" will create an ethernet tunnel.
# Use "dev tap0" if you are ethernet bridging
# and have precreated a tap0 virtual interface
# and bridged it with your ethernet interface.
# If you want to control access policies
# over the VPN, you must create firewall
# rules for the the TUN/TAP interface.
# On non-Windows systems, you can give
# an explicit unit number, such as tun0.
# On Windows, use "dev-node" for this.
# On most systems, the VPN will not function
# unless you partially or fully disable
# the firewall for the TUN/TAP interface.
;dev tap
dev tun

# Windows needs the TAP-Win32 adapter name
# from the Network Connections panel if you
# have more than one.  On XP SP2 or higher,
# you may need to selectively disable the
# Windows firewall for the TAP adapter.
# Non-Windows systems usually don't need this.
;dev-node MyTap

# SSL/TLS root certificate (ca), certificate
# (cert), and private key (key).  Each client
# and the server must have their own cert and
# key file.  The server and all clients will
# use the same ca file.
#
# See the "easy-rsa" directory for a series
# of scripts for generating RSA certificates
# and private keys.  Remember to use
# a unique Common Name for the server
# and each of the client certificates.
#
# Any X509 key management system can be used.
# OpenVPN can also use a PKCS #12 formatted key file
# (see "pkcs12" directive in man page).
ca ca.crt
cert server.crt
key server.key  # This file should be kept secret

# Diffie hellman parameters.
# Generate your own with:
#   openssl dhparam -out dh2048.pem 2048
dh dh2048.pem

# Network topology
# Should be subnet (addressing via IP)
# unless Windows clients v2.0.9 and lower have to
# be supported (then net30, i.e. a /30 per client)
# Defaults to net30 (not recommended)
topology subnet

# Configure server mode and supply a VPN subnet
# for OpenVPN to draw client addresses from.
# The server will take 10.8.0.1 for itself,
# the rest will be made available to clients.
# Each client will be able to reach the server
# on 10.8.0.1. Comment this line out if you are
# ethernet bridging. See the man page for more info.
server 10.12.12.0 255.255.255.0

# Maintain a record of client <-> virtual IP address
# associations in this file.  If OpenVPN goes down or
# is restarted, reconnecting clients can be assigned
# the same virtual IP address from the pool that was
# previously assigned.
ifconfig-pool-persist ipp.txt

# Configure server mode for ethernet bridging.
# You must first use your OS's bridging capability
# to bridge the TAP interface with the ethernet
# NIC interface.  Then you must manually set the
# IP/netmask on the bridge interface, here we
# assume 10.8.0.4/255.255.255.0.  Finally we
# must set aside an IP range in this subnet
# (start=10.8.0.50 end=10.8.0.100) to allocate
# to connecting clients.  Leave this line commented
# out unless you are ethernet bridging.
;server-bridge 10.12.12.4 255.255.255.0 10.12.12.10 10.12.12.20

# Configure server mode for ethernet bridging
# using a DHCP-proxy, where clients talk
# to the OpenVPN server-side DHCP server
# to receive their IP address allocation
# and DNS server addresses.  You must first use
# your OS's bridging capability to bridge the TAP
# interface with the ethernet NIC interface.
# Note: this mode only works on clients (such as
# Windows), where the client-side TAP adapter is
# bound to a DHCP client.
;server-bridge

# Push routes to the client to allow it
# to reach other private subnets behind
# the server.  Remember that these
# private subnets will also need
# to know to route the OpenVPN client
# address pool (10.8.0.0/255.255.255.0)
# back to the OpenVPN server.
;push "route 10.12.12.0 255.255.255.0"
;push "route 192.168.20.0 255.255.255.0"

# To assign specific IP addresses to specific
# clients or if a connecting client has a private
# subnet behind it that should also have VPN access,
# use the subdirectory "ccd" for client-specific
# configuration files (see man page for more info).

# EXAMPLE: Suppose the client
# having the certificate common name "Thelonious"
# also has a small subnet behind his connecting
# machine, such as 192.168.40.128/255.255.255.248.
# First, uncomment out these lines:
;client-config-dir ccd
;route 192.168.40.128 255.255.255.248
# Then create a file ccd/Thelonious with this line:
#   iroute 192.168.40.128 255.255.255.248
# This will allow Thelonious' private subnet to
# access the VPN.  This example will only work
# if you are routing, not bridging, i.e. you are
# using "dev tun" and "server" directives.

# EXAMPLE: Suppose you want to give
# Thelonious a fixed VPN IP address of 10.9.0.1.
# First uncomment out these lines:
client-config-dir ccd
;route 10.9.0.0 255.255.255.252
# Then add this line to ccd/Thelonious:
#   ifconfig-push 10.9.0.1 10.9.0.2

# Suppose that you want to enable different
# firewall access policies for different groups
# of clients.  There are two methods:
# (1) Run multiple OpenVPN daemons, one for each
#     group, and firewall the TUN/TAP interface
#     for each group/daemon appropriately.
# (2) (Advanced) Create a script to dynamically
#     modify the firewall in response to access
#     from different clients.  See man
#     page for more info on learn-address script.
;learn-address ./script

# If enabled, this directive will configure
# all clients to redirect their default
# network gateway through the VPN, causing
# all IP traffic such as web browsing and
# and DNS lookups to go through the VPN
# (The OpenVPN server machine may need to NAT
# or bridge the TUN/TAP interface to the internet
# in order for this to work properly).
;push "redirect-gateway def1 bypass-dhcp"

# Certain Windows-specific network settings
# can be pushed to clients, such as DNS
# or WINS server addresses.  CAVEAT:
# http://openvpn.net/faq.html#dhcpcaveats
# The addresses below refer to the public
# DNS servers provided by opendns.com.
;push "dhcp-option DNS 208.67.222.222"
;push "dhcp-option DNS 208.67.220.220"

# Uncomment this directive to allow different
# clients to be able to "see" each other.
# By default, clients will only see the server.
# To force clients to only see the server, you
# will also need to appropriately firewall the
# server's TUN/TAP interface.
client-to-client

# Uncomment this directive if multiple clients
# might connect with the same certificate/key
# files or common names.  This is recommended
# only for testing purposes.  For production use,
# each client should have its own certificate/key
# pair.
#
# IF YOU HAVE NOT GENERATED INDIVIDUAL
# CERTIFICATE/KEY PAIRS FOR EACH CLIENT,
# EACH HAVING ITS OWN UNIQUE "COMMON NAME",
# UNCOMMENT THIS LINE OUT.
;duplicate-cn

# The keepalive directive causes ping-like
# messages to be sent back and forth over
# the link so that each side knows when
# the other side has gone down.
# Ping every 10 seconds, assume that remote
# peer is down if no ping received during
# a 120 second time period.
keepalive 10 60

# For extra security beyond that provided
# by SSL/TLS, create an "HMAC firewall"
# to help block DoS attacks and UDP port flooding.
#
# Generate with:
#   openvpn --genkey --secret ta.key
#
# The server and each client must have
# a copy of this key.
# The second parameter should be '0'
# on the server and '1' on the clients.
;tls-auth ta.key 0 # This file is secret

# Select a cryptographic cipher.
# This config item must be copied to
# the client config file as well.
;cipher BF-CBC        # Blowfish (default)
cipher AES-128-CBC   # AES
;cipher DES-EDE3-CBC  # Triple-DES

# Enable compression on the VPN link.
# If you enable it here, you must also
# enable it in the client config file.
;comp-lzo

# The maximum number of concurrently connected
# clients we want to allow.
;max-clients 100

# It's a good idea to reduce the OpenVPN
# daemon's privileges after initialization.
#
# You can uncomment this out on
# non-Windows systems.
user nobody
group nobody

# The persist options will try to avoid
# accessing certain resources on restart
# that may no longer be accessible because
# of the privilege downgrade.
persist-key
persist-tun

# Output a short status file showing
# current connections, truncated
# and rewritten every minute.
status openvpn-status.log

# By default, log messages will go to the syslog (or
# on Windows, if running as a service, they will go to
# the "\Program Files\OpenVPN\log" directory).
# Use log or log-append to override this default.
# "log" will truncate the log file on OpenVPN startup,
# while "log-append" will append to it.  Use one
# or the other (but not both).
;log         openvpn.log
;log-append  openvpn.log

# Set the appropriate level of log
# file verbosity.
#
# 0 is silent, except for fatal errors
# 4 is reasonable for general usage
# 5 and 6 can help to debug connection problems
# 9 is extremely verbose
verb 3

# Silence repeating messages.  At most 20
# sequential messages of the same message
# category will be output to the log.
;mute 20

#possible bandwidth increase
sndbuf 393216
rcvbuf 393216
push "sndbuf 393216"
push "rcvbuf 393216"
#UDP server set
multihome
Client config
client
dev tun
remote remote.xyz
resolv-retry infinite
nobind
persist-key
persist-tun
ca /etc/openvpn/ca.crt
cert /etc/openvpn/cert.crt
key /etc/openvpn/key.key
verb 1
keepalive 10 60
port 1194
proto udp
remote-cert-tls server
cipher AES-128-CBC
Omnia client config
config openvpn 'client_tun'
        option nobind '1'
        option client '1'
        option dev 'tun'
        option persist_tun '1'
        option persist_key '1'
        option remote_cert_tls 'server'
        list remote 'remote.xyz'
        option ca '/etc/luci-uploads/cbid.openvpn.client_tun.ca'
        option cert '/etc/luci-uploads/cbid.openvpn.client_tun.cert'
        option key '/etc/luci-uploads/cbid.openvpn.client_tun.key'
        option keepalive '10 60'
        option verb '2'
        option enabled '1'
        option cipher 'AES-128-CBC'
1 Like

Yeah, you´re right! It works only with TCP in my config, but that okay with me for now - thanks!