Ongoing Challenges With DHCP & Eth0 / VLAN1 Ethernet Ports

Hi Turris Omnia Cz.nic team, All

So, I have been monitoring the strange event on my Turris Omnia since receiving it a couple of weeks ago. I have been collecting the “Messages Log”, “Dmesg Output” and “Network Output” as suggested as part of the problem solving Trouble Shooting Guide.

My Setup is as follows: I have separated the Eth0 and Eth2 Lan Interfaces into 2 x Subnets / VLANS (Vlan1 & Vlan2) in addition to this I have a further 3 x Vlans setup on Eth0 / Vlan1 using the Switch functionality. Vlan1 uses Ports 0 - 3 and the Eth1 / WAN Interface and Vlan2 uses Port 4 on Eth1 / WAN6 Interface

Everything works really well; this was not a simple task and took multiple attempts and Factory Resets before getting working as i want.

My issue is this. Each morning all the Cat6 Ethernet Devices cannot receive any DHCP on Eth0 / Vlan1, the DHCP on Eth2 / Vlan2 works fine.
To Troubleshoot this have tried various things as follows:

  1. I set Static IP’s to all devices on Eth0 / Vlan1, this didn’t help. I saw that despite setting Fixed IP, the DNSmasq was repeatedly resetting the DHCP Leases throughout the day
  2. I disabled the DHCP / DNSmasq as i could see it was trying to ignore the static IP’s; the downside of this meant that now I had to make everything on Vlan1 / Eth0 a static as there was no DHCP allocation. This actually worked well for the next 48hours as each morning the Devices on Vlan1 all received their Fixed IP / DHCP Addressing.

After 48 Hours I had the same issue as the Devices were once again not being assigned an IP, despite being static. This was easily resolved by performing a reboot, but i forgot to collect the Logs on that occasion before rebooting.

I have noticed that if I wait long enough, 2,3,4,5hrs , each Wired Ethernet Device does eventually receive its Fixed IP settings without any reboots.

I appreciate this is quite minor, but having to follow the same procedure on a daily basis is Very Frustrating. I have the Logs as suggested for the last couple of days which I can send across if needed?? Unfortunately the Logs do not really highlight anything, despite DEBUG Logging being set.

Is there was a known “Bug” with the Ethernet Ports on the Turris Omnia and when you think a Fix will be implemented?

Any feedback would be appreciated

Previous Posts: