Omnia loosing LAN/WAN connection regularly for some seconds


#1

Hi,

Since some weeks I’m experiencing WAN/LAN dropouts I’m unclear though if it’s just WAN itself or also LAN. I’m just experiencing disconnects in VoIP calls every 30-90 minutes, VPN disconnects and also when using Online Games I have disconnects every now and then. It normally lasts only about 5-10 seconds. As all of this stuff is WAN based it maybe just WAN failing for some seconds. The only thing where I could observer it so war was running a ping when it happened and it seemed like for 1-2 pings got very slow and then recovered. So it could also mean that LAN is affected as well.

My biggest problem is, what could cause it and how to make sure if it’s the omnia loosing the connections or the cablemodem from my ISP. And if it’s the Omnia if it’s LAN or just WAN?

The strange thing is that my omnia ran without any bigger problems for at least 1-2 years (except of some occasional updater problems). And since some weeks I’m having this problems, updating to latest version which I do regularly anyhow didn’t help at all but for a problem like this I’m really out of ideas on how to diagnose the issue and it’s slowly driving me nuts that I have WAN connection droput every 30-90 minutes for some seconds.

Any help whatsoever would be greatly appreciated…

UPDATE: could this be related to this strange error message in /var/log/messages?

2018-11-24 19:32:06 info dnsmasq-dhcp[28349]: DHCPRELEASE(br-lan) 192.168.10.157 70:ee:50:16:15:92
2018-11-24 19:32:06 warning dnsmasq-dhcp[28349]: not giving name PORTAL.lan to the DHCP lease of 192.168.10.175 because the name exists in /tmp/hosts/dhcp with address 192.168.10.179
2018-11-24 19:32:06 warning dnsmasq-dhcp[28349]: not giving name PORTAL to the DHCP lease of 192.168.10.175 because the name exists in /tmp/hosts/dhcp with address 192.168.10.179
2018-11-24 19:32:06 info dhcp_host_domain_ng.py[]: DHCPv4 new lease
2018-11-24 19:32:06 warning dhcp_host_domain_ng.py[]: Add_lease, hostname check failed
2018-11-24 19:32:06 warning dhcp_host_domain_ng.py[19804]: Last message 'Add_lease, hostname ' repeated 17 times, suppressed by syslog-ng on turris.lan
2018-11-24 19:32:06 info dhcp_host_domain_ng.py[]: DHCP delete hostname [del,Netatmo-Personal-Weather-Station,192.168.10.157]
2018-11-24 19:32:06 debug dnsmasq-script[28349]: uci: Entry not found
2018-11-24 19:32:06 err dhcp_host_domain_ng.py[]: Kresd socket failed:<class 'socket.error'>,[Errno 111] Connection refused
2018-11-24 19:32:06 warning dnsmasq[28349]: script process exited with status 1

I’m seeing this regularly in the logs. Especially th “socket.error” worries me