Omnia jako WIFI AP, problém s dhcp

Zdravím,
mám doma dva Turrisy, původního jedničkového modráka a omnii.

Původního turrise jsem před časem upgradoval na turris os 5, při té příležitosti jsem modráka i omnii vyresetoval a vše nastavoval znovu. Od té doby mám problémy s wifi.

Modrý turris je výchozí, připojen k internetu, omnia je připojená kabelem a na druhém konci bytu tak slouží jako switch/wifi ap.

Omnii jsem nastavil dle [OpenWrt Wiki] Wireless Access Point / Dumb Access Point
Na omnii je tedy vypnuté dhcp, wifi sítě mají stejný název i heslo, jiné kanály, a zapnuté 802.11r fast transition.

Vše na první pohled funguje, ovšem při přechodu od turrise k omnii s nějakým bezdrátovým zařízením (tablet, telefon, atd.) sice přeskočím na silnější wifi omnie, ovšem v zápětí zařízení dostane ip 169.254.x.x

Pokud si u omnie zažádám s novou mac adresou o novou ip, dostanu klasicky 192.168.x.x, jsem připojen a pokud přejdu zpět k modrákovi wifi se mi drží, přeskočí na modráka a jsem stále připojen.

Celé nastavení jsou zkoušel opakovaně, ani nevím kolikrát jsem už za posledních pár dní omnii vyresetoval do továrního nastavení a nastavil znovu

Jediná podivnost která se mi opakovaně děje, je že v interfaces vidím wlan0 nepřipojenou do lan (a nejde přiřadit do lan), v luci se vše tváří v pořádku


Potvrzuji naprosto stejný problém (a i fakticky i stejnou konfiguraci zařízení). U všech přemísťujících se zařízení připojených na wifi byla nastavena náhodná MAC adresa. Po nastavení na MAC adresa zařízení se situace zlepšila, k problému nedojde s každým “přechodem” od modráka k omnii, ale dochází k tomu stále, takže to není řešení. Budu zkoumat dál a zároveň doufat, zda se v tomto vlákně najde nějaké řešení.