Omnia can't boot, all LEDs lighting from green to red in loop

Hi, my Omnia won’t boot. After connecting power just flash once with blue led and than start lighting leds from green to red one by one, when all is red starts again. I let it several hours and still looping. I also tried removing all cards but still the same state.

  • I don’t know if its HW or software problem.
  • I don’t know exactly how it starts, because my Omnia was in flat where I was not living for some time. Current rentier just switch to his own router doesn’t tell me if it was because of not working WiFi or because of estetic reasons ( I leaved it without cover and with big weird heatsink )
  • Might be just coincidence but last message I get from router was about planned restart after system update on 26.March and since 27.March I getting only downtime summary.

Please can anybody give me some advice how to recover? No matter data lose…


From the video, I don’t like how the thermal pad looks. What I can see and what could be related to your issue is that the reset button is somehow stuck. Can you remove the board from the case and try the plug the power supply? Be very careful where you put the board from the case as it is electronics when you remove it from the case as static electricity could happen and damage the router.

If the issue is the same when you remove the board from the case then most probably this issue can not be solved here. Reach our Technical support on Me or somebody else will respond to your issue.

Yes, it looks like a jammed reset button.
If it’s not a button, try connecting via a serial link to see the boot process:

Thanks. Problem persist even after removing board from case… I will try the serial link, when I get the right cable somewhere.

By thermal pad you mean the aluminium cooling block? It’s dirty from thermal paste.

Check if the “click” button. Try to squeeze several times. What is interesting is that right after the connection, it acts like a button pressed. It may be destroyed and replacement or service is required.

Has this issue been solved? I encounter the same problem. I fear to have damaged the board while manipulating it outside its case. But I checked the button and the test point TP54, signal goes to GND when the button is pressed, otherwise it’s up to 3.3V. There’s no shortcut between the button and the STM32F030R8T6 pin 26.

Does anyone have any idea of what could have been damaged?

Any Updates? Did you manage to fix it? Mine arrived today and after a mode 4 flash is doing the same

Hi, yes issue was resolved. I sent it to manufacturer and they told me the board is dead and offered me free recycle of electronic trash. :frowning: I think motherboard was burned because I added button to GPIO to switch wifi on and off and this button starts to switch randomly (I saw melted chip on one wireless card). So be careful with hacking :wink:

Guess what, you were right. The sad thing is that mine self-combusted, i wasn’t even tinkering with it