Nový updater - error

Dobrý den, asi před 14 dny jsem provedl migraci na nový Updater dle návodu: https://www.turris.cz/doc/cs/howto/updater_migration. Vše se zdálo být v pořádku, ale asi před 2 dny jsem začal nestálé dostávat email:

Oznámení o chybách

Updater selhal:
inconsistent: Requested package luci-app-lxc that is not available.

Když zkusím spustit ručně updater.sh, tak je situace stejná a hned dostanu email s chybou.

Poradil by někdo, co bych mohl udělat pro nápravu?
Děkuji

Tuhle chybu dostávám od 26.2. Nejspíš bude potřeba kontaktovat oficiálně podporu.
Psal jsem to na IRC a opět jsem pingnul miska, ale zatím žádná změna. (Jsem občas otravnej, já vím! :-D)

Pokud nepotřebujete LXC kontejnery tak opkg remove luci-app-lxc a pak se updater spustí.
Případně by mělo pomoci i odebraní list lists ‘lxc’ z /etc/config/updater

Zřejmě začnu zaplavovat podporu emaily z nightly branch. :smiley:

Tak po příkazech:
opkg remove luci-app-lxc
updater.sh

Jsem dostal email:

Oznámení o chybách

Updater selhal:
inconsistent: Requested package lxc-create that is not available.

Každopádně LXC využívám, takže je mazat nechci, v etc/config/updater jsem LXC ani neměl uvedeno, zkusil jsem jej i přidat, ale situace se nezměnila…

Taky mam novy updater, ale jakakoliv snaha o spusteni updater.sh konci nasledovne:

root@turris:~# updater.sh
WARN:Script revision-specific not found, but ignoring its absence as requested
WARN:Script serial-specific not found, but ignoring its absence as requested
WARN:Lock on //var/lock/opkg.lock released by garbage collector

Tohle je v pořádku. Je to jen upozornění.

To @kosi123 týká se to Turrisu 1.x?
Pokud ano, tak jedině počkat na opravu a přinejhorším, pokud chcete aktualizace hned (a jste v nightly branch), tak to jedině vždy smazat, co Vám to napíše.
Mělo by se to týkat balíčků:

• Odstraněn balík mount-utils
• Odstraněn balík lsblk
• Odstraněn balík libmount
• Odstraněn balík getopt
• Odstraněn balík ethtool
• Odstraněn balík cfdisk
• Odstraněn balík lxc-create
• Odstraněn balík flock

Já vím, že když jsem smazal luci-app-lxc, tak mi to smazalo i to uvedené výše. Vždy když jsem něco smazal, tak jsem provedl opkg update.

Tak teď jsem to vyzkoušel ještě jednou.

opkg remove luci-app-lxc
opkg update
updater.sh

Updater.sh odinstaloval:

INFO:Queue removal of getopt
INFO:Queue removal of ethtool
INFO:Queue removal of lxc-create
INFO:Queue removal of flock

Systém aktuální. LXC neběží a nemůže, protože je odinstalované.

Při dalším pokusu o spuštění: opkg update a updater.sh to napíše:

WARN:Requested package ghostscript that is missing, ignoring as requested.
WARN:Requested package cfdisk that is missing, ignoring as requested.
WARN:Requested package lsblk that is missing, ignoring as requested.
WARN:Requested package mount-utils that is missing, ignoring as requested.
WARN:Requested package lxc-create that is missing, ignoring as requested.
WARN:Requested package luci-app-lxc that is missing, ignoring as requested.

Pro znovu zprovoznění je nutné znovu nainstalovat luci-app-lxc (ale hláška se bude vyskytovat)