No ipv6 gateway on lan side

Hello,

all computers connected on lan side have no ipv6 gateway defined. How can I change that?

ping6 tells me “no network available”, ping works.

What’s your network setup?

Cable Modem — Switch — Turris — Computer

I have no special setup, I’m using defaults. The network between Modem and Provider is ipv6 only, local computers have an 192.168.* ipv4 address.

This setup worked with Turris OS 3.*, now I have OS 5.

Some additional information:

uci show network

network.loopback=interface
network.loopback.ifname=‘lo’
network.loopback.proto=‘static’
network.loopback.ipaddr=‘127.0.0.1’
network.loopback.netmask=‘255.0.0.0’
network.globals=globals
network.globals.ula_prefix=‘fd95:a2e9:68c2::/48’
network.lan=interface
network.lan.type=‘bridge’
network.lan.proto=‘static’
network.lan.ipaddr=‘192.168.1.1’
network.lan.netmask=‘255.255.255.0’
network.lan.ip6assign=‘60’
network.lan.bridge_empty=‘1’
network.lan.ifname=‘lan0’ ‘lan1’ ‘lan2’ ‘lan3’ ‘lan4’
network.wan=interface
network.wan.ifname=‘eth2’
network.wan.proto=‘dhcp’
network.wan.hostname=‘turris’
network.wan.ipv6=‘1’
network.wan6=interface
network.wan6.proto=‘dhcpv6’
network.wan6.ifname=’@wan
network.guest_turris=interface
network.guest_turris.enabled=‘1’
network.guest_turris.type=‘bridge’
network.guest_turris.proto=‘static’
network.guest_turris.ipaddr=‘10.111.222.1’
network.guest_turris.netmask=‘255.255.255.0’
network.guest_turris.bridge_empty=‘1’

and

ip -6 a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 532
inet6 fe80::da58:d7ff:fe00:3d2e/64 scope link
valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 532
inet6 fe80::da58:d7ff:fe00:3d2c/64 scope link
valid_lft forever preferred_lft forever
4: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 532
inet6 2a02:908:5b0:4f00:da58:d7ff:fe00:3d2d/64 scope global dynamic noprefixroute
valid_lft 169198sec preferred_lft 82798sec
inet6 2a02:908:5b0:4f00::bdcf/128 scope global dynamic noprefixroute
valid_lft 59108sec preferred_lft 59108sec
inet6 fe80::da58:d7ff:fe00:3d2d/64 scope link
valid_lft forever preferred_lft forever
22: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
inet6 fd95:a2e9:68c2::1/60 scope global noprefixroute
valid_lft forever preferred_lft forever
inet6 fe80::6f0:21ff:fe23:3093/64 scope link
valid_lft forever preferred_lft forever
23: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
inet6 fe80::6f0:21ff:fe23:3093/64 scope link
valid_lft forever preferred_lft forever
24: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
inet6 fe80::6f0:21ff:fe24:d61/64 scope link
valid_lft forever preferred_lft forever

In my case I have to connect to a fibre modem via PPPoE but still I have the same “no IPv6 gateway” symptom. And I have left default network config apart from setting PPPoE credentials… I must admit I don’t really understand how IPv6 is managed in Turris OS and there seem to be different options. I am happy to do some investigations but a few clues would help :slight_smile:

network.wan6=interface
network.wan6.proto='dhcpv6'
network.wan6.ifname='@wan'
network.wan=interface
network.wan.ifname='eth0'
network.wan.proto='pppoe'
network.wan.ipv6='1'

You have no global IPv6 address on the LAN interface therefore there cannot be any IPv6 gateway. Your setup is default and depends on the upstream router to delegate IPv6 prefix for the LAN side. Cable modems are known to have problems with that. My guess is that the modem has a limit of just one DHCP-PD client and by upgrading TOS3 to TOS5, the cable modem thinks it is a different client and refuses to assign any prefix to it.

Try to look into the admin interface of the modem. Or maybe try to reboot it or perform a factory reset, if available.
You can also find some helpful information in the output of ifstatus wan6 command:

        "ipv6-prefix": [
                {
                        "address": "2001:db8:1234:5680::",
                        "mask": 57,
                        "preferred": 2341,
                        "valid": 5941,
                        "class": "wan6",
                        "assigned": {
                                "lan": {
                                        "address": "2001:db8:1234:5680::",
                                        "mask": 60
                                }
                        }
                }
        ],
1 Like

br-lan has no global ipv6 address and no ipv6-prefix. eth2 has a global ipv6 address which is the wan port.

On the modem side there is not much to configure for ipv6. But if you look at the ipv6 lan connection details, there is an interface named brlan0 (looks like br-lan) with the following configuration:

Interface IPv6 Global Addr IPv6 Link Local Addr
brlan0 2a02:908:5b0:4f00:422b:50ff:fee3:365e/59 fe80::422b:50ff:fee3:365e/59

IPv6 DHCP Addr Pool 2a02:908:5b0:4f00::/59
IPv6 Default Gateway fe80::201:5cff:fe9f:ba46/59
IPv6 DNS Servers 2a02:908:2:a::1/59

Could it be a naming conflict?

This means that IPv6 is available on the link between your modem and your router, but there is no IPv6 prefix delegated to the downstream interfaces of the router.

I don’t think it is a naming conflict. It’s just a coincidence that the cable modem calls its LAN bridge brlan0, that is more or less up to its vendor.

The configuration of the modem looks good. There may be some incompatibility between DHCP server in the modem and DHCP client (odhcp6c) in Turris router. Try to look at dhcpv6 communication during ifup wan6:

tcpdump -vv -npi eth2 port 546

Also see this similar issue on OpenWRT forum.

There are 4 packets (I can’t upload the pcap file). One response tells me that “Server support for prefix delegation is not enabled. Sorry buddy.” Does this mean that my Turris doesn’t get an ipv6-prefix from my cable modem?

Identity Association for Prefix Delegation
Option: Identity Association for Prefix Delegation (25)
Length: 83
Value: 000000010000000000000000000d00430006536572766572…
IAID: 00000001
T1: 0
T2: 0
Status code
Option: Status code (13)
Length: 67
Value: 000653657276657220737570706f727420666f7220707265…
Status Code: NoPrefixAvail (6)
Status Message: Server support for prefix delegation is not enabled. Sorry buddy.

Yes, that is exactly what it means. As I said before, if it worked previously, you can try to do some sort of factory reset of the modem so it forgets all the delegated prefixes and maybe it will be willing to delegate a new one afterwards.

This is a new cable modem. My previous provider was Unitymedia (where prefix delegation was no problem). They were bought by Vodafone and because of that I have this new modem. I will have a look into their forum to see if there is a solution.

This ticket is missing the information on what is the router manufacturer and/or branded reseller (e.g. Liberty Global, Vodafone), model, firmware and the country (EDIT: assuming DE, as Unitymedia is the Liberty Global brand in Germany) you are seeing it in (as the cable routers may have country-specific adjustments).

I have seen this with the Vodafone Station DOCSIS 3.1 router (see also this tweet, unfortunately the key message is in Czech), which is in fact an Arris TG3442VF/DE). There was no fix available at the time I tweeted the message - the router simply has buggy firmware, somebody at the firmware development company thought prefix subdelegation is not needed.

If this is the case, PLEASE request a fix from your ISP, or vote with your wallet that mandating crappy cable modems is an unacceptable practice.

(I have also seen other issues with the Compal router, like: prefix delegation available, but no more prefix available. In that case we had to perform a full HW reset (using a button on the router) and then eventually the subdelegation started to work. But that was a different case.)

The cable modem name is “Vodafone Station” and it’s manufactured by Arris as you say. There is no product number. Firmware version is 01.02.068.11.EURO.SIP.

I will have a look in Vodafone forum to see if anybody has already a ticket on this topic. If not I will open one. But I’m not confident to get a solution.

Thanks to everybody for your help until now.

I checked the forum of Vodafone: I’m not the only one having that problem.

Here are some options / workarounds:

  1. Change from private to business contract. No option because why should I pay more to get a ipv6 feature which is standard.

  2. Switch my modem into bridge mode. No option because Vodafone Station has no setting to do so.

  3. Change the provider. No option now because I have to switch from cable to telephone line where I could get 25 Mbit max.

  4. Buy an own cable modem. This could work because Vodafone seems to support it.

  5. Buy a LTE mini PCIe card and install it into my Turris Omnia. I tried this some time ago but I failed to get a card. Is there any hope nowadays?

My guess is that getting IPv6 prefix delegation from an LTE uplink would be almost impossible. So switching to LTE would probably not help.

Ok. Buying an own cable modem would be the best solution then.