No hard reset, no serial console, no u-boot - all 12 LED turn from green to red successively

I think I could need some advice or support, as I am at the end of my knowledge.

Hardware: Omnia CZ11NIC13, no hardware changed

What happened: I made a clean installation from the latest medkit - HBT 6.2.1 - which performed as expected. No issues and then I started to configure the router for a SFP VDSL modem.
Closing the configuration and restarting the Omnia … it restarted directly into the situation where the LED just turned from green to red one after another till all were red and the it started all over again.
A serial terminal , which I used to monitor the update process , froze, no change visible, no u-boot, no terminal output.
After a while I cut off power and restarted by inserting the power plug … but same behavior: No terminal,
I tried to stop the process, but the hard reset button has no effect whatsoever.
As the reset button does not work, non of the standard rescue procedures work.
I tried a serial boot, kwboot, but also not working, as the terminal does not respond anything.
My USB-TTL adapter is working just fine, I checked it on a banana pi without issues.

I fear, It could be the SPI flash, dead or corrupted, as there is no U-boot, no reset.
But should not at least there be a serial communication possible? I even did not touch u-boot during the update before.
How can this LED colour band work, if there is no firmware running? Is this the work of the STM32F030 mcu?
What does this actually mean?
I doubt, that is directly connected to the 6.2.1 turris os update, as there is no u-boot change, and there were no issues with u-boot reported for the new Turris os6 so far.
Any advice on how to rescue the router is appreciated, including components to be changed or programmed.

Hello, it seems to be a HW problem. Can you verify the reset button is not stuck and makes a clicking sound when pressed?

Does this happen when you remove the SFP module?

Thanks for your quick response!
Yes it looks like a hardware failure, in early boot stage probably… but where to look on the PCB for clues … I have no idea.
I dismantled the PCB already, no SFP module, no PCIe cards. Same behavior.
The reset button works just fine, multi-meter showed 3.3V signal voltage , with reset button pushed 0V.
I checked the PCB for burn marks, but nothing.
I looked into the schematics:

  • the Reset line NMANRES is directly connected from the switch SW2 to the reset input of the main CPU 88F8620 SYSRST_INn. (pg.2)
  • the LEDs and all peripherals are controlled by the mcu STM32F independent of main CPU over SPI with the help of the LED driver ICs STP16CPC26.STP16CPC26. (pg.15)
    Does this help? What can I do?

I made some further tests, with at least some results:

  • I changed the power supply to a new one from my NAS (12V/4A). It resulted in a normal boot after several trails.I had to wait at least 2-3 minutes and then a normal boot was possible.
  • A hard reset and a software reboot led to the former behavior of color changing LEDs and no reset is accepted through switch SW2. So after normal boot a Reset is possible, but not for the rescue modes. (?)
  • Even at normal boot, serial console is dead. So boot monitoring is not possible any more.
  • If I add peripheral components like USB stick or SFP module the router always goes into the LED changing state not accepting Reset.
    With this results I assume an issue with the power rail…
    The Reset and Reboot issue remain

Any suggestions?

Contact the support.